• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1851
  • Last Modified:

Excel zooms to 400% view when laptop is connected to projector

This problem occurs on a Dell Precision M70 laptop running Windows XP SP2 & Excel 2002 (Office XP).  The video card in this unit is an nVidia model, and the drivers have been updated to the latest rev as posted by Dell.

When docked or in standalone mode, performance is normal when using Excel or any other application.  However, when this laptop is connected to an Epson projector, the screen automatically zooms to 400% normal view when a cell is selected or the worksheet is scrolled.  No amount of toggling between the laptop display and the projector will reset the video back to the default.  The overall Windows desktop appears to take on a low-resolution, large size icon scheme when this problem happens in Excel.

The only 'fix' I've found thus far is to shut down cold, which will restore the laptop to it's normal display mode.

There is a similar posting in one of the forums for a PowerPoint problem, but I require more than a 'adjust the video settings' suggestion for a solution.

Thanks, and good luck.
0
mikeosb
Asked:
mikeosb
  • 4
  • 4
  • 3
  • +6
1 Solution
 
rbmacrossCommented:
The problem could be that the projector can not handle the video display settings of the laptop.  I suggest trying to reduce the display settings on the laptop to 800x600 and go up from there to see what works for you.
0
 
TheSipCommented:
i would try reinstalling excel if that doesn't work. if the problem persists call microsoft
0
 
moorhouselondonCommented:
Have you tried using the twin screen facility as a workaround?  (Or perhaps it is in two screen mode and can't handle it).  Setup the projector as the second screen and then move the spreadsheet onto it, see if that works.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
mikeosbAuthor Commented:
I can add that it doesn't matter whether the display is set to laptop only, projector only or both simultaneously.  Click a cell or scroll within Excel & you're toast.
0
 
moorhouselondonCommented:
The fact that the hangup occurs on clicking on an application indicates to me that this is a video driver problem.  (Yes I hear what you say - you have the latest version),

Have you tried slugging the video properties (number of colours, rbmacross has already suggested reducing the resolution)?  Does anyone here think that the version of DirectX currently loaded will make any difference?  (Excel does interact with DirectX)
0
 
scrathcyboyCommented:
start - programs -accessories - accessibility - magnifier.  Look at that for a moment, it is 400% magnification.

When the device driver for the projector installed, it was set as an "accesibility" device, and pickup up those settings.  Therefore, you need to get into the actual device driver for the projector and change those settings there.  Now this device drive MAY be acccessible through an Epson projector option (look for that in control panel, or go to start, settings, control panel, projectors, and look for it).  If you find, make those changes there.  If you cant find, right click My computer, properties, hardware device manager, find the porojector device, find the installed drivers for it, and change the settings for those drivers in the registry, start, run, regedit, search F3 for the projector name, fix there.

Normally, there is an application module to install for any device like a projector that lets you make these adjustments, you should not have to do it in the registry .. but alas, bad software ... sometimes you have to resort to the registry.
0
 
mikeosbAuthor Commented:
I agree with it most likely being a combination of resolution & driver settings, and the Accessibility options had crossed my mind too.  I hadn't thought about DirectX though since Excel isn't multimedia! The new nVidia driver does have a sync dual monitor settings function, so I'm keen to try that.  Once I can pry the unit away from the user (yes...it's one of those 'critical' issues where one can never have the unit away from the user long enough to flesh the problem out), I'll test all of these out & post my findings.  Thanks all.
0
 
moorhouselondonCommented:
Excel isn't multimedia - but it can make use of DirectX.  Look for instance at the Excel Easter Egg which makes use of DirectX.
0
 
NerdxCommented:
Dear mikeosb,

Does the screen size of 400% go up if you press the keys Fn + F8?

~ Nerd
0
 
NerdxCommented:
Have you tried reducing the magnification level using the projector remote? This is the only solution I've seem to come across... so far.

~ Nerd
0
 
NerdxCommented:
Another solution: Disable scrolling feature or Remove Intellipoint software

~ Nerd
0
 
mikeosbAuthor Commented:
Wonder of wonders, I may actually have a chance to work on this unit today if the user will part with it!

For Nerdx, the problem only occurs when the screen is scrolled or when a cell is selected.  Toggling the display (internal, external, both) doesn't seem to have an effect.
0
 
mikeosbAuthor Commented:
OK, here's some other symptoms & the actual solution.  I mentioned that this problem occurred in Excel, and that I had also seen a report of the same issue in PowerPoint.  In this case, opening PowerPoint and attempting to move the scroll bar while connected to the projector also produced a 400% zoom.  I took this one step further and also opened a Word doc under the same conditions, and when I tried to scroll the document it zoomed to 500% magnification.

Here's the solution - the only video setting that I changed that made any difference was the default font size under Advanced Properties.  Instead of the default setting of Small 96 DPI fonts or Large 120 DPI fonts, the user had enabled an odd size of 152 DPI, which apparently MS-Office can't deal with under these conditions (internal & external displays).  I tested with resolutions up to 1920x1024 (nVidia custom res) at both 96 DPI & 120 DPI, and the display never hiccuped once.

Thanks for the input, and I wish that I had a clear-cut winner to award the points to.  I wonder if Experts-Exchange will refund my 10 bucks? :-)
0
 
NerdxCommented:
Nice find, mikeosb. I had been looking for a solution to this problem for you for ages. I also found that many other people were encountering this same problem and also couldn't find a fix.

Good work!

P.S: Why not become an expert?

~ Nerd
0
 
DarthModCommented:
PAQed with points refunded (500)

DarthMod
Community Support Moderator
0
 
brwillis1Commented:
mikeosb stated that the solution was "the only video setting that I changed that made any difference was the default font size under Advanced Properties.  Instead of the default setting of Small 96 DPI fonts or Large 120 DPI fonts, the user had enabled an odd size of 152 DPI, which apparently MS-Office can't deal with under these conditions (internal & external displays)."
 However, I have tested that on several different models of Dell Precision and Latitude laptops and could not get the same results.  Instead I got rid of our "Excel zooms to 400%" problem by removing Microsoft "Intellitype" software.  After removing Intellitype and rebooting, the zooming problem goes away even after pressing Fn-F8 to change the display/projector mode. (I can re-install Intellitype and the problem will re-appear).
Mikeosb's solution may have worked in his instance, but I have also tested and verified that Intellitype also is a culprit that causes Excel to zoom to 400% after pressing Fn-F8. (Nerdx came close to the solution when he mentioned removing Microsoft "Intellipoint" software ("Intellipoint" is for Microsoft mouse, "Intellitype" is for Microsoft keyboards)
 
0
 
TrelleborgCommented:
I know this is dead but i just had the same problem yesterday, for the second time.  The first time it happend a long time ago, I swapped out the users keyboard and mouse from Microsoft ones to Logitech ones, removing Intellitype/point, and installed Logitechs drivers.  this fixed the issue for no reason I can figure.  So yesterday the problem came back with a different user.  So my question is...  Is there Microsoft Intellitype or Intelliprint installed?  I just uninstalled the bloated Intelli drivers, and let Windows automatically use default generic keyboard and mouse drivers.  This does turn off the functionality of some fancy keyboard buttons, but most standard users do not use those anyway.  Hope this helps.  
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 4
  • 4
  • 3
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now