Outlook RPC over https instead of TCP/IP even when in office

Hi,

I'm sure this is a very simple one and I'm just overlooking something. Have set up RPC over HTTPS for a number of clients with no problem. My issue, embarrasingly enough, relates to myself. I have established RPC over HTTPS for my own Outlook and SBS2003 server. Problem is even when I am in the office on our LAN, my Outlook is trying to connect using HTTPS instead of TCP/IP. Any one have an idea why this is so?

I have tried ticking and unticking "On slow/fast Networks, connect using HTTP first, then connect using TCP/IP" to no avail.
Settings are: Connect using SSL only / Mutually authenticate session / Basic Authentication

HTTPS connection is working fine, but can no longer connect with TCP/IP. Any help would be appreciated.
LVL 1
lukerussellAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
So, I take it you have a laptop?  
Was that laptop joined to the domain using http://<servername>/connectcomputer?  
Is it currently using DHCP to acquire it's network settings?

Jeff
TechSoEasy

0
lukerussellAuthor Commented:
Hi, Jeff. and thanks for the response.

The laptop is not actually on the domain. I take it to clients all the time, so I found it easier to keep the laptop on a workgroup and not on the domain.

And yes, we are using DHCP, although the server is not our DHCP server - the router is... Actually, you have me thinking, now. I did an nslookup on my laptop and it looks as if DNS is not properly configured. (I guess we are using WINS in the office). I should probably make the server our DHCP server - that should solve the DNS problem. Do you think that could be contibuting to the problem?

Strange that it works fine over TCP/IP until you add the HTTPS info in the mail configuration, then it defaults to HTTP. We still have a few people in the office running normal TCP Outlook without a problem...
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Exchange uses WINS... so that would be your problem.  You can work around not using WINS, but it's part of the default configuration of SBS, and I wouldn't mess with that.

It's not strange at all that it works fine over TCP/IP because it's actually resolving with WINS. (http://support.microsoft.com/kb/837391)

You definitely want to get DHCP running on the SBS.  it configures about 5 or 6 network settings that are crucial to your environment's stability.  I don't completely understand why you would want to keep your laptop in a workgroup... just because you go to client sites shouldn't make a difference unless you've configured them with similar IP subnets.  You should always do yours differently, by the way.  Since the recommended subnet for SBS is 192.168.16.0/24, I have mine set at 192.168.96.0/24 so there aren't any IP conflicts when I VPN to my clients either.

Jeff
TechSoEasy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lukerussellAuthor Commented:
hey, Jeff - yeah, configured DNS and all is good.

Cheers
0
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
cool!

Jeff
TechSoEasy
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.