Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 672
  • Last Modified:

Procedure successful when using dbms_job, but fails in a shell script

I have a procedure which is throwing the following error when run from a shell script. This procedure completes successfully when run using dbms_job

ORA-00164 distributed autonomous transaction disallowed within migratable distributed transaction
0
MohanKNair
Asked:
MohanKNair
1 Solution
 
actonwangCommented:
ORA-00164:      distributed autonomous transaction disallowed within migratable distributed transaction
Cause:      A request was made by the application to start a distributed autonomous transaction when the application was in a migratable distributed transaction.
Action:      Roll back or commit the current distributed transaction first.
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now