Help With Network Configuration

Hi all, I have recently purchased SBS 2003 and a Dell Power Edge 830 Server.  I successfully connected a client PC to the server through a switch (192.168.16.1) by manually assigning IP addresses to each machine (192.168.16.2 and .3) in TCPIP and putting the Server IP in the DNS Code of the Client PC and running the setup wizard through the browser.  However, I now want to connect my router to the switch to share a boadband connection.  I have changed to IP address of the router 192.168.16.4 but I cant share the connection on the network.  I can only share a connection if I switch on DHCP with the Router and Switch and set each machine to automatically find an IP address.  Can anyone help me with my network settings please.  Here my current settings after enabling DHCP

 SERVER
Host Name .............: HECSERVER
Primary Dns Suffix.....: hecprecision.local
Node Type..............: Unknown
IP Routing Enabled.....: Yes
WINS Proxy Enabled.....: Yes
DNS Suffix Serach List.: hecprecision.local

Connection-specific DNS Suffix....: hecprecision.local
DHCP Enabled......................: Yes
Autoconfiguration Enabled.........: Yes
IP Address........................: 192.168.16.6
Subnet Mask.......................: 255.255.255.0
Default Gateway...................: 192.168.16.4
DHCP Server.......................: 192.168.16.4
DNS Servers.......................: 192.168.16.4
Primary Wins Server...............: 192.168.16.2


SWITCH
IP Address........................: 192.168.16.1
Subnet Mask.......................: 255.255.255.0
Default Gateway...................: 192.168.16.6
   
manhoodoAsked:
Who is Participating?
 
pseudocyberCommented:
Are you router and switch one box - integrated?  Or two seperate boxes?  I can't tell from your question.  What make and moel is it (are they)?

Do you want to use static addressing or DHCP?  You set everything up statically, and then you turned on DHCP?  Pick either or.  In any case, you can only have ONE DHCP server on the network - either your router (a SOHO router) or the server.

You're using SBS - do you want all Internet connections to go through it and then to the Internet?  Or do you want to use the router for Internet Sharing?

Using static addressing and going through a router should be no problem at all.  You would just set up the inside network on the router, the inside IP, and turn off DHCP.  After that, the router should not care wether the IP was dynamically assigned or not.
0
 
manhoodoAuthor Commented:
Just to clarify when I switch on DHCP my server client connection dont work anymore...
0
 
manhoodoAuthor Commented:
Here are the Client Details......

CLIENT
Host Name .............: HECSERVER
Primary Dns Suffix.....: hecprecision.local
Node Type..............: Mixed
IP Routing Enabled.....: No
WINS Proxy Enabled.....: No
DNS Suffix Serach List.: hecprecision.local

Connection-specific DNS Suffix....: hecprecision.local
DHCP Enabled......................: Yes
Autoconfiguration Enabled.........: Yes
IP Address........................: 192.168.16.7
Subnet Mask.......................: 255.255.255.0
Default Gateway...................: 192.168.16.4
DHCP Server.......................: 192.168.16.4
DNS Servers.......................: 192.168.16.4
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
Jay_Jay70Commented:
Hi manhoodo,

you need to set your ISP's DNS addresses as forwarders under your DNS properties, you the need to configure your DNS settings to look to itself for Resolution, make sure the gateway is set to the IP of the router
0
 
manhoodoAuthor Commented:
so should I switch of DHCP and go back to manual IP configuration?  And then enter the ISP DNS in DNS Properties?
0
 
manhoodoAuthor Commented:
Ok, My equipment is a BT Voyager 220V ADSL Router and Dell Power Connect 2716 16 Port Switch.  I would like to go for static IP addressing, so I will now turn off DHCP on all devices.  I would also like to use the router for internet sharing, and not go through the server.  Should I now enter again the IP's in TCPIP manually???

Thanks a mil

Ollie
0
 
pseudocyberCommented:
Yes.  You would enter the IP's, the mask, the default gateway, and the DNS address of your DNS server, if you have one internally - if not, then use your ISP's.
0
 
manhoodoAuthor Commented:
the default gateway would be the router IP, and the DNS would be the Server IP?
0
 
pseudocyberCommented:
Yes.  IF you have your DNS set up to forward to your ISP's DNS.
0
 
Jay_Jay70Commented:
sorry, i was watching the footy, pseudocyber nailed it
0
 
manhoodoAuthor Commented:
Hi Guys, I have now manually configured IP's and I have the Server and Client PC comunicating Ok and The server has Internet Access from router.  However, the Client PC does not.  here are my new network settings.....

SERVER
Host Name .............: HECSERVER
Primary Dns Suffix.....: hecprecision.local
Node Type..............: Unknown
IP Routing Enabled.....: Yes
WINS Proxy Enabled.....: Yes
DNS Suffix Serach List.: hecprecision.local

Connection-specific DNS Suffix....: hecprecision.local
DHCP Enabled......................: Yes
Autoconfiguration Enabled.........: Yes
IP Address........................: 192.168.16.2
Subnet Mask.......................: 255.255.255.0
Default Gateway...................: 192.168.16.4
DHCP Server.......................: 192.168.16.4
DNS Servers.......................: 194.72.65.68
                                  194.72.9.38
Primary WINS Servers..............: 192.168.16.2


CLIENT
Host Name .............: OLLIEMANHOOD01
Primary Dns Suffix.....: hecprecision.local
Node Type..............: Mixed
IP Routing Enabled.....: No
WINS Proxy Enabled.....: No
DNS Suffix Serach List.: hecprecision.local

Connection-specific DNS Suffix....:
DHCP Enabled......................: No
IP Address........................: 192.168.16.3
Subnet Mask.......................: 255.255.255.0
Default Gateway...................: 192.168.16.4
DNS Servers.......................: 192.168.16.2

ROUTER
IP Address...........................: 192.168.16.4

I have noticed that DHCP is still enabled on my server.  Do i need to switch it off?

Please help.....

Thanks

Ollie








0
 
pseudocyberCommented:
On a pc which can't get to the Internet, try making the SBS server the default gateway - change the DFGW IP to the Server IP and try it.  Just curious.  Wondering if you've got your modem/router setup in bridge mode and you're supplying the SBS server with the outside IP instead of the router.
0
 
manhoodoAuthor Commented:
Just tried that, but no joy.  Again its connected to the server perfectly, but no internet....

Just to confirm, the ISP DNS codes are in the TCPIP DNS Settings on the server yeah?
0
 
pseudocyberCommented:
Ok.  Will assume it can ping itself, gateway, and server.

On the problem pc, type ipconfig /flushdns to clear the dns cache.
Then, do an nslookup www.cisco.com.  You should get the IP of:
Non-authoritative answer:
Name:    www.cisco.com
Address:  198.133.219.25

Then do a tracert to 198.133.219.25.

You should be able to go past the router to the Internet.

If not, you need to get on the router and check the config.  Ideally, it would have an ARP table which would show the pc's MAC and IP, but this is seldom the case with a SOHO router.
0
 
manhoodoAuthor Commented:
The DNS flush worked fine.
The nslookup and tracert both came back with a 'DNS Request Timed Out'

I'll take a look at the router settings....
0
 
vertex_paulCommented:
Change your DNS on the client machine to match that of the server:

SERVER
Connection-specific DNS Suffix....: hecprecision.local
DHCP Enabled......................: Yes
Autoconfiguration Enabled.........: Yes
IP Address........................: 192.168.16.2
Subnet Mask.......................: 255.255.255.0
Default Gateway...................: 192.168.16.4
DHCP Server.......................: 192.168.16.4
DNS Servers.......................: 194.72.65.68
                                 194.72.9.38
Primary WINS Servers..............: 192.168.16.2

CLIENT
Connection-specific DNS Suffix....:
DHCP Enabled......................: No
IP Address........................: 192.168.16.3
Subnet Mask.......................: 255.255.255.0
Default Gateway...................: 192.168.16.4
DNS Servers.......................: 192.168.16.2                      <-------------------   Change this to 194.72.65.68  and 194.72.9.38
0
 
rickyclourencoCommented:
do you have a STATIC IP from your ISP?

if you do have a STATIC IP...then all you have to do is either:  

1.  Configure the SBS Server as a DNS server, setup forwarding, and configure the clients DNS to point to the SBS server for DNS requests
http://support.microsoft.com/?scid=http%3a%2f%2fwww.support.microsoft.com%2fkb%2f172953%2fen-us%2f
http://support.microsoft.com/default.aspx?scid=kb;en-us;814591

or

2.  This is probably easier, but, all you have to do is, For the DNS put the: 194.72.65.68 and 194.72.9.38 and for the Gateway: 192.168.16.4(router)
0
 
manhoodoAuthor Commented:
I Placed both the server and router IP's in the 2 DNS fields and its worked....

Thanks for all your help.

Ollie

0
 
pseudocyberCommented:
You're welcome.  Thanks.  :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.