[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Pix 506e VPN tunnel and remote client ipsec access

Posted on 2006-05-24
4
Medium Priority
?
1,061 Views
Last Modified: 2013-11-16
I have a Pix 506e with a VPN tunnel connecting to a VPN3005 concentrator, which is working fine.  I am also trying to set up the Pix to serve ipsec clients using the Cisco VPN Client.  The VPN Client is not working, and I am wondering if it is even possible for the Pix to perform both of these functions at the same time.

The Pix is running 6.3(5) and the Cisco VPN Client is version 4.8.01.0300.

In case this is possible, and I am just not doing it right, I have included my Pix config.

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname ourhostname
domain-name ourdomain.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 100.100.100.100 vpn-3005
access-list from-outside permit icmp any any echo-reply
access-list split-tunnel-acl permit ip 10.100.1.0 255.255.255.0 172.100.1.0 255.255.255.0
access-list to-hq-vpn permit ip 10.100.1.0 255.255.255.0 10.1.0.0 255.255.0.0
access-list to-hq-vpn permit ip 10.100.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list to-hq-vpn permit ip 10.100.1.0 255.255.255.0 172.16.0.0 255.255.0.0
access-list to-hq-vpn permit ip 10.100.1.0 255.255.255.0 10.226.219.0 255.255.255.0
access-list no-nat permit ip 10.100.1.0 255.255.255.0 172.100.1.0 255.255.255.0
access-list no-nat permit ip 172.100.1.0 255.255.255.0 172.100.1.0 255.255.255.0
access-list no-nat permit ip 10.100.1.0 255.255.255.0 10.226.219.0 255.255.255.0
access-list no-nat permit ip 10.100.1.0 255.255.255.0 172.16.0.0 255.255.0.0
access-list no-nat permit ip 10.100.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list no-nat permit ip 10.100.1.0 255.255.255.0 10.1.0.0 255.255.0.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 200.200.200.200 255.255.255.255
ip address inside 10.100.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn-pool 172.100.1.20-172.100.1.50
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no-nat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group from-outside in interface outside
route outside 0.0.0.0 0.0.0.0 200.200.200.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa-server ms-ias protocol radius
aaa-server ms-ias max-failed-attempts 3
aaa-server ms-ias deadtime 10
aaa-server ms-ias (outside) host 10.100.1.10 ******** timeout 5
http server enable
http 192.168.0.0 255.255.255.0 inside
http 10.0.0.0 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set hq-set esp-3des esp-md5-hmac
crypto ipsec transform-set vpn-set esp-aes esp-sha-hmac
crypto dynamic-map dynmap 20 set transform-set vpn-set
crypto map ourmap 10 ipsec-isakmp
crypto map ourmap 10 match address to-hq-vpn
crypto map ourmap 10 set pfs group2
crypto map ourmap 10 set peer vpn-3005
crypto map ourmap 10 set transform-set hq-set
crypto map ourmap 20 ipsec-isakmp dynamic dynmap
crypto map ourmap client authentication ms-ias
crypto map ourmap interface outside
isakmp enable outside
isakmp key ******** address vpn-3005 netmask 255.255.255.255
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption aes
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup ipsec-group address-pool vpn-pool
vpngroup ipsec-group split-tunnel no-nat
vpngroup ipsec-group idle-time 1800
vpngroup ipsec-group password ********
telnet 192.168.0.0 255.255.0.0 inside
telnet 10.0.0.0 255.0.0.0 inside
telnet 172.16.0.0 255.255.0.0 inside
telnet timeout 5
ssh timeout 5
management-access inside
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe auto
vpdn group 1 client configuration address local vpn-pool
vpdn group 1 client configuration dns 10.100.1.10
vpdn group 1 client authentication aaa ms-ias
vpdn group 1 pptp echo 60
vpdn group ipsec-group client configuration address local vpn-pool
vpdn username vpnuser password *********
vpdn enable outside
dhcpd address 10.100.1.101-10.100.1.150 inside
dhcpd dns 11.11.11.11
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain ourdomain.com
terminal width 80
Cryptochecksum:a953fde9e97b3df8fd39899f3fc5f802
0
Comment
Question by:BRNIIT
  • 3
4 Comments
 
LVL 9

Accepted Solution

by:
stressedout2004 earned 1000 total points
ID: 16753015
Make the following changes:

no access-list no-nat permit ip 172.100.1.0 255.255.255.0 172.100.1.0 255.255.255.0
no vpngroup ipsec-group split-tunnel no-nat
vpngroup ipsec-group split-tunnel split-tunnel-acl
isakmp nat-t

Also, with regards to the following line:

aaa-server ms-ias (outside) host 10.100.1.10 ******** timeout 5

Your IAS server has the IP of 10.100.1.10, as far as the PIX is concern, that is on the inside network not the outside. So you should change it to:

aaa-server ms-ias (inside) host 10.100.1.10 <preshared key> timeout 5

If the VPN client still fails to connect. Enable the following debug on the PIX and post the output:

debug crypto isa
debug crypto ipsec

0
 
LVL 9

Expert Comment

by:stressedout2004
ID: 16753028
BTW, the PIX can perform both site to site and remote access at the same time.
0
 

Author Comment

by:BRNIIT
ID: 16753247
stressedout2004-
Thank you very much - your suggestion worked perfectly.  If you don't mind, can you explain the isakmp nat-t statement?  I am still new at Pix stuff, and I would like to understand what that statement is doing.

Thanks again.
0
 
LVL 9

Expert Comment

by:stressedout2004
ID: 16755291
The isakmp nat-t allows the user using the VPN Client to be able to connect and pass traffic over the tunnel when the user is connecting from a PAT device. When you say PAT, it means that there is more than one user using  the same public IP address.
0

Featured Post

Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
On Feb. 28, Amazon’s Simple Storage Service (S3) went down after an employee issued the wrong command during a debugging exercise. Among those affected were big names like Netflix, Spotify and Expedia.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month19 days, 22 hours left to enroll

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question