IIS sub directory access restriction

How do I restrict access to an IIS sub-directory to web user log-in clients only?  The following url should be password restricted, but is currently acessible to all:
http://www.nsia.ca/forms/advanced.pdf
The forms sub directory currently has the following settings:
Sharing tab - Do not share this folder
Security tab - only Administrators (Server) is listed as a group name (removed Everyone)
Should we set up this sub-drectory as a virtual directory instead of real directory?
THX
Geo
GeorgeJacobsonAsked:
Who is Participating?
 
kevp75Connect With a Mentor Commented:
you can't....google has cached it, and will have to wait until the next time google indexes the site
0
 
kevp75Commented:
i've found that NTFS security settings override IIS security.

if you right click on the folder in IIS, you should be able to restrict the access.  If not, try right clicking the folder in Explorer, go to properties, then the security tab
0
 
VAScottCommented:
in IIS, right click the folder > properties > directory security tab > click the edit button under anonymous access and authentication control.  Un-check anonymous access and then setup your access control in the bottom part (domain, NT, etc...)
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
GeorgeJacobsonAuthor Commented:
How is this done in Windows Server 2003?
THX
Geo
0
 
GeorgeJacobsonAuthor Commented:
In IIS right click the folder Directory>Directory Security>Edit> -uncheck Enable Annonymous Access

Note if I google a form that has been accessed, it still shows up as an html version, how to clear this?
thx
Geo
0
 
GeorgeJacobsonAuthor Commented:
thx alot!  Any idea how often (ie how long) Google indexes sites?
Geo
0
 
kevp75Commented:
honestly not too sure.  I have 3 sites getting indexed now, but I submitted them almost a month ago.

I believe if you submited them, you should be able to login to your account with them and re-submit, this may re-start the indexing cycle
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.