Mac Can no Longer Connect to one of our servers

Posted on 2006-05-24
Last Modified: 2013-11-13
We are running Active Directory on Windows 2003 R2. We are running Mac OS X. We have bound our macs to the domain using the Directory Access utility. This was all working fine until one day all of our macs suddenly couldn't connect to a particular server that they were able to connect to before. They are being authenticated on our domain controller, but are being denied access to a shared folder that any PC user can access. If these same users jump onto a terminal server, or a PC, they can access the folder without a problem. Below are the error messages I get from the Mac console when I try to access the share. Oh also, when I try to access the share, it does ask for a username and password. I've even typed in the administrator username and password, but it doesn't matter. If we try to access this folder from a share, we get denied permission.

mount_smbfs: error from NetrShareEnum call: exception = 382312522
mount_smbfs: tree connect phase failed: syserr = Permission denied
mount_smbfs: could not login to server MCKDATA: syserr = Permission denied
Question by:mckeough
    LVL 6

    Expert Comment

    Two options to try:

    1. Allow the mac to send clear text passwords, explaind here:

    2. Allow your Windows machine to accept packets that are not digitaly signed
    Change this key at the server to 0

    LVL 3

    Expert Comment

    Did you by any chance upgrade the server just before the problem happened.

    You may want to download a trial of ADmitMac and try that. It sorts out incompatablilty problems with Mac/Windows Server.


    Author Comment

    No. We didn't perform any upgrades to ther server. It's already a brand new box, but everything was working. We have another program we might try. It looks like the server doesn't think that our macs are using a secure enough protocol.
    LVL 3

    Accepted Solution

    If the server thinks that, then the problem is most probably the fact that Macs use an older version of Samba I think. This is solved by using Shareware Apps such as DAVE and ADmitMac.


    Author Comment

    Well I can't say that this fixed the problem because we worked around this, but the best comment here is probably from gileze33 and his comments about DAVE and ADmitMaC.
    LVL 51

    Expert Comment

    by:Keith Alabaster
    Thank you for the response. Do you wish to accept the answer you have indicated?

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Find Ransomware Secrets With All-Source Analysis

    Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

    SUMMARY Enterprise backup in a heterogeneous network is a subject full of complications and restrictions. Issues such as filename & path structure, attributes and extended metadata always tend to complicate the subject to the extent where either …
    In this article we will discuss some EI Capitan Mail app issues and provide some manual process to resolve them.
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    This video discusses moving either the default database or any database to a new volume.

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now