Resolution Problem with Multiple NIC's

Posted on 2006-05-24
Last Modified: 2010-03-19
Hi, I'm new to the Forum so I'll explain this the best I can.

I have a couple servers that I'm trying to configure on a separate VLAN for backup purposes.  The majority of these server have at least 3 NIC's installed: 2 that are teamed with a 10.0.31.x address, which is plugged into a standard 10/100 port on our switch, and the third acting as the backup NIC with an address of 10.0.91.x, which is plugged into a Gig Port on the switch.  The problem is, whenever I ping from any other machine in the network, I hit the machine's .31.x address, but, if I'm on that specific machine and ping the machine name, it resolves as the .91.x address.  I'm experiencing intermittent problems, such as email spontaneously not sending/receiving, servers locking up, and service failures (web, etc) since assignment.

Solutions I've tried:
All the servers have manual entries in DNS and I've also tried entering either the .31.x address or the servers assigned private IP (192.168.100.x) into the hosts file, but with no luck.

Is there a priority assignment for Addresses with faster connections within windows?  I've googled this for a couple days off and on and haven't found any possible resolution.

This website is the best resource I've found for solutions to problems, so... thanks in advance.
Question by:david_sims
    LVL 7

    Expert Comment

    What operating system?
    LVL 10

    Expert Comment

    What protocols are enabled on the LAN? you may want to "disable Netbios over TCP/IP" on the interfaces and try again.

    Author Comment

    OS: Either Windows 2000 Advanced Server or Server 2003 Enterprise (mixed environment).  I meant to include that, by the way...

    I should also mention that Default Gateway and Static DNS Entries are assigned to the .31.x or private IP, but no Default Gateway or DNS entries are assigned under TCP/IP Properties for the .91.x addresses.

    Only IP protocols are enabled over the LAN, no NetBios or IPX.

    Thanks for the quick response guys...
    LVL 77

    Accepted Solution

    It might help to check/change the binding order. To do so go to:
    Control panel | Network Settings | Advanced (on the menu bar) | advanced settings | Adapters and Bindings

    Author Comment

    Thanks, RobWill... you da man!
    LVL 77

    Expert Comment

    by:Rob Williams
    Thanks David
    Good luck,

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Let’s list some of the technologies that enable smooth teleworking. 
    Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
    Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    8 Experts available now in Live!

    Get 1:1 Help Now