Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 425
  • Last Modified:

Mailbox Management not deleting emails Exchange 2003

I have setup our exchange server to delete all email older than 180 days from users Inbox, Sent Items and Deleted Items.  I have set the schedule for every Saturday night at 12:00 AM.  Users receive an email that email have been deleted but their inboxes still have email dating back to 2004.

Help
0
kapara
Asked:
kapara
  • 2
1 Solution
 
ajj1Commented:
have you got a filter applied at all in the policy? are there any other reciepient polices on the server?
are you running any other backup or maintenance procedures at that time? is anything reported in the event logs?


AJJ
0
 
kaparaAuthor Commented:
The policy is the default policy which has not been customized.  There are no other recipient policies.  
Filter Rule:  (mailnickname=*)  They get emails saying mail has been deleted but still have mail much older than the settings and I verified that it is supposed to delete instead of just reporting.  There should not be any other process at that time.
0
 
abhi_akCommented:
Hello ,
Please check the below mentioned links they explain in detail on how the mailbox manager policy calculates the age.

http://msexchangeteam.com/archive/2004/08/17/215807.aspx

http://support.microsoft.com/?id=326397

Please let me know if u need the hotfix in 326397

also let me know if there is anything else u need.

Regards,
Abhijeet Kulkarni
0
 
abhi_akCommented:
Hello,
You can also follow the the below steps to change the way exchange tackels the msExchMailboxManagerAgeLimit

You can find the msExchMailboxManagerAgeLimit attribute by opening the configuration container in adsiedit.msc and getting properties on the relative mailbox manager policy object:

CN=%name_of_policy%,CN=Recipient Policies,CN=%orgname%,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=tree,DC=exchadmin,DC=com

When you set a value of 1, you can expect the following behavior:
We ignore the modified date property on messages and delete messages whose delivery and submitted date property exceed the age limit that is set by the policy setting.

When you set a value of 2, you can expect the following behavior:
We ignore the submitted date property on messages and delete messages whose delivery and modified date property exceed the age limit that is set by the policy setting.  

When you set a value of 3, you can expect the following behavior in Exchange 2000 Server: (Exchange 5.5 behavior)
We ignore both the submitted and the modified date properties on messages and delete messages whose delivery date property exceeds the age limit that is set by the policy setting.  

So if you want to ignore both the submitted and the modified date and want the policy to directly delete the message after 180 days then you can set the value of 3 for this attribute.

Please do let me know weather this helps. :)

Regards,
Abhijeet Kulkarni
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now