• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3253
  • Last Modified:

error generating wsdl from java file using eclipse web services toolkit.

I am quite new to web services and seem to have run into an issue that I
hope some of you can give me an idea on how to debug.

Firstly I started out with installing the eclipse and web services plugins.
My eclipse version is 3.1.1  and for web services I have the web standard
tools feature version 1.0.0 which I installed off of the
wtp-all-in-one-sdk-1.0-win32 .zip file

I have run through  all the initial tutorials for farenheit to celcius
conversions using the wtpconverter example and this works just fine. i.e I
am able to access the temperature units converter as a web service and see
the right output.

I now have a class called RuleCientDB which has a method called executeRule.
It would like to expose this class and method as a webService. But havent
succeeded in doing so.

The two parameters are String and an object.
executeRule("Const_Boolean_True" , null );


When I run it through the process I get the following errors.



IWAB0398E Error in generating WSDL from Java
java.lang.ClassNotFoundException: RuleClientDB



Any ideas why I may be getting this error ? What should I attempt to do ?

Would this have anything to do with the parameters that I pass to
executeRule. The signature of executeRule is as follows executeRule(String,
Object)

Are there issues when passing objects to web services ? ANy workarounds ?

Could this be a eclipse configuration issue ?

Would appreciate all the suggestions I can get.

Thanks and Regards,

MN

0
mrnmrn
Asked:
mrnmrn
  • 2
2 Solutions
 
objectsCommented:
make sure your class is in a package
0
 
Mayank SAssociate Director - Product EngineeringCommented:
Try using WSDL2Java from Apache (it has an Eclipse plugin too)
0
 
mrnmrnAuthor Commented:
Apparently the answer is to restart . It seems like a eclipse bug and according to the newsgroups it is related to timing.
I hate to be stingy especially since this was my first post. I tried the give the above two folks half the points each. But the system wont let me do that without specifying someone's answer as right.
thanks anyways guys.
0
 
Mayank SAssociate Director - Product EngineeringCommented:
You can do that by selecting the "Split Points" section and select one of them as the 'Accepted answer'. However, if you found the solution yourself, request in Community support for a delete/ refund of points.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now