• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 192
  • Last Modified:

2 Exchange 2003 Servers in One Domain, Old Exchange Server not routing to New Exchange Server...

Dear Experts:

First let me start with: I have read every post in EE and also googled till I can google no more about my problem.

Here is the environment:

Windows 2003 Domain with SP1 (from Day 1)
Exchange 2003 Enterprise w/OWA enable with forms with SP2 (from Day 1)
New Exchange 2003 Standard with SP2 (just installed last week)
We are not using a Front End Exchange Server

We installed the new Exchange server in the same domain as our other Exchange server and is located in the same building and same network.  We have no smart host entries in either Exchange SMTP Advanced Tab (seen this posted a lot as a major cause.).  

You can telnet between the servers using:
telnet SERVERNAME 25
telnet IP 25
telnet FQDM 25

The new Exchange will route email to the old Exchange where all other users are located (except my test I have on the new one) and also out of the network as it should.   But the old Exchange will not route email to the new Exchange (where I have the one test mailbox).

When I move the mailbox back to the old server, it works great.  When I move it to the new server, it doesn't receive any email.

The SMTP Queue of the old server does show email ready to be delivered to the new server, yet it just sits in the SMTP queue.  

Here is one catch: I can restart the server and as soon as it is up, it will release the email to the new Exchange server that it is currently holding (which made me happy the first time it did it thinking I solved it.)  Then if you send another email to that mailbox user on the new Exchange server, the email again will sit in the STMP queue (restarting the server every minute possibly isn't the best solution, ha, ha!).

Both servers are in the same routing group.  The orginal server is listed as Master and the new one is listed as Member.

Can some please help me figure out why the old Exchange 2003 server will not route email to the new Exchange 2003 server?  What could I be missing?

Thanks,

Micky
0
mickythompson
Asked:
mickythompson
  • 7
  • 5
1 Solution
 
aa230002Commented:
Increase the diagnostic logging on MSExchangeTransport and MSExchangeIS on the old server and see if you see some errors or warnings in the Application logs.

Do you see anything strange when you track this message using Message Tracking center?

Do you see Public Folder hierarchy getting replicated from your old server to the new server?

Thanks,
Amit Aggarwal.
0
 
aa230002Commented:
Public Folder replication (hierarchy replication and Content  replication) is also email based in Exchange. So, if your emails are not flowing fine between two servers, you should be facing problem with Public Folder replication.

Use this KB to troubleshoot PF replication (its always recommended to replicate public folders to new server before moving your mailboxes so that users dont face any problem with public folders after migration to new server)

How to troubleshoot public folder replication problems in Exchange 2000 Server and in Exchange Server 2003
http://support.microsoft.com/kb/842273/en-us

The troubleshooting steps in this KB will help you solving the mail flow issues between your old and new server.

Thanks,
Amit Aggarwal.
0
 
mickythompsonAuthor Commented:
Thank you Amit.

I increased the diagnostic logging on MSExchangeTransport and MSExchangeIS.  Nothing has showed up in the event log.  Everything is clean.

Also the public folders have replicated to the new never and I can access them.

Would you have anything else I could try?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
aa230002Commented:
what happends When you manually try to send a mail to the new server using command line - Telnet SMTP port 25?

Do you see anything in the Message tracking center?
0
 
aa230002Commented:
is your new Exchange server 2003 SP2 running on Windows server 2003? if yes, do you have SP1 applied on Windows Server 2003?

Is there anything in the "Outbound security" - SMTP virtual server properties on the old server - Delivery tab?

0
 
aa230002Commented:
Try this ->
you have increased the diagnostic logging on MSExchangeTransport, now try to send a new message. once it gets stuck in the queue, track the message, try to do the force connection on this queue, check the application logs. Still, if its clean.
Just restart the SMTP virtual server, instead of rebooting the server itself and see if it gets delivered.

Thanks,
Amit Aggarwal.
0
 
aa230002Commented:
Next step would be to enable the logging on SMTP protocol -->
1. Start Exchange System Manager.  
2. Expand Servers\Your_ Server_Name\Protocols\SMTP.
3. Right-click SMTP Virtual Server, and then click Properties.  
4. On the General tab, click to select the Enable Logging check box.
5. In the Active Log Format list, click W3C Extended Log File Format.  
6. Click Properties.
7. On the General Properties tab, click the log schedule that you want to use under New log schedule.
8. In the Log file directory box, type the path where you want to keep the log files.  
9. Click the Advanced tab, and then click to select the check box next to each extended logging option in the Extended logging options list that you want to track.
10. Click Apply, and then click OK to close Logging Properties.
11. Click Apply, and then click OK to save your settings and close SMTP Virtual Server Properties

You can use protocol logging to track incoming commands that an SMTP virtual server receives from SMTP clients and to track outgoing commands.

Thanks,
Amit Aggarwal.
0
 
mickythompsonAuthor Commented:
1.  Yes.  We are running Exchange 2003 with SP2 and Windows 2003 with SP1.  On the "Outbound security" of the old servers SMTP virtual server properties, anonymous access is selected.

2.  When I send a mail to the new server using command line Telnet SMTP port 25, it works successfully.

3.  I sent another email to the mailbox on the new server.  There are now 8 emails in the queue to be delivered to that server.  I checked the application log and it is clean as a whistle.  I then forced a connection and still the application log is clean.  

4.  Here is the message that shows in the message tracking:

5/25/2006      2:5:21 GMT SERVER02 micky.thompson@DOMAINREPLACED.com      1033 2D01AAE8D5DA7341806167B065EAADE70EDC@server02.DOMAINREPLACED.local 0 0 444 1 2006-5-25 2:5:21 GMT 0 - - - admin@DOMAINREPLACED.com-

4.  I stopped and then restarted the SMTP Virtual Server.  The messages going to the new server are still in the queue.

Good test but still no dice.

Do you got more good stuff I can try?
0
 
aa230002Commented:
1033 in Message tracking --- hmm....
if i am not mistaken, i have experienced the similar issue with Public folder replication, Try deleting and recreating the mailbox store on the new Exchange server 2003 (also manually delete all database files).

as its a standard edition, otherwise, we would have created a new storage group and new mailbox store.

Thanks,
Amit Aggarwal.
0
 
SembeeCommented:
You should use the Message Tracking Center in tools to look at the message tracking logs, rather than trying to look at the raw logs.

The most common reason for traffic failing to go between the servers is a smart host configured on the SMTP VS.

ESM, Servers, <your server>, Protocols, SMTP. Right click on the SMTP VS and choose Properties. Click on the Delivery tab and then Advanced. Ensure that the smart host is clear.

If you need to use a smart host for outbound email, then use an SMTP Connector instead.

Simon.
0
 
mickythompsonAuthor Commented:
Sembee:  Thanks for the heads up on the Message Tracking Center.  I always wondered why the place you turn it on and the Message Tracking menu were called it the same name.  I will try that next time.

You may have missed in my first post where I stated "We have no smart host entries in either Exchange SMTP Advanced Tab (seen this posted a lot as a major cause.)."  I put that in the post because I know someone would recommend that.
0
 
mickythompsonAuthor Commented:
Dear Amit:

I think I was able to isolate the problem with help from you last post.  When I deleted the Storage and recreated it.  The SMTP's still would not talk to each other.  I decided to restart the server just to see what it would do.

I restarted the server and noticed an error message related to Symantec Antivirus, one I seen before during my other restarts but now I was getting desperate.  

When I looked up the error, it stated that the message was related to Symantec Antivirus scanning incoming and outgoing email.  Now this is Symantec Corporate 10.0 edition and it made me wonder.  If I uninstall Symantec, will email work.

Would you beleive that the email started working!  It was because of Symantec Corporate Client 10.0.  So for you guys that are reading this in a couple of months, uninstall any Antivirus.  It maybe what is causing the problems.

For you help Amit, you get the points.  You definitely deserve it!

0
 
mickythompsonAuthor Commented:
Sembee:  

It appears I accidently accepted you answer instead of the one right above yours from aa230002 which I meant to select as the accepted answer.  Can you correct that for me?  Thanks.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now