• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 271
  • Last Modified:

Home network - lapop can't see docs

Firstly, I'm no IT expert!

I've set up a wireless router so I can go online from desktop and laptop. This works.

I also want to share docs between machines (and possibly print from laptop).

I've set up networking as well as I can, and I can see the laptop shared docs from the desktop.
However, when I try to see the Desktop from the laptop I have problems.

- The desktop pc is present in the workgroup computers
- When I try to open it, I get message "network path was not found"
- If I disable the McAfee firewall on the desktop, this msg changes to "user has not been granted the requested logon type at this computer"

There are no user passwords set up on either computer.

Can anyone help?

Be patient pls!
0
teallach
Asked:
teallach
  • 7
  • 3
  • 3
  • +4
1 Solution
 
r-kCommented:
What version of Windows is running on the two systems, esp. on the desktop?
If XP, is it Home Edition or Pro?

You might find this link helpful:

 http://www.practicallynetworked.com/sharing/xp_filesharing/
0
 
r_naren22atyahooCommented:
0
 
r_naren22atyahooCommented:
too late :)
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
r-kCommented:
It is a good link, though. Worth repeating twice :)
0
 
r_naren22atyahooCommented:
at first glance, i thought both are same links :)
0
 
r-kCommented:
Yes, I noticed that too. So I guess they may be independently of value depending on whether poster wants to use simple file sharing or not. May have to if he has XP Home.
0
 
FriarTukCommented:
both the laptop & the desktop must be members of the same workgroup

xp:
1) right click - my computer - click prop's - click computer name tab - click change button - select workgroup - enter workgroup name like "theden" - click ok
2) right click network icon in systray by time (or control panel - network connections - local area connection) - click status - click properties button - scroll down in the box & select tcp/ip - click properties button - click advanced button - click wins tab - select enable netbios of tcp/ip - click ok all the way out (last will click close)
3) click start - control panel - folder options - view tab - scroll to bottom of advanced settings box & check use simple file sharing - click ok


98 -
1) right click network neighborhood - click prop's - click identification tab - enter workgroup "theden" - <step2>
2) -- click configuration tab - at the top make sure the client miscrosoft networks is there (if not click to add - select client - click add - select micrsoft - select the client for ms netwks - click ok) - then scroll down & select tcp/ip for your network card - click prop's - click netbios tab - make sure checked enable netbios over tcp/ip - click ok (will reboot)

on both the laptop & the desktop, open windows explorer, right click a folder to share, click sharing, & enter the share name
xp - click permissions - select everyone - check full control
98 - for access type select full - enter in full access password (will need this when you try to connect from another system)
0
 
teallachAuthor Commented:
thx

xp pro on both comps.

they're both in same group

i'll investigate these links and let y'all know
0
 
ImmediateActionCommented:
Saw a similar problem; this was a quick fix, and may / may not be similar to your scenario. You probably have no password on your computers logon account; you dont need to put one in; just create an account on the other computer that has your username, and give it any password; 12345. now try and access it.

*To find out your username on your computer:
(Windows) Strat menu --> run --> taskmgr
**Your user account name will be shown in a coulumn or in its shutdown/log off xxx menu
0
 
teallachAuthor Commented:
Imm.Act.
Both comps have same acc. names
0
 
Mad_JasperCommented:
In order ta access a XP computer in a workgroup, you cannot leave the passwords blank (unless you change the setting in group policy).

Set up an account with the same username and password with administrative rights on both computers and this should take care of your problem.

Go to Administrative Tools | Local Security Policy | Local Policies | User Right Assignment | Access this computer from the Nnetwork | Ensure that the users to access the computer are displayed. By default, Everyone, ASPNET, Backup Operators, Users, Power Users, and Administrators are listed. I have seen viruses/malware remove replace users with system accounts.

Here are some other tips about peer-to-peer network  that you probably already know if this was working before. But, maybe a username or password has changed.

If John is a user on Computer A with a password of 1234, then John also needs to be a user on Computer B with a password of 1234.

To allow users to log onto their computers without a password and then access the XP Professional machine without a password, you must make a security policy change:


Go to Control Panel |  Administrative Tools | Local Security Policy.
Expand Local Policies | Security Options.
Double-click Accounts: Limit local account use of blank passwords to console login only, which is enabled by default. Disable this option and click OK.
This will permit network access without a password. The user's computer can boot directly to the Windows desktop, and be validated against the corresponding XP Professional user account, without a password.

Note that the term “blank passwords” isn't technically accurate.  There's a difference between having a password which consists of one or more blank characters, and having no password at all.  This setting actually permits access by users who have no password at all.
0
 
ImmediateActionCommented:
My apologies teallach, i only glanced at your question and saw the error message; was thinking of a similar problem I had seen, and it was to do with no password at all for one user.  

Thanks for the security options tip Mad Jasper
0
 
teallachAuthor Commented:
Thanks all so far, but...

I've tried everything and I still have the same problem - I can access laptop files from desktop but not other way around.

A couple of points:
- it makes no difference if I use simple file sharing or not
- since I made passwords the same and set "Administrative Tools | Local Security Policy | Local Policies | User Right Assignment | Access this computer from the Network" (on the desktop) to 'Everyone', the error message I get has changed to "Access is denied".

Lastly, the only difference I can see between the shared docs on the two comps is that if simple file sharing is NOT enabled, then clicking 'sharing and security' on the right-click menu of the desktop gives a window with THREE tabs (general, sharing & security), whereas doing the same on the laptop only gives two (general & sharing).

More help needed please!
0
 
FriarTukCommented:
"...access laptop files from desktop but not other way around."

both are xp pro
both are on same workgroup]
both have same acct name & pswd

1) are both set to use "netbios over tcp/ip"?
2) are both set to "simple file sharing"?
3) do both have the below services running?
     computer browser
     dhcp client
     dns client
     network location awareness
     tcp/ip netbios helper
     workstation

the difference between simple & not file sharing is:
simple grants group everyone access by default
not means you may have to set folder permissions instead of share permissions on the security tab

0
 
teallachAuthor Commented:
Hi again all. Getting there.

Firstly, FriarTuk,

1) are both set to use "netbios over tcp/ip"? Not sure
2) are both set to "simple file sharing"? No, because I want to share 'My documents' also and these don't give sharing option unless simple file sharing is not allowed.
3) do both have the below services running? I don't know... beyond me... Maybe you can give more layman terms?  

ANYWAY, for some reason (don't ask me how!) I appear to be getting somewhere.

There are two users, both set up as administrators with the same passwords on both comps.

Now, both users can see the laptop docs from the desktop, but only user B can see the desktop from the laptop. This is already something, as previously no-one could see dt from lt.

Also, both comps run identical McAfee firewall, but the dt firewall must be disabled for the lt user to gain access. The dt users can access the lt with the firewall still up.

Anyone have any ideas? We are nearly there...
0
 
FriarTukCommented:
from my earlier post:
2) right click network icon in systray by time (or control panel - network connections - local area connection) - click status - click properties button - scroll down in the box & select tcp/ip - click properties button - click advanced button - click wins tab - select enable netbios of tcp/ip - click ok all the way out (last will click close)

3) do both have the below services running? < start - run - services.msc >
     computer browser
     dhcp client
     dns client
     network location awareness
     tcp/ip netbios helper
     workstation
0
 
teallachAuthor Commented:
thanks

2) Done. Desktop was set to 'default', and if it makes any difference, there is a network bridge here. Laptop settings were already "enable netbios of tcp/ip " (it is 'over', not 'of')
3) both comps running all these

The error msg is now "The user has not been granted the requested logon type at this computer". Is it not more likely that the problem lies in the laptop users?
Laptop user B can see the dt, and it logs in using name and pw from User A. User A, however, cannot.
0
 
teallachAuthor Commented:
...also, even though user B can log on from laptop, this is still only if desktop firewall is disabled. Once logged on, it's possible to enable desktop firewall again and laptop user B can still access files.

User A is 'default' user on laptop and still can't log on under any circumstances.

I've made new accounts on laptop but they also can't log on - even if they're administrators.

Points still up for grabs...
0
 
teallachAuthor Commented:
Hello

I'm sorry, but I've solved the initial probs myself. It was that user A on the laptop was only called User A, but was actually the 'Default User'. Therefore he couldn't log on.

The firewall prob still exists. I'll open a new post for this one.

In the meantime, I'll ask for a refund and I'm sorry for the time wasted everyone.
0
 
GranModCommented:
Closed, 300 points refunded.

GranMod
The Experts Exchange
Community Support Moderator of all Ages
0

Featured Post

NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

  • 7
  • 3
  • 3
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now