• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 278
  • Last Modified:

OWA loading... after upgrading to 2003 enterprise

Hi,

I had OWA on 2003 standard, which was working fine (with SSL).

I made some changes, and now when I try to access I get loading... forever. (also from the server itself)

The changes I made that might cause the problem:
1. This server is no longer a DC.
2. I've upgraded the server to 2003 enterprise.
3. I've deleted the certificate and created a new one (but I get this problem also after disabling SSL so I guess it doesn't matter).

I've deleted the virtual directories and restarted exchange services to let them be created again.

any suggestions?

Thanks.
0
AbelB
Asked:
AbelB
  • 15
  • 13
  • 3
  • +1
1 Solution
 
LeeDerbyshireCommented:
There is an MS doc for this that may help:

http://support.microsoft.com/?kbid=280823

The VDirs in E2003 aren't so easily recreated as they were in E2000, here is the MS doc for that too, in case you missed it:

http://support.microsoft.com/kb/883380
0
 
AbelBAuthor Commented:
Thanks for your reply, I have already followed those articles.... but I still get this error message.
0
 
LeeDerbyshireCommented:
If you've already tried the 'OWA Loading' article, then it will probably be quite difficult to fix (judging by other people's experiences - this seems to happen quite a lot).  It might be because the server is rejecting WebDAV requests that IE uses with OWA.  Can you try a non-MS browser, like Firefox or Opera, to get OWA into the 'Basic' (i.e. not Premium) mode, and see if you have the same problem with that?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
AbelBAuthor Commented:
I've tried firefox and it works.

0
 
LeeDerbyshireCommented:
There are probably some WebDAV calls being blocked somewhere between the browser, and IIS.  Unfortunately, there are quite a few places to choose from.  We may as well start at the server end, to make sure that they are actually reaching IIS.  Can you try accessing it in IE again, and after a few minutes (so that it can flush the entries), open your current IIS Log file, and copy/paste the logged entries for me?  There should be quite a few, but we are only interested in the ones created by your most recent attempt to access OWA.  You can tell which ones are relevant from the time column at the left-hand side.
0
 
AbelBAuthor Commented:
there are lot of entries added each time I try to login, what should I look for?
0
 
LeeDerbyshireCommented:
If you are using IE, you should see lines including the WebDAV verbs SEARCH or SUBSCRIBE, mixed in with the more usual GET, etc.  There will be a 3-digit status number at or near the end of the line - if it begins with a 2 (200, 204, 207) then the request was successful.  If it begins with a 4 (401, 403, 404), and is not followed later by a successful call then it failed (sometimes a 401 indicates an auth challenge that is followed immediately after by an authenticated 20x).  If you don't see SEARCH or SUBSCRIBE, then the calls are probably being blocked somewhere else.
0
 
AbelBAuthor Commented:
I found these lines, it returns 405.

Thanks again for your help.
0
 
LeeDerbyshireCommented:
Okay, 405 is 'Method not allowed', so something on the server is blocking it.  My first guess would be URLScan, although it could also be a locally installed firewall.  Can you find a URLScan.ini file on the server?  If so, is it denying the SEARCH verb?
0
 
SembeeCommented:
Did you change the role of the server with Exchange installed? That isn't supported and may well have caused the problem.
Did you reinstall the service pack after doing the upgrade to Enterprise edition? If not, then I would reapply the service pack.

Simon.
0
 
AbelBAuthor Commented:
Hi, thanks for helping me.

I've reinstalled SP2 but it didn't help.
I couldn't find urlscan.ini, where should it be?

About changing the role, can you please explain me in more details because I think it might be the problem...


Thanks again,

Ronen.
0
 
LeeDerbyshireCommented:
If you can find URLScan.ini with a search, then it's probably not installed.  'Changing the role' refers to the part of your question where you said 'The server is no longer a DC'.  If you demoted the server while Exchange was installed, then that could cause your problems.  Changing the role with Exchange installed is not supported, although I am not sure what symptoms you would see after doing so.  One thing you could try is to use IIS Manager to check the identity used for your ExchangeApplicationPool - does it say 'LocalSystem' ?
0
 
AbelBAuthor Commented:
I did demote the the server while exchange was installed.

I checked the identity of ExchangeApplicationPool, it's Local System.
0
 
LeeDerbyshireCommented:
LocalSystem is correct.  Is anything written to the server's Event Logs when you try to use OWA?
0
 
AbelBAuthor Commented:
No :(
0
 
LeeDerbyshireCommented:
Strange thing is, though, if OWA works okay with Firefox, the I think Exchange is basically okay.  Can you confirm again that it works okay with Firefox?  Also, if you have Forms-based Auth enabled, try using the Basic client.
0
 
AbelBAuthor Commented:
I have tried the basic client, and it works ok.
0
 
LeeDerbyshireCommented:
Does the server have a software firewall installed, or an AntiVirus program, that can be configured to block WebDAV extensions?
0
 
AbelBAuthor Commented:
There is no software firewall, there is mcafee virusscan, but I never had trobules with it and OWA.
0
 
LeeDerbyshireCommented:
Have a look in Web Service Extensions in IIS Manager.  Make sure that Microsoft Exchange Server is allowed.  Also try allowing WebDAV.  This is normally set to Prohibit, but I knew one guy that couldn't use OWA without this being set to Allow.  If it makes no diff., set it back to Prohibit.
0
 
AbelBAuthor Commented:
Exchange server is allowed.

WebDav is prohibited, it didnt make any change setting it to allow so I set it back to prohibit.
0
 
LeeDerbyshireCommented:
Hmm.  I may be barking up the wrong tree here.  Let's see if Sembee has any more suggestions before I send you off on another wild goose chase.  If not, I'll see if I can think of anything else.
0
 
SembeeCommented:
It is OWA that suffers most when the role of an Exchange server is changed from being a member server to a domain controller. It usually screws up the permissions that the IIS accounts use.
I have had clients make the same change and I don't even bother try to fix it. I simply quote them a price to rebuild the server. It is the only guaranteed way of fixing it.

As a minimum I would be looking to reinstall IIS. However to do that means removing Exchange first, then IIS, rebooting the machine, then reinstalling IIS and Exchange, followed by service packs etc. You will need to have good backups in case the old databases don't mount.
I use a second machine and swing the data around - no chance of anything going wrong then.

Simon.
0
 
LeeDerbyshireCommented:
I thought it was going to be something drastic like that.  I'd have tried re-installing Exchange on its own first, since that is fairly easy.  How about just promoting it back again?  I have to admit that I've never encountered a server in this condition before, so I don't know if even that would work.  My searches on the Web haven't revealed any successful recoveries from this.  There are a few accounts out there of people that have reinstalled IIS (without realizing what that would do the Exchange), and recovered by reinstalling Exchange when they discovered that Exchange got upset.  I daresay that ~might work.
0
 
LeeDerbyshireCommented:
Oh - another possibility; since the Basic client is (somehow) working, you could always change the registry to disable the Premium client, if you don't want to risk doing anything drastic just yet.
0
 
AbelBAuthor Commented:
Can I set just OWA to be installed on a different server?
0
 
LeeDerbyshireCommented:
You can't install OWA without installing Exchange, so yes, you can, but you'd need another server license.  You also need to check the 'this is a front-end server' checkbox to get it to act as an OWA proxy (but that also means you can't have any mailboxes on it).  But it is a possibility, if you have a spare server that you can use for this role.
0
 
AbelBAuthor Commented:
Thanks alot for your help.

If if I will uninstall exchange, what is the easiest way to backup and restore the data? moving it to another exchange and bringing it back?
0
 
LeeDerbyshireCommented:
If you have another Exchange server that you can move them to (using the normal ADUC move mailbox option), then that's a nice clean way of doing it, yes.  That way, the mailboxes stay online, and you're less likely to lose them.
0
 
SembeeCommented:
A swing migration is the best way to do it.
This is where you move all the mailboxes to another Exchange server, then remove the original Exchange server using the best practise KB article.
Once Exchange has gone, I usually rebuild the machine so that it is nice and clean and there is no residue from the domain controller change.
Then reinstall Exchange and move everything back.
I have a guide on my web site: http://www.amset.info/exchange/migration.asp
There is also a guide on Microsoft's web site at http://support.microsoft.com/default.aspx?kbid=821896
and finally the procedure for removing the first Exchange server (if you don't read anything else - you should read this one): http://support.microsoft.com/default.aspx?kbid=822931

Simon.
0
 
AbelBAuthor Commented:
I've reinstalled exchange and IIS, but still get the loading..............................................

I was following this article: http://support.microsoft.com/default.aspx?kbid=320202


Any ideas? or should I format the server?

0
 
CetusMODCommented:
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 15
  • 13
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now