web hosting

hello,
to give web hosting to my friends in my FC1 I just need to do this in the shell

adduser mike
mkdir /home/mike/public_html
vi /home/mike/public_html/index.html

visit http://1.2.3.4/~mike/
and thats it? cause is not working!
apleloisAsked:
Who is Participating?
 
Heem14Connect With a Mentor Commented:
what about the parent - /home/mike  - that should be at least 711.
0
 
Heem14Commented:
theres a few things you need to do.

first of all, you should tell us what error message you are getting. that would help us narrow down where the problem is.

Make sure apache is started and running.

userdir (~mike) is disabled by default in apache. search your /etc/httpd/conf/httpd.conf file for the word "userdir". you will need to change it as noted in the default conf file. it's well commented so you can figure out what to do.

also, make sure to set the permissions on /home/mike/public_html to 755  (chmod -R 755 /home/mike/public_html

that should do it for you.
0
 
apleloisAuthor Commented:
Forbidden
You don't have permission to access /~mike/ on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

-> http://httpd.apache.org/docs/1.3/misc/FAQ.html#forbidden

yes they are 755
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
Heem14Commented:
is index.html also 755?
0
 
apleloisAuthor Commented:
I see this


<IfModule mod_userdir.c>
    UserDir public_html
</IfModule>


# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
#
#<Directory /home/*/public_html>
#    AllowOverride FileInfo AuthConfig Limit
#    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
#    <Limit GET POST OPTIONS>
#        Order allow,deny
#        Allow from all
#    </Limit>
#    <LimitExcept GET POST OPTIONS>
#        Order deny,allow
#        Deny from all
#    </LimitExcept>
#</Directory>
0
 
apleloisAuthor Commented:
yes index is 755
0
 
Heem14Commented:
if thats not it - can you post relavent parts of your error log?
0
 
apleloisAuthor Commented:
thanks I didnt know it had to be 711
0
 
Heem14Commented:
you're welcome, and good luck.
0
All Courses

From novice to tech pro — start learning today.