Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Port forwarding with Emule

Posted on 2006-05-25
22
Medium Priority
?
1,488 Views
Last Modified: 2013-11-29
Hi. I had it working fine before, but I've re-formatted and cant recall the necessary steps.
In connections (emule) Client port is 4662 TCP, and 4672 UDP. Test ports results in a FAIL always.
I have a netgear router WGR614, I have entered setup and under ADD CUSTOM SERVICE I have entered service name (emule2) Start port 4662, end port 4662. Now server IP address. I have entered 192.168.0.4 (This I got from command/ipconfig) Is that correct? Apply. I cant see where I can edit UDP settings.

Underwindows/firewall I have added emule under exceptions, and I have added ports for 4662 tcp and 4672 udp
Then I test ports, and another fail ... help!
0
Comment
Question by:Nasturtiumman
  • 12
  • 10
22 Comments
 
LVL 30

Accepted Solution

by:
Irwin Santos earned 2000 total points
ID: 16760956
0
 

Author Comment

by:Nasturtiumman
ID: 16761281
Thanks irwinpks. I did all that, but still no joy...
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16763384
disable your Windows firewall and anyother firewall software you have on your computer.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 

Author Comment

by:Nasturtiumman
ID: 16774970
Yes thanks I did that. XP firewall is disabled, and I am still seeing TCP test failed.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16776129
ok...how about recording your router's configuration.. then visit the following page
http://kbserver.netgear.com/products/WGR614.asp
locate your router and download the latest firmware update, then Flash the firmware
confirm your router settings.. test, and post your results.

if that doesn't work, then connect directly to your cable/dsl modem.  test to see if that works.
0
 

Author Comment

by:Nasturtiumman
ID: 16776278
Ok I'll do that, will be back ...
0
 

Author Comment

by:Nasturtiumman
ID: 16776594
I have installed the latest firmware. If I remove the Netgear router and connect the modem directly to PC, then the TCP test passes (!) but only if I set Internet Protocol (TCP/IP) for the 1394 NET Adapter to obtain an IP address automatically/Obtain DNS server address automatically. If I use the settings as advised in the guide as per your first reply, it fails again.

Using the Netgear at fails either way.

Just to help clarify things a little. with a direct connection (No netgear), in Network Connections, there are two icons, Local Area connection, connected, VIA Rhine 2 Fast Ethernet Adapter. This is showing a rapid exchange of bits. 1394 Connection Connected 1394 Net Adapter. Status 0/0. However Internet and EMule are fully functional.

These connections are actually the same with the Netgear in situ.

Still i cant get it to work.  N
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16777762
do you have a static or dynamic Internet connection?
0
 

Author Comment

by:Nasturtiumman
ID: 16778845
I have contacted my ISP for this information. Will post when they answer. Thanks irwinpks.
0
 

Author Comment

by:Nasturtiumman
ID: 16780946
Hi Irwinpks, I got a reply from the ISP (On a Sunday!). It is dynamically assigned.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16780968
go into your router's configuration and set the WAN interface for DYNAMIC retrieval of the IP.

Set the LAN IP as

192.168.1.1

Set your DHCP to start assigning address at 192.168.1.100
0
 

Author Comment

by:Nasturtiumman
ID: 16780985
I found this tip on Emule's forum
Start -> Run(type cmd and hit enter) -> In the new window at the command prompt type "ipconfig /all" without the "", and make a note of the "IP Address". Now click -> WhatIsMyIp.com and see if it matches the one displayed there.

Not matching = Proxy
Matching = No Proxy

In My case I get IPConfig: 192.168.0.2
WhatsMyIp:81:xxx.xxx.246

I guess its the proxy thing, then. Do you agree. is it worth trying to forward ports to the proxy ip?
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16781324
before we go in that direction...apply my previous router config.
0
 

Author Comment

by:Nasturtiumman
ID: 16783327
I applied your router configuration.
Does that change the port forwarding settings. Do I need to use 192.168.1.1

In the WAN interface I dont see a direct option for setting the interface for DYNAMIC retrieval of the IP. There is a 'connect automatically as required' which I have checked, and a few other options that dont seem relevant. \
I have
Set the LAN IP as

192.168.1.1

Set my DHCP to start assigning address at 192.168.1.100.
here I had to change the ending IP address to 192.168.1.200. Is 200 okay.
Still I have a low ID and tcp test fails.
Thanks for your effort so far. N.





0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16783367
"connect automatically as required' "

This is adequate

"here I had to change the ending IP address to 192.168.1.200. Is 200 okay."

200 is ok

"Does that change the port forwarding settings."

YES

" Do I need to use 192.168.1.1"

NO...it will be the IP address of your workstation. ideally you want to assign a STATIC IP in the range that is lower than .200.

At this point, are you at least able to browse the Internet?

0
 

Author Comment

by:Nasturtiumman
ID: 16784268
Changed the port forward IP to 192.168.1.2 as per IPCONFIG.
yes i can browse the internet, but no change with Emule.
0
 

Author Comment

by:Nasturtiumman
ID: 16784695
This is from emules help screen / The 4711 TCP is news to me. Will try it later today. It is on a network, but Im on the gateway PC. Why does the router not let me choose TCP or UDP or BOTH ? All I get to do is enter the values of the ports.

Without proper configuration you will have a low ID when using a router. A router works like a shield to the network behind it, masquerading the IP addresses of the computers in the LAN. When another client tries to establish a connection to your eMule it only sees the IP of the router but not the actual IP of the computer eMule is running on. To prevent this all ports in the list that have the incoming direction – port 4662, 4711 TCP and port 4672 UDP – have to be forwarded.
See your router's manual. Keywords to start are port forwarding, DMZ – Demilitarized Zone, Filters and Rules.
Many routers also have built in firewalls so be sure to set the appropriate ports (see Firewall) there, too.

Note:
When using a router in a network the option DHCP - Dynamic Host Configuration Protocol in the router should be turned off. Assign static IPs to each client in the network. This can be done in Window's Network Connections -> LAN Connection -> Properties -> TCP/IP. Deactivate the automatic IP assignment and enter an IP in the range of 192.168.xxx.xxx. Different types of router have different home IP ranges, this is noted in the routers manual.
After entering a valid IP the Subnet Mask field automatically changes to 255.255.255.0. Last step is to enter your router's IP as Standard Gateway.

0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16785471
hmmm.....  follow the 2nd note and assign a static IP to your machine..

go into the router setting and locate the Primary & Secondary DNS addresses.  record

IP address  192.168.1.50
subnet 255.255.255.0
Gateway 192.168.1.1
Primary DNS (enter from above)
Seconary DNS (enter from above)

go back into the router and change the 192.168.1.2 ->>>> 192..168.1.50

reapply my 1st comment
0
 

Author Comment

by:Nasturtiumman
ID: 16801285
I havent abandoned this thread. I have 2 poorly pcs, both of which wont boot,  to fix first!
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16801532
ok
0
 

Author Comment

by:Nasturtiumman
ID: 17395877
I gave up on this one, but I gave the points to irwinpks as his advice is no doubt sound for someone else in the same situtation. Thanks. N.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 17396124
bummer on the cause.....but Thank you on the points.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question