Restrict users to only send to a list of other users

I have exchange server 2003.  I jsut recently set restrictions for certain to only recieve emails from other users, but when I tested it with an email it did not work.  Does this thing take time to work.

This is what I changed:

I went in AD and went into the the properties of the restricted users.
I than went to the Exchange General tab
I clicked on Delivery restrictions
I checked only from under message restrictions
I put the users they should only get email from


What am I doing wrong for this not to work?

Any help would be appreciated. Thanks.
afs757Asked:
Who is Participating?
 
amaheshwariCommented:
How to restrict the users who can send inbound Internet e-mail to another user or to a distribution group in Exchange 2003
http://support.microsoft.com/kb/827616/en-us
0
 
amaheshwariCommented:
This is fine for internal users but for External users do steps like this:

Open the properties for the user that you want to stop receiving Internet mail in Active Directory Users and Computers.
Select the Exchange General tab, and then click on the Delivery Restrictions button, the Delivery Restrictions dialog box will now appear.
Check the “From authenticated users only” checkbox in the Message Restrictions section.

By checking the “From authenticated users only” checkbox, this user will still be able to receive mail from users in your organization but will be unable to receive mail from anyone who cannot successfully authenticate with your server.
0
 
amaheshwariCommented:
you can restrict the user from the user properties =>Exchange Genral=> Delivery Restriction . Select the option from everyone except and add users to whom you do not want mail.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
afs757Author Commented:
I did everything that you all have asked but users are able to send to each other.  Should this be immediate?
0
 
amaheshwariCommented:
yes it has to be immediate .What you can try is restart your exchange server and domain controller(take Downtime if you are online).
0
 
afs757Author Commented:
Why would I have to restart the server for a simple change like that.  I can't afford any downtime.  Is there anything else that you can think of why thi isn't working.  Do I have to refresh something or logoff and log back on I am stuck.
0
 
SembeeCommented:
Certain permissions and settings in Exchange are cached. The cache is flushed every couple of hours. If you want them to be set immediately, then you will have to restart the Exchange services.
Otherwise wait.

Simon.
0
 
afs757Author Commented:
I've did rstart the services before I left for the weekend.  When I cam in this morning it still doesn't restrict the users.  The mail goes  to the other restricted user like nothing happens.  I think I might have the setup wrong or something is not right.
0
 
afs757Author Commented:
I need help on this ASAP thanks.
0
 
SembeeCommented:
If you want ASAP then phone Microsoft.

Undo everything that you have done and do it again.

You may also want to look at these two articles at msexchange.org to see if you have missed anything:
http://www.msexchange.org/tutorials/MF009.html
http://www.msexchange.org/tutorials/MF025.html

Simon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.