• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1206
  • Last Modified:

Problems with NSLookup...

Hello,

I have two servers.  Server number one is running Win SBS 2K3, and server 2 is running Win 2K3 Enterprise.  Both have DNS installed, and both are domain controllers.

Anyway, whenever I try to run an nslookup, i get the following message:
*** Can't find server name for address 192.168.36.120: Non-existent domain
*** Default servers are not available
Server:  UnKnown
Address:  192.168.36.120

The IP of Server 1 is 192.168.36.120, it's DNS server in TCP/IP properties is pointed at itself.  It's forwarders are pointed to the DNS servers of my ISP.  It has a reverse lookup zone 192.168.36.X Subnet with SOA as server 1, NS to both servers and a PTR to server 1.

How can I fix this error?

Thanks,
-Torrwin

0
Torrwin
Asked:
Torrwin
  • 7
  • 6
1 Solution
 
feptiasCommented:
You need to add PTR records in your Reverse Lookup Zone, for the servers are acting as DNS servers. That is how nslookup is able to report the name of the default DNS server based on its IP address.
0
 
feptiasCommented:
You might have to create the reverse lookup zone first, of course. You need a reverse lookup zone for 192.168.36 - it will have a name like 36.168.192.in-addr.arpa

Just say if you would like more detailed instructions.
0
 
TorrwinAuthor Commented:
So, you're saying I should add a PTR record for server 2?  It already has a PTR for server 1, as stated above.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
TorrwinAuthor Commented:
I said above that I already had a reverse lookup zone, did you read that part, or do I need another?
0
 
feptiasCommented:
There is no reason not to have a PTR record for every Host (A) record, so yes you can and probably should have a PTR record for the second server. If both servers are in the same subnet then both PTR records would be in the same reverse lookup zone. (I'm surprised Windows didn't add the pTR records itself - it usually does for DC's.)

Sorry, I did only read the first half at first, but then later I read it and noticed the name looked wrong. Are you sure your reverse lookup zone is correctly named?

You stated it was 192.168.36.X, but it should be 36.168.192.in-addr.arpa.
0
 
feptiasCommented:
1. Even though you get the error message when it starts, does nslookup still work? i.e. can it still resolve names to IP's?

2. What if you force nslookup to use an external DNS server (best to specify your ISP's DNS server). The command in nslookup is:
server 123.123.123.123

3. It would be useful to see a posting of output from ipconfig /all.
0
 
TorrwinAuthor Commented:
1)  
C:\Documents and Settings\akrier>nslookup armada-perrier
*** Can't find server name for address 192.168.36.120: Non-existent domain
*** Default servers are not available
Server:  UnKnown
Address:  192.168.36.120

Name:    armada-perrier.wisemanagement.local
Addresses:  192.168.36.26, 192.168.36.21

2)
DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address 123.123.123.123: Timed out
Server:  UnKnown
Address:  123.123.123.123

DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out

3)
Windows IP Configuration

   Host Name . . . . . . . . . . . . : Server1
   Primary Dns Suffix  . . . . . . . : DomainName.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : Yes
   DNS Suffix Search List. . . . . . : DomainName.local

Ethernet adapter LAN - Gigabit NIC:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : MAC_Address
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.36.120
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.36.1
   DNS Servers . . . . . . . . . . . : 192.168.36.120
0
 
feptiasCommented:
For (2), please can you substitute the actual IP address of your ISP's DNS server for the nominal IP address 123.123.123.123. That address is not a real one and was just to illustrate the syntax.

As an additional test, call it (2a), what happens if you tell nslookup to use server 127.0.0.1
I would expect it to confirm that the new server name is "localhost". nslookup should still work.

You can instruct nslookup to lookup PTR records like this:
C:\> nslookup
>set type=PTR
>192.168.36.120
It should report back results a bit like this:
120.36.168.192.in-addr.arpa    name = server1.domainname.local

Do you get the same problem if you run nslookup on other PC's on the LAN - workstations or on the other server?

P.S. You will be able to see more details of your DNS setup if you click on the Advanced view option in the DNS management console - Just select View | Advanced.  When the advanced view is enabled, it shows the reverse lookup zones as z.y.x.in-addr.arpa (sorry, I only just found out that they are shown with a different format when Advanced view is disabled 'cos I always have advanced enabled - doh).

P.P.S. In the end, what really matters is that your servers and domain work correctly. Are there other problems besides just getting an annoying error message every time you start nslookup? Do you get errors reported if you run dcdiag on the domain controllers?
0
 
TorrwinAuthor Commented:
(2)
From my workstation AND Server1:
     *** Can't find server name for address 192.168.36.120: Non-existent domain
     *** Default servers are not available
     Server:  UnKnown
     Address:  192.168.36.120

     Name:    ns1.ok.cox.net
     Address:  68.12.16.30

(2a)
From my workstation AND Server1:
     *** Can't find server name for address 192.168.36.120: Non-existent domain
     *** Default servers are not available
     Server:  UnKnown
     Address:  192.168.36.120

     Name:    localhost
     Address:  127.0.0.1

     *** Can't find server name for address 192.168.36.120: Non-existent domain
     *** Default servers are not available
     Default Server:  UnKnown
     Address:  192.168.36.120

     > set type=ptr
     > 192.168.36.120
     Server:  UnKnown
     Address:  192.168.36.120

     *** UnKnown can't find 120.36.168.192.in-addr.arpa.: Non-existent domain

P.P.S.
     1)  Yes, whenever an employee VPN's in, they can't automatically detect the DNS server.
     2)  The only test that fails on dcdiag is:
          Starting test: Services
                IsmServ Service is stopped on [ARMADA-SRVR01]
                ......................... ARMADA-SRVR01 failed test Services


0
 
feptiasCommented:
hmm. This is a tough one.

Have you considered that there may be no connection between your nslookup "unknown server" messages and the VPN users failure to detect DNS - it may be better to work directly on the VPN user problem and put nslookup to one side. Try manually setting the IP address of the office DNS server in the properties of the TCP/IP protocol for the VPN connection on the remote clients.

You should start that IsmServ service, because it is used with Active Directory replication and is required for Active Directory servers. I don't think that is going to solve the DNS problems however.

Re the nslookup problem, all the evidence is that your DNS server doesn't have a correctly named reverse lookup zone. The message "*** UnKnown can't find 120.36.168.192.in-addr.arpa.: Non-existent domain" clearly backs this up. Is it possible that your DNS management console is connected to the DNS server running on the other DC? Does nslookup work ok on the other DC server?
0
 
TorrwinAuthor Commented:
VPN
     Yes, if you manually input the DNS server into the VPN connection properties it works fine.  
     However, automatic detection is definitely preferable.

IsmServ
     Done. =)

Nslookup
     Server1 is the primary DNS, and Server2's DNS copies Server1.
     Really, the only reason Server2 has DNS is in case we need to restart Server1.

     I'll try deleting the reverse lookup zone and re-creating it.
0
 
feptiasCommented:
You should keep a watch on this question (currently open) and see if anyone posts a useful suggestion that you can use to solve your problem of VPN client DNS setting:
http://www.experts-exchange.com/Networking/Microsoft_Network/Q_21865512.html

Clients don't do "automatic detection" of DNS servers (at least not that I know of) - they have to be told by something. So what you need is to find a central point within the VPN mechanism where VPN clients can be told which DNS server to use. For example, DHCP servers can often be configured to give out the IP address of the DNS server at the same time as they give out the IP address lease for the client. Unfortunately, different VPN's do it different ways.
0
 
TorrwinAuthor Commented:
I deleted and re-created the zone and it worked fine.  Thanks for all the help!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now