"Send As" issue with Exchange

I followed the following which I found here on EE to do a Send As permission, yet it keeps denying me to be able to send I get the following error:
  You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            MSEXCH:MSExchangeIS:/DC=local/DC=olympus:ODIN



Here are the instructions I followed:

Grant "Send as" permissions
If you grant a user "Send as" permissions for another user's mailbox, the DelegateUser can send mail as the MailboxOwner. The From box in these messages appears as follows:
From: MailboxOwner
To grant a user "Send as" permissions for another user's mailbox: 1. On an Exchange computer, click Start, point to Programs, point to Microsoft Exchange, and then click Active Directory Users and Computers.
2. On the View menu, click to select Advanced Features.
3. Expand Users, right-click the MailboxOwner object where you want to grant the permission, and then click Properties.
4. Click the Security tab, and then click Advanced.
5. In the Access Control Settings for MailboxOwner dialog box, click Add.
6. In the Select User, Computer, or Group dialog box, click the user account or the group that you want to grant "Send as" permissions to, and then click OK.
7. In the Permission Entry for MailboxOwner dialog box, click User objects in the Apply onto list.
8. In the Permissions list, locate Send As, and then click to select the Allow check box.
9. Click OK three times to close the dialog boxes.
For example, if you grant UserB "Send as" permissions for UserA's mailbox, UserB can send messages that appear to be sent from UserA. The From box in these messages appears as follows:
From: UserA


Please help.  I have four email accounts and the last thing I want to do is setup 4 profiles, I would rather get this Send As working.
TruckFanaticAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
december41991Commented:
In Microsoft Outlook 98 and in Microsoft Outlook 2000, follow these steps: 1. Start Outlook.  
2. On the Tools menu, click Options.  
3. Click the Delegates tab, and then click Add.  
4. Select a user from the global address list, click Add, and then click OK.  
5. In the permission list for Inbox, click Reviewer.

Note This requires a minimum of Reviewer permissions. However, you can give a higher level of permissions if you want.  
6. Click OK two times.  
In Microsoft Outlook 2002 and in Microsoft Office Outlook 2003, follow these steps: 1. Start Outlook.  
2. On the Tools menu, click Options.  
3. Click the Delegates tab, and click Add.  
4. Select a user from the global address list, click Add, and then click OK.  
5. In the permission lists for Calendar and Tasks, click None.  
6. Click OK two times.  
For example, if you grant UserB "Send on behalf" permissions to UserA's mailbox, UserB can send messages on behalf of UserA. The From box in these messages appears as follows:
0
 
TruckFanaticAuthor Commented:
So there are no modifications that need to be made to grant "Send As" , or are your instructions on top of what I already did above?  

Also, wasnt sure if I didnt make it clear , I do NOT want to "Send on Behalf"  I want to "Send As"  big difference between the two.  I can get "Send on Behalf" working fine, its the other I cant.
0
 
december41991Commented:
You have done what needs to be done....
the article which help earlier is regressed.....327000 KB.
Will let you know if I come across something....
To enable send as and not send on behalf you have to configure from the exchange and from the client.

Sometime it takes time when you have set the permission in the AD. The time is taken is between the AD and the Information store.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
BembiCEOCommented:
Do you have more than 1 DC?
Maybe you have to wait until replication.

Also it's an idea, to logoff and relogon the user, which tries to "send as".
0
 
TruckFanaticAuthor Commented:
it is one server, DC, exchange, all on one.
0
 
TruckFanaticAuthor Commented:
I tried logging of, loggin on, same error.

0
 
TruckFanaticAuthor Commented:
"To enable send as and not send on behalf you have to configure from the exchange and from the client."

This part isnt right.  As soon as I enable the person as a delegate on the client it changes to "Send on Behalf"

Again, I have to "Send As"  
0
 
TruckFanaticAuthor Commented:
I think I found an issue, when I follow the steps below, it seems to work, BUT when I go back in to check the permissions, the user isnt listed there anymore.

1. On an Exchange computer, click Start, point to Programs, point to Microsoft Exchange, and then click Active Directory Users and Computers.
2. On the View menu, click to select Advanced Features.
3. Expand Users, right-click the MailboxOwner object where you want to grant the permission, and then click Properties.
4. Click the Security tab, and then click Advanced.
5. In the Access Control Settings for MailboxOwner dialog box, click Add.
6. In the Select User, Computer, or Group dialog box, click the user account or the group that you want to grant "Send as" permissions to, and then click OK.
7. In the Permission Entry for MailboxOwner dialog box, click User objects in the Apply onto list.
8. In the Permissions list, locate Send As, and then click to select the Allow check box.
9. Click OK three times to close the dialog boxes.
0
 
TruckFanaticAuthor Commented:
Is this part correct:
7. In the Permission Entry for MailboxOwner dialog box, click User objects in the Apply onto list.
0
 
BembiCEOCommented:
This is just the same than any NTFS permission. To shorten the advice, you have to go to the user properties of the user, you want to give other people permissions, add the user to the list and set the "Send as" permission.

More practical.
You want to allow UserB to "send as" UserA (UserB changes the senders address to UserA):

Open the UserA properties -> Security
Add UserB to the list.
Under enhanced properties, select UserB and enable the right "send as"
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
TruckFanaticAuthor Commented:
OK, thats what I thought.  I went in and gave UserB FULL CONTROL over UserA....still same error.  Should I restart Exchange?  I cant figure what the heck is going on....
0
 
TruckFanaticAuthor Commented:
I even tried adding Full Mailbox rights under the Excange Advanced tab....still same error.    Arrrgghhhh!
0
 
BembiCEOCommented:
Usually, a reboot is not needed, more a relogin of the user, but it maybe a try to reboot the server anyway.  

What happens sometimes, if you run any addins for outlook, that you close outlook, but its not really closed. So a reboot of the client is also a try.

Also have a look at the permissions list, if there are any other users, you have rights (like Domain-Admin). Try to logon as such a user and try to send as..., just to veryfy, that it works in general.
0
 
TruckFanaticAuthor Commented:
Tried rebooting, nada.  Damb, this sucks.

OK, this is freaky, I went back into the user properties under Security, and the user I added is gone again.  It is like every 5-15 min it takes any changes I made out.
0
 
TruckFanaticAuthor Commented:
Here is another tidbit....the Administrators group has full access including Send As for all users, and my user is in the Admins group, so essentially this should have worked without me doing anything.
0
 
BembiCEOCommented:
1.) I'm wondering about, that your user is away after a while. It seems to be that the server is not really storing the permissions.
2.) Yes, you are right, the admin groups has full permissions and the members should be able to "send as" by default.

Any events within the event log?

Also an idea may be to enable the reporting of your exchange. EMC - > properties of the server, there you can track nearly everything.

Can you tell something about your system? Windows version, exchange version, service packs?

0
 
TruckFanaticAuthor Commented:
I am getting ready to leave the office, I will check out and post more info tomorrow......see you then...
0
 
TruckFanaticAuthor Commented:
I found this error, could this be related?  It is the user I am trying to allow to Send As:

Event Type:      Error
Event Source:      MSExchangeIS
Event Category:      General
Event ID:      9671
Date:            5/25/2006
Time:            1:06:11 PM
User:            N/A
Computer:      ODIN
Description:
User truck has exceeded the allowed maximum number of simultaneous registrations for MAPI notifications.

 The configured maximum number of event notification registrations is 8.

For more information, click http://www.microsoft.com/contentredirect.asp.
Data:
0000: 32 00 30 00 34 00 2e 00   2.0.4...
0008: 31 00 33 00 2e 00 32 00   1.3...2.
0010: 33 00 31 00 2e 00 34 00   3.1...4.
0018: 34 00 00 00               4...    
0
 
TruckFanaticAuthor Commented:
I found this too:

Event Type:      Warning
Event Source:      MSExchangeIS Mailbox Store
Event Category:      Rules
Event ID:      1211
Date:            5/25/2006
Time:            1:11:06 PM
User:            N/A
Computer:      ODIN
Description:
User mark@viptrucks.com used ROWLIST_REPLACE to delete all rules in folder 1-22C3. 2 rules got deleted and 1 rules were added.

For more information, click http://www.microsoft.com/contentredirect.asp.
0
 
TruckFanaticAuthor Commented:
Regarding the exchange logging, there are so many things to enable reporting on, what do you think is the best to enable to help troubleshoot this issue?
0
 
BembiCEOCommented:
> Regarding the exchange logging...
MSExchangeIS--> mailbox
You can select everything, what point into direction of that, if you are unsure, select all options and late reduce the settings to errors. My system is germean, so I#m not sure about the english descriptions of all options. But there are a few, which points directzly to that.

Second error, I would say, has nothing to do with that.
The first error, read the following:
http://www.freelists.org/archives/exchangelist/03-2006/msg00091.html
http://www.freelists.org/archives/exchangelist/03-2006/msg00092.html
http://www.freelists.org/archives/exchangelist/03-2006/msg00093.html

Maybe this account has a lot of connections to other mailboxes setup?

Also check your licenses. In comparison to Win2003, which do not take care of client CALs, you have to register Your CALs with SBS Server. If you have more clients than registered CALs, SBS starts making trouble in different situations. This only affects WIN SBS Server.

If you have a normal Win Server, check your system, for viruses and rootkits, following the article above, I you can not explain the MAPI message by some additional mailboxes, which are opened with the account above, there maybe a service, which uses MAPI connections on your system.

This simply for excluding the possibility as I'm wondering, why your server do not strore ACL changes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.