• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1218
  • Last Modified:

Hidden SSID connection problem (URGENT worth 350 points !!)

I have a Windows XP Pro SP2 PC, with a usb Dlink DWL G122  wireless adapter ...

It's configured to use Windows to manage the wireless networks,  when I disable the broadcast of the SSID of my router then manually add the network to my preferred networks ... it never actually connects !!  (automatically connect when within range is enabled).

I have tried this with both a Netgear and a BT wireless router !! the same.

The network it sitting there in my preferred networks list and doesn't connect, if I log into the router and enable SSID broadcast it will connect immediately !! again this is the case on both wireless routers.

Why doesnt this work !! why do I have to enable the SSID broadcast to be able to connect, then disable it after !

Please help ASAP
0
ma77smith
Asked:
ma77smith
1 Solution
 
jhanceCommented:
Turn on the SSID broadcast if you want the WZC autoconnection feature to work.  Otherwise, Windows will not know the wireless network is there and will not connect to it unless you force it manually.

There is, in my opinion, no valid reason for turning the SSID off.  It's not a help security-wise and any of the well known methods for scamming a wireless AP will work regardless of the SSID broadcast.  The best available method to secure your wireless network is via WPA or WPA2 encryption.  Both schemes are relatively robust and will stop all but the most well-funded and determined snoop.
0
 
BellscapeCommented:
Try using the software that came with your Dlink DWL G122 to configure the wireless connection on your PC instead of allowing Windows to configure your wireless connection.  From my experience using the manufacturers wirelsess config tool over the Windows configuration option illiminates problems like this.

Also I agree with jhance if you are disabling the SSID broadcast feature for security reasons ensure you are using WPA encryption.
0
 
Rob WilliamsCommented:
For the record, though I generally remove the SSID broadcast feature, and without a problem, on 2 occasions I could not get 2 D-Link DI-524's on different sites to work with it disabled. Wonder if  D-Links have a problem ? These were both WEP configs, so perhaps the WPA suggestion would resolve.
0
What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

 
benhymanCommented:
I have had a problem with D-Link cards and the windows software not picking up wireless networks when the SSID has been disabled. Try updating any drivers for the card, and if you can update the firmware for the router.

When I was having problems, I ended up leaving the SSID broadcast on (even though I wanted to disable to hide the network). Use WPA2, MAC filtering and you should have a reasonably secure wireless network.
0
 
ma77smithAuthor Commented:
jhance ..

So the WZC will not auto connect without the SSID broadcast on ?

Is this right or just a bug ?  because I sure it used to work prior SP2
0
 
lrmooreCommented:
Wireless Zero Config received a complete overhaul with SP2 along with many other wireless enhancements.
Works just fine with my Linksys wireless with SSID broadcast disabled.
I would take the above suggestions to update the firmware of the router and the wireless USB NIC driver
Else, it could just be a quirk in the Dlink
0
 
JJT2750Commented:
It really doesn't matter if you do or don't advertise it, as soon as you connect to it anyone with the air sniffing tools can see the ssid anyways.  
I would  turn it on and crank up WPA2 and use it.
That way only you and the people you want to will be able to connect.  
0
 
jhanceCommented:
I've never seen WZC connect to non-broadcasting APs.  It has no way of knowing that the AP is available since the AP doesn't advertise itself.  You've always had to manually connect to these "hidden" APs.  Nothing in SP2 changed that...

But, as I and others have already mentioned, disabling SSID broadcast does NOTHING to enhance the security of you network.  And, in fact, I believe will compromise it since it may give you a false sense of security.

Today, WPA-PSK using TKIP is the ABSOLUTE MINIMUM level of security you should use on any wireless equipment.  If your AP or NIC doesn't support WPA, scrap it and get one that does!  Even though TKIP uses essentially the same encryption as WEP, the problem with WEP was NOT the encryption algorithm itself, which is sound, but the LAME IMPLEMENTATION of the WEP scheme in 802.11.

Even better is to use WPA-AES or the newer (but unfortunately still hard to find) WPA2 based systems.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now