No password configured for VNC Auth

Posted on 2006-05-26
Last Modified: 2013-12-27
Hi experts,

I have decided to post this as a separte thread, I might just be lucky. I loaded Realvnc, the client where vnc viewer is running is Windows XP, the server where vncserver is running is a V440 machine running solaris 10 with configured zones.
Now, after setting up a password by running vncpasswd, I started the server, when I try to access the server using vncviewer it prompts me for a password, I then enter the password which I configured with vncpasswd, but it still rejects the password by bring up a pop which reads the following: "No password configured for VNC Auth".
Could some please help me, I have searched google and all resources I know of but I still cannot find a solution.
Question by:mwari
    LVL 38

    Accepted Solution

    When you stat vncserver on V440, did you remember the Xwindow session number such as :1 or :2?

    Then put the session number in Realvnc
    to see
    LVL 14

    Assisted Solution

    Take a look in the .vnc directory of the account where you start the vncserver.

    If you don't kill the previous versions of the server, you may find a bunch of files with names like wesly describes hostname:1 hostname:2 etc

    you will also see a file named passwd  Check the dates and times on these files and see if maybe the passwd file is old (which means it might a a different password then you think.)

    I tried a similar setup on my Solaris to, wwith only one container, and it worked fine.  One difference is that I used tightvnc on the windows box, and the package for vncserver

    Maybe you can delete the .vnc folder (after making sure all vnc sessions are killed.)  I did have a problem with killing some sessions while testing, and had to kill them manually...
    LVL 22

    Assisted Solution

    It means that you need to specify the location of your passwd file when you start the server. For example:

    x0vncserver --PasswordFile=/home/myfolder/.vnc/passwd

    man the version of vncserver that you are using to get the correct format.

    (   (()
    (`-' _\
     ''  ''

    LVL 22

    Expert Comment

    vncserver -help
    Xvnc -help
    x0vncserver -help

    etc to get the full list of parameters.

    (   (()
    (`-' _\
     ''  ''


    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Join & Write a Comment

    When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
    My previous tech tip, Installing the Solaris OS From the Flash Archive On a Tape (, discussed installing the Solaris Operating S…
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
    This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now