SMTP Auth connection delay

Using Plesk and Qmail on Fedora Core 3.

In Plesk, you specify SMTP Auth required.
There is a delay when connecting to the SMTP relay (20-30 seconds) before the email is accepted from the client machine.

I am trying to establish what underlying processes are involved in the AUTH process and acceptance of the email for relay in an attempt to reduce the delay.

Thanks
SF


sheepfarmerAsked:
Who is Participating?
 
PAQ_ManCommented:
Closed, 500 points refunded.
PAQ_Man
Community Support Moderator
0
 
sheepfarmerAuthor Commented:
I wonder if this file has something to do with it?  Comments?

#/xinitd.d/smtp_psa
service smtp
{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        disable         = no
        user            = root
        instances       = UNLIMITED
        server          = /var/qmail/bin/tcp-env
        server_args     = /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
}
0
 
sheepfarmerAuthor Commented:
Sorted it.

If anyone is interested, the -Rt0 argument was added to the server_args line thus:
 
       server_args     = -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true

Basically, this throws away the TCPREMOTEINFO request and sets the timeout to zero.  man tcp-env for details.

SF
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.