can't connect to google via Linksys wireless router

I have a wacko problem that no one can figure out.

I have cable internet.  Works fine if I plug a single computer to it.  I bought a Linksys Router WRT300N model.  It does 802.11 b,g, and Draft N.  Anyhow, I am not using the N part b/c I don't have any N wireless nics.  

I have 3 computers.  Desktop 1 is a XP SP2 desktop using a linksys wireless PCI nic.    It sees the network fine, and I can connect using the WPA key, but the NIC never gets assigned an IP address.  However, if I manually put in an IP address, gateway, and DNS servers, it works fine, except that I can't connect to a few websites including Google.  most other sites connect fine.

The 2nd computer is a new dell laptop with XP sp2 with an internal wireless NIC.  The NIC gets an IP address fine and connects to most sites, but still no Google.  Windows firewall is off but still no google.  I have even flushed the DNS to no avail.

The 3rd computer is a new dell laptop exactly like #2 with an internal wireless NIC.  It gets Google and everything else fine.  

All is well if I plug the any of the computers via patch cables into one of the 4 ports.  They get Google fine that way.

Anyone every come across this problem or can suggest anything to try?  I can't find any config differences between the 2 laptops that might allow one to get to google and one not to.  
ebarroukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
Craig_200XCommented:
sounds like something within the router is crashing... update your firmware... hard reset it... and then reprogram it..powercycle it and then try.
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
ebarroukAuthor Commented:
Yep, it turned out to be a bad router.  I have never heard of a cable router/hub denying access only to a certain website, but there must have been something bad inside.  (I can only guess)

New router works fine.
Thanks
0
 
Craig_200XCommented:
yah this is a weird one to explain.. but it happens alot.. almost always on low end switches.. but sometimes low end routers...
0
 
sasmileyCommented:
Had the same exact problem with the Linksys wireless 300N router/switch.  Could not access Google or Linksys! on the wireless network.  If RJ45 direct connect then fine.  Also cause my Cisco VPN to fail TCP connection.  Hard to find help on the problem!

Thanks
0
 
ebarroukAuthor Commented:
Good replies, guys, thanks.

UPDATE:  I have sent the router back and will get another in exchange.  I will try it and post and update here, so others will know if the Linksys Router WRT300N is any good or not.  I also got a few N cards, and want to see if they live up to the speed and range increase it is supposed to...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.