Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 33213
  • Last Modified:

Hard disk read failure - No bootable devices - Strike F1 to Retry boot, F2 for setup utility

Dell Inspiron 1150 presented with "Hard disk read failure - No bootable devices - Strike F1 to Retry boot, F2 for setup utility" at boot up after POST beeps. Pressing F1 displayed same message. Entering the Dell setup utility showed the HDD correctly identified at 40GB. Loaded Knoppix and could see HDD and all folders and files and was able to transfer files from My Documents to external USB HDD.

Decided to reinstall OS. Deleted existing partition, reformatted using NTFS and reinstalled XP Home SP2 - reinstall was uneventful. Installed system drivers and AVG and performed a number of warm restarts along the way. System seemed fine. Turned off machine and came back two hours later, rebooted and again get  message "Hard disk read failure - No bootable devices - Strike F1 to Retry boot, F2 for setup utility". Checked with Knoppix if HDD file system intact and everything seems OK but cannot boot to windows.

Thought that perhaps the MBR may be corrupt so launched Recovery Console, ran Chkdsk /r, fixmbr - still get "Hard disk read failure - No bootable devices - Strike F1 to Retry boot, F2 for setup utility".

To eliminate possibility of physically damaged HDD, replaced internal HDD with new Hitachi Travelstar and reinstalled Windows XP. Completed stage 1 of installation (partitioning of disk and loading of files). When system restarts to complete second stage of installation again got error "Hard disk read failure - No bootable devices - Strike F1 to Retry boot, F2 for setup utility". New HDD is seen in Dell setup utility as 40GB and disk can be accessed and interacted with via Knoppix.

Need help in sorting this one out as can see no reason why the two HDDs are not seen as a bootable device.

... Bren

0
bbrohan
Asked:
bbrohan
4 Solutions
 
shankshankCommented:
could be the hd controller, hence motherboard...

had same problem with a PC, replaced motherboard, done
0
 
rbmacrossCommented:
You might want to see it they have available an update version of the BIOS.  That sometimes could be the problem.
0
 
mcsa_2003Commented:
Hi,
its ID cable problem

Regards
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mcsa_2003Commented:
remove CD rome cable and connect your HD without CD and try it if no problems go and buy new one

Regards
0
 
applesmashCommented:
Hi,

This is a pretty general error.

The Dells diagnostics utility has served me well in pinpointing the real cause of these errors. Is the Utility partition still on the original drive or accessible?
If not, on another PC, go here and download the floppy version of the diagnostic utilites:

http://support.dell.com/support/downloads/devices.aspx?c=us&cs=RC962167&l=en&s=slg&SystemID=INS_PNT_P4_1150&os=WW1&osl=EN#

When the page loads click diagnostic utilities.
Choose the Graphical User Interface Version.
Download the Floppy version.
Run it and it will prompt you to insert a blank floppy.
Once it's done making the floppy boot to it and you can either run diags on everything or choose to just run diags on specific components.

GL
0
 
FriarTukCommented:
did you by chance run a complete virus scan on the drive?
if a virus duplicated the mbr somewhere else, then everytime the system boots it load the virus
try hooking it to another computer as a slave, boot into safe mode, & run a full virus & spyware scan

partitioning & formatting does not completely wipe a drive, so try using killdisk from a bootable floppy
http://www.killdisk.com/downloadfree.htm

http://www.bootdisk.com
http://www.allbootdisks.com
0
 
nobusCommented:
it can be :
-bad ide cable (as said)
-bad ide channel - try the other one (as said)
-disk startup too slow (should be ok on warm reboot)
you can (if you do not wish to replace your mobo) use a PCI to ide adaptor card :
http://www.tigerdirect.com/applications/category/category_slc.asp?CatId=109
0
 
bbrohanAuthor Commented:
Thanks for comments so far. I should have pointed out that this is a LAPTOP computer, so no IDE cables/connectors involved.
0
 
BennyM82Commented:
Stick the HD in  USB caddy and ensure you can boot from it.
Or stick a different HD in the laptop and rule out the possibility that it is a HD issue.
IDE controller on the laptop motherboard is possible, and is possibly the worst case scenario.
0
 
mcsa_2003Commented:
Hi again,
laptop >>>> Oops sorry

if you have external one try to boot from it
i thing somthing wrong in your bios, or conflicte some where!!!
do you have any external device connected? because you say "Turned off machine and came back two hours later, rebooted and again get  message" i thing conflicte issue ...

Regards
0
 
Nick DennyCommented:
<--"this is a LAPTOP computer, so no IDE cables/connectors involved."-->

I had a Toshiba Satellite with the exact same problem and it was indeed the IDE cable.
Often, but not always, there is some kind of cable/ribbon connecting the hard drive connector to the the motherboard. You wont always see it unless you open up the laptop.

I spent hours trying all sorts of things and eventually replaced the cable - sorted!! I tried the drive (successfully) using an adaptor like this:
http://cgi.ebay.com/Notebook-Laptop-Drive-to-Desktop-IDE-Adapter_W0QQitemZ6885871434QQcategoryZ86759QQcmdZViewItem
in a desktop to confirm the drive was ok.

However, locating a new cable can be a hard task. The one I got was an "Amiga 2.5" hard disk drive cable", (also from ebay).
0
 
bbrohanAuthor Commented:
Seriousnick, thanks for the info on Toshiba Satellite - what I want to get clear in my head is whether I would be able to access the HDD via knoppix if there was a problem with the IDE cable from the HDD connector to the motherboard?

I will be trying the HDD in a desktop tomorrow as I have the appropriate connector for connecting to IDE connector on desktop m/board. But I expect it to work as it is a new HDD and is behaving the same as the old HDD in the Dell laptop.

Will also try the Dell diagnostics floppy - no Dell utility partition on either HDD.

I discount it being a virus as the second (new) HDD has never been connected to the web or any other potential source of viral contamination - it came straight from the manufacturer.

BIOS shouldn't be the source of the problem as it was working one day and not the next (according to customer). No external devices are attached.

Will keep you posted, but keep suggestions coming.
0
 
Nick DennyCommented:
If it helps - I was having random errors.

Some of the time it was ok, and at others, then not.

I put this down to it being a laptop and that if I moved it even slightly maybe something inside shifted just enough for a movement to break a circuit somewhere. And then only the circuit that needed to be running at that moment. (I might add that one the one I was working on, there were signs of casing damage indicating it may have been dropped or badly knocked).

Without knowing if the same pins are used across all systems, it could even be 1 pin wire that has bad continuity that is not used for some o/s maybe? I really don't know.

I'm not saying for sure it is the IDE cable (there may not even be one if the HDD connector is soldered or pinned to the motherboard), just that there are IDE cables in some laptops. Most likley it is a bad mobo.

I can imagine that this is driving you nuts. Good luck - you may well need it!!  :)
0
 
bbrohanAuthor Commented:
<--Often, but not always, there is some kind of cable/ribbon connecting the hard drive connector to the the motherboard. You wont always see it unless you open up the laptop.-->

I just had a look at the way the HDD assembly is arranged inside the laptop and it is one of those occasions when a cable IS NOT used. The HDD connector is a plastic surface-mounted block soldered directly to the mainboard. So faulty cables is off the agenda.

0
 
Nick DennyCommented:
Ah well - sorry to have wasted your time.
I suppose in the "process of elimination" - that process is now eliminated!!
0
 
bbrohanAuthor Commented:
Driving me crazy? Maybe a little.

It's looking more and more like a m/b issue and probably not economical to repair from the customers POV as they bought it second hand for very little, but I like to get to the bottom of problems. There have been some good suggestions and a few leads to follow up - and one thing I will do is load a linux distro to the HDD to see if that will run. The customer only uses it for e-mail and web-browsing so that might be a work around.

'It still bugs me why it won't boot Windows.

Will post back.
0
 
ridCommented:
I had a very similar problem with a Mac a few years ago.... ended up loading Linux (Yellow Dog) on it and it worked (works still). Wouldn't take OS9, though...

Seriously, you may want to try a CMOS reset, if you haven't done that. Could be something with HD detection after cold start that doesn't work properly and that is related to CMOS values. A new CMOS battery may be a good idea, too.
/RID
0
 
applesmashCommented:
Did you run the Dell diags for the 1150 I posted a link to above?
0
 
bbrohanAuthor Commented:
rid,applemash,

will be following up your suggestions tomorrow.


Later ...
0
 
scrathcyboyCommented:
Motherboard problem most likely.  You can try ram replacement first, but either motherboard or on-board controller which are typical failure points on Dell systems.  Have replaced lots of Dell MBs because the HDD controller on board failed.
0
 
bbrohanAuthor Commented:
Put the old HDD back in to Laptop yesterday and, surprise, surprise, it booted first time into Windows. Did a number of warm and cold restarts and came up each time. Took the opportunity to run Dell Diagnostics - all test passed except IDE Disk Read Test, which gave Error Code 0F00:0248 for MSG block 16073215 and a number of other MSG blocks before I cancelled the test. All other IDE tests OK.

This morning I rebooted the laptop and again got "Hard disk read failure - No bootable devices - Strike F1 to Retry boot, F2 for setup utility". I reran the diagnostics for the hard drive and this time the Read Test failed at MSG Block 1, then 2, then 3, etc. Googled the error code but came up with nothing.

Bear in mind that I have got similar behaviour with a brand new HDD, so I'm reasonably confident that the problem is not the HDD.

Anyone confirm that M/B (or HDD controller on M/B) is the problem - or is there something else I'm missing?

 
0
 
bbrohanAuthor Commented:
After running the diagnostics a second time this morning it showed no read errors and the laptop booted into Windows. Since then (about 4 hours ago) I have done warm and "cold" reboots on the laptop and Windows came up each time. However, I suspect that this may be because the m/b is now warm and that the problem tends to manifest itself when the unit is cold. Running the diagnostics test this morning may have warmed up the m/b sufficiently for the fault to disappear, albeit temporarily. I have just switched the laptop off and will let it cool down for 1-2 hours to see what happens when I next power the unit up.
0
 
TEK-01Commented:
Yep you need a new MB as the controllers seem like they are gone
0
 
hawkeyexCommented:
Yeah, probably a new MB is required. Have you contacted Dell Support to see if you can wrangle a RMA from them to get your MB replaced?
0
 
bbrohanAuthor Commented:
Final conclusion is that there is a problem with the MB, probably the silicon that controls the HDD. The problem occurs when the laptop is cold and disappears when the electronics have warmed up a bit - running the Dell Diagnostics for 30-50 minutes does the trick. Customer did not want to pay for a new motherboard and is happy with the warm-up workaround.

Thanks to all who contributed - those who get the points were in early with on target points/suggestions. Applemash gets the lion's share as his pointing me to the Dell Diagnostics really helped identify the read error problem when the system is cold.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now