Mapped drives on losing connection (Windows XP client on Server 2003)

One of my client computers running Windows XP Pro keeps losing connection to the mapped network drives. I have tried everything I could possibly do, but the problem persists. Every morning I come in I have to reboot the client computer, after which the mapped drives will work fine for about 4 hours, then lose connection. This has been going on for about two weeks. I need your help
ericsworldAsked:
Who is Participating?
 
scrathcyboyCommented:
The solution to this is to reinstall all networking parameters on that system, it is easy, takes all of 10 minutes --

1.  go into networking, remove all protocols (remembering what they are).
2. go into device manager and remove networking adapter.
3.  if a laptop, at this point pull out the network card.
4.  Shut down system.  Reboot.  There should be no networking.
5.  when windows redetects the network card, then reinstall the protocols.
6.  Rejoin the domain and make sure that the drives and printers are still shared.
7. reboot again, and you should have forced a refresh of all networking protocols and devices.
0
 
Pete LongTechnical ConsultantCommented:
XP loses Mapped Drives after a few minutes (this process is carried out on the server)

XP does this by default (It's set in the registry) The usual (default is 15 minutes) and its set in the following key..

HKLM\System\CurrentControlSet\Services\Lanmanserver\parameters

In here you will see autodisconect you can set its value in minutes (The valid value range is -1 to 65535 minutes)

To disable it completely set it to -1

For more info see
http://support.microsoft.com/default.aspx?scid=kb;en-us;138365 (This also applies to XP)

Mapped Drive Connection to Network Share May Be Lost
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q297684

In windows 2000 Server environments you can use the following command also
net config server /autodisconnect:-1

Then On the XP Client

Click Start >Run >Type "gpedit.msc" {enter}

Navigate to

Local Computer Policy >Computer Configuration >Windows Settings >Security Settings >Local Policies >Security Options

Scroll down to

"Microsoft Network Server: Amount of idle time required before suspending session"

The default is 15 minutes change it to 99,999
0
 
rickyclourencoCommented:

anything new installed around the time it started happening?  any network changes?

when you say lose connection, are the mappings literally gone when you check MY COMPUTER?  or are the mappings still there, but they just cannot connect to them?

did you Check the compuer for spyware?





0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
ericsworldAuthor Commented:
Nothing was added to the network?
0
 
rickyclourencoCommented:
I would check out some of the things that Pete mentioned above, looks like some good stuff
0
 
trwojcikCommented:
Check the power settings on the network card.

Open Device Manger, Start, Run, devmgmt.msc click OK. Expand Network Cards. Right click on the network card, click properties, click the Power Management tab, clear the check box for "Allow the computer to turn off this device to save power".
0
 
ericsworldAuthor Commented:
Works for the moment. Thank you for the effort. I'll keep track of it in the next few days.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.