cannot view the windows domain

Posted on 2006-05-26
Last Modified: 2010-04-20
Hi ,
i have a linux samba server configured and joined a windows 2003 domain. From a windows workstation i can see the samba server.

The samba server has succesfulyy joined the domain and can ping any other workstation.
when i open nautilus and do
smb://firm  (thats my domain ) i cannot see anything.
Question by:c_hockland

    Author Comment

    actually when i try to do smb://64..83.80.20   (thats another server) it says:

    couldnt display smb:// because no host could be found. check that the spelling is correct and that your proxy settings are correct "

    I can ping  succesfully.

    Any ideas?
    LVL 16

    Expert Comment


    In GNOME go to Computer on your desktop then select network and in network your windows shares should be visable.
    also try this:

    smbclient /
    LVL 2

    Expert Comment

    You can do the following from any terminal:

    smbclient -L /

    This command should list any available resources on the Windows computer that are available to you.  If you get an error, or get no return from it, you may need to check to insure you have your settings in the /etc/samba/smb.conf file correctly setup.


    LVL 87

    Accepted Solution

    I don't know if nautilus understands samba shares. Try konqueror as browser, that I know works.
    LVL 51

    Expert Comment

    add to your /etc/samba/smb.conf:

       wins server         = IP-of-your-wins-server
       wins support         = yes
    LVL 31

    Expert Comment

    Samba server being configured is ok, but you may have to check the samba client settings. PING is not related to a windows domain, it's just TCP/IP.
    LVL 51

    Expert Comment

    > .. but you may have to check the samba client settings.
    I assumed that the server and the client are identical (for the question). Anyway, my suggestion is valid for both;-)
    LVL 1

    Expert Comment

    Seconding Rindi, Try Konqueror for the smb://url/format . Not sure if any other browser is configured for that. I know for a fact Firefox doesn't support the protocol.

    Also, url of the form smb://domain alone might not work.

    Correct format is smb://domain\username@hostname/sharedFolder. Without "sharedFolder" in the URL doesn't work for me. If you guys know why please let me know. Anyway, i'm fine with the current URL format :-)

    Let us know how it goes.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Do You Know the 4 Main Threat Actor Types?

    Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

    SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
    I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension ( This reminded me of questions tha…
    Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

    761 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    9 Experts available now in Live!

    Get 1:1 Help Now