This site has sent an untrusted certificate. continue anyway?

I have made a .DER certificate and used it as a IIS 6.0 webserver certificate. I then went to mmc /Certificates /Local Computer and exported a PKSC 12 file from one of the two certificates there under Personal. I chose the one that had the label "Server authenciation".

This file was then copied to my Nokia E61 Symbian mobile phone. It accepted it.

When I connect to my site with https://DNSadress/virtual directory, I always get the message "This site has sent an untrusted certificate. Continue anyway?". When I continue, it works.

The problem is to get Activesync to work properly, I need to ged rid of this message.

Why do I get this message when I have installed a certifivate on the mobile device? Do I need to use the same PKSC 12 file on the webserver?

What can I do to solve this problem? Please help.
atlixAsked:
Who is Participating?
 
atlixAuthor Commented:
From this: http://www.experts-exchange.com/Web/WebDevSoftware/Authoring/Q_10230668.html?query=untrusted+certificate&clearTAFilter=true

it seems that the message always appears until the root certificate is installed on the device. I installed my root certificate, but it still get this message. I guess it is impossible with a self-made certificate. Can anyone agree with me on this?
0
 
atlixAuthor Commented:
Thanks, I will read it all tomorrow and try it out.
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
atlixAuthor Commented:
Hello again,

I tried the above. Since my Phone is not PPC, most of it does not apply. However, I found  http://support.microsoft.com/?kbid=841060
useful. It put me on the track that I have to get a backend certificate from a CA that is represented by a root certficate on my phone. Verisign is there, so I am in the process of testing out a trial. I made a mistake, though, so I have to wait for Verisign to delete the certificate and start over. I will post back if it solved it. But it means I cannot use Microsoft, even though I added the root certificate.
0
 
atlixAuthor Commented:
It worked perfectly using a Verisign certificate. So my conclusion is: MS does not work on this phone.
0
 
DiTOH1Commented:
I know this is probably a long shot...but I changed the settings from checking in every 15 minutes, to connected and downloading emails continuously...and its working just fine.
Also, I checked in all the other features like notes and calendar as well, but always letting the server win in case of failure.

hope that helps.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.