[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 396
  • Last Modified:

Not remembering passwords

I access a number of Web sites where basic authentication is turned on.

On a machine running XP Home I was getting the username/password popup appearing with the fields prefilled and a checkbox asking if passwords were to be checked remembered.

Now some of the sites have just had the server upgraded to Windows 2003 and during this process authentication was turned off and then turned back on.

Since then the XP machine no longer displays the username and password in the fields and the check box is missing from the dialog box. On a 2000 machine this is not happening.

Does any one know what needs to be done to make the check box re-appear?

Thanks
0
mouatts
Asked:
mouatts
1 Solution
 
war1Commented:
Greetings, mouatts !

What troubleshooting steps have you taken?

Make sure autocomplete is turned on.  Go to Tools > Internet Options > Content tab > Autocomplete button. Check "Remember user names and passwords".  Click OK.

Make sure javascript is turned on.  At the Internet Options menu, select Security tab.  Make sure default security setting is selected. Click OK.

Best wishes!
0
 
mouattsAuthor Commented:
Yes all that is turned on.

As I said this only happened following the server upgrade/cock up. Before that everything was ok and nothing on the XP box has been changed.
0
 
war1Commented:
>> during this process authentication was turned off and then turned back on.

What was exactly turned off?  Are you sure everything related to authentication is turned back on?
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
mouattsAuthor Commented:
During the upgrade the authentication settings weren't copied across to the server. Then they were turned on. It was after this that the problem occurred.
0
 
war1Commented:
Authentication settings need to turned on for the websites for the Remember Password box to be enabled.
0
 
mouattsAuthor Commented:
I'm well aware of what needs to be turned on the server that isn't the issue as I said before this is only effecting an XP box, W2000 is fine and prior to the upgrade everything was ok. But it would seem that because the authentication was turned off and then on again XP has 'decided' not to remember the passwords nor allow it to be re-saved (hence the lack of a check box).

0
 
rgkeleherCommented:
under the previous location, there is another checkbox that asks to prompt to save passwords.  Make sure that is also checked.  Sounds like the usern/pass just need to be resaved.
0
 
mouattsAuthor Commented:
Thanks.

But it was already checked. I tried unchecking, re-checking and clearing old passwords but it made no difference.

Steve
0
 
mouattsAuthor Commented:
I've sussed it. My ISP turned Integrated authentication on as well as Basic once turned off it was ok.

I'll get this deleted.

But thanks all for trying.
0
 
war1Commented:
mouatts,

Ah, ISP changed the authentication!  Glad you were able to fix the problem.
0
 
war1Commented:
OK to refund.
0
 
RomModCommented:
Closed, 250 points refunded.
RomMod
Community Support Moderator
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now