Map C$ share in separate subnet fail: The network path was not found.

Could someone advice me what was wrong:
I have 7 PC (OS is XP SP 2) and a server (OS is Win 2003).
I named the PC A1,A2,A3,A4,B1,B2 and the server S1 for description sake.
PC A1,A2,A3,A4 is in one subnet (X). They all are cloned from a single source disk.
PC B1,B2 and server S1 are in a separate subnet (Y).
PC in subnet X are in the same workgroup (U).
PC in subnet Y are in different workgroup (V).
All the PC are not join to S1 domain.

Now, from B1 or B2, I can mapped to \\A1\C$ but I cannot mapped to A2,A3 or A4,
the error message was "The network path was not found."
A1,A2,A3 and A4 can mapped to each other and S1.
I have enabled "NetBIOS over TCP/IP".
I have stopped the share and rebooted the PC.
All Guest account is disabled.

Why am I able to map to A1 and not A2,A3 and A4?
What went wrong?
michellechan57Asked:
Who is Participating?
 
mvvinodConnect With a Mentor Commented:
What firewall program are you using??? If its a windows firewall, checking File and print sharing in exception does the trick.

Sorry i gave you the wrong port numbers. File and print sharing needs 445, 137-139 to work. So if it is not a windows firewall, try these ports.

Vinod.
0
 
mvvinodCommented:
How are the subnets separated?? Windows only braodcast netbios so the range is only subnet. If computer from one subnet has to access share from another subnet, 2 things has to happen.

Computer 1 should be able to resolve computer 2's name. If both computers are in different subnet, netbiod broadcast dont reach each other. So you have to have WINS server or try accessing using ip address

If you have firewall between the computers/subnets, you have to make sure several ports that is required for windows networking should be opened. For SMB, it is 445. Also some other like 135-137 i think but you should check on that.

Assuming you dont have firewall between the subnets and only a router, if you tried to use ip address, file share should work.

Vinod.
0
 
michellechan57Author Commented:
All PC and S1 points to the same Primary and Secondary WINS server.
I have tried using IP address to map but could only map to A1 and not A2,A3 and A4.
I shall disabled the firewall and try again.
Thanks.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
mvvinodCommented:
When you ping, does that go through between non working machines ??? Are you sure SMB ports are not blocking ??

Vinod.
0
 
KlintanCommented:
What first came to my mind is a question. Did you change the SID for each computer you cloned?
0
 
KlintanCommented:
Otherwise download NewSID.exe from http://www.sysinternals.com/Utilities/NewSid.html
Sorry for the double post
0
 
michellechan57Author Commented:
Vinod,
No problem pinging between any computers.
I tried open port 445,135-137 on A2,A3 and A4, rebooted the PC, cannot map.
But after I disabled the firewall, it work!
What puzzle me is A1 has default firewall setting and yet I can map to its C$ successfully.
Thanks.

Klintan,
I will try NewSID.exe on the next roll out tomorrow.
Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.