• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 519
  • Last Modified:

The file or folder smb://locallinux/shared does not exist.

I am trying to share a folder on FC4 with an winXP machine. I get a  "network path not found" when I try to connect to the folder (I see the Linux machine in Network Neighborhood.)

When I am in konquerer I can see the samba shares icon under network folders and I can connect to any of the windows machines just fine, but when I try to connect to the linux machine I get the "The file or folder smb://locallinux/shared does not exist." error.

Any help on troubleshooting would be appreciated.

Thanks,
james
0
James Stone
Asked:
James Stone
3 Solutions
 
rindiCommented:
Try this from a terminal as root:

/etc/init.d/iptables stop

Then try again. If that helps and you want your firewall active on the linux box, you will have to configure firewall to allow the following ports:

tcp 139, 445
udp 137, 138

0
 
James Stonewarehouse managerAuthor Commented:
I didn't put that I had turned off both the windows and linux firewalls.  Why is linux saying the path is not valid? - Is it a lack of permission?
0
 
ahoffmannCommented:
did you configure locallinux as host in /etc/hosts or your NS? check with
  nslookup locallinux

did you setup y folder shared in you Samba configuration? check with
  smbclient -L locallinux
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
James Stonewarehouse managerAuthor Commented:
How do I configure the host? I put in locallinux in the DNS tab of the network configuration.

Here is the result of the nslookup
[root@locallinux etc]# nslookup locallinux
Server:         199.45.32.40
Address:        199.45.32.40#53

** server can't find locallinux: NXDOMAIN

[root@locallinux etc]#
0
 
ahoffmannCommented:
assuming that you also have not configured locallinux in /etc/hosts (and most likely have not configured /etc/resolv.conf), the question is: why do you use a hostname (locallinux in your example) which is unknow to your system?
0
 
James Stonewarehouse managerAuthor Commented:
When I set up the box the host was default localhost.localdomain, but I later found out that this was reserved by Windows and thought by going to the network configuration and changing the host name to locallinux that it would change it where needed. I guess I was wrong.
0
 
ahoffmannCommented:
localhost is usually maped to 127.0.0.1, which may never cause conflicts
hence localhost is never a remote host name, for obvious reason

In your case, you configured your Linux's hostname to be locallinux, this locallinux must be mapped to the IP (for example 192.168.1.1), while localhost is always 127.0.0.1 on every machine (even your windows).

Don't know what "going to the network configuration and changing the host name" really does on your system, but after doing that you should have locallinux mapped to its IP. Check with:
  ifconfig -a
  ping locallinux
If both report the same IP, you should be able to use smb://locallinux/ from this mashine.
To connect from another mashine, you either need to setup DNS, or better add locallinux to the WINS server if you have one. In smb.conf you can also define the netbios name to be locallinux.
0
 
aravinthrkCommented:
Also, in addition to what hoffman says, you will have to define the directory 'shared' to be actually shared in the smb.conf file. In order to do this in Fedora, you can use the Samba GUI utility. To invoke this utility, use the 'system-config-samba' from root.

Let us know how it goes,
Good luck
Aravinth.
0
 
James Stonewarehouse managerAuthor Commented:
I haven't time to play with linux box until this holiday weekend.  I ended up reinstalling the OS and setting the host name from the beginning.  I finally got all three parts (host name, share, and firewall config) working and now have a file server for my home!

Thanks for taking the time to explain what needed to be...
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now