DHCP Scope not working / DNS problem?

I recently installed Win2k Server and have until now been using the router to assign IP addresses and share the internet.
But the internet on random clients has been dropping out until the computer is rebooted. I assume this is some sort of DNS problem, as I have (in the router) the primary DNS set to our ISP's DNS and the secondary set to the 2k server.

Anyway, to cut it all short I assume if I share the net through the server it will help solve this problem but after I create the scope, it just wont assign any computers an IP.

I'm a bit of a noob with this so any help will be appreciated thanks!
TechyheadAsked:
Who is Participating?
 
Michael PfisterConnect With a Mentor Commented:
3 things to check:
- Is the routers DHCP turned off?
- Did you authorize the DHCP (open DHCP manager, right click on the server, Authorize)?
- Is the DHCP scope active?

Hope it helps,

Michael

0
 
rindiCommented:
The DNS on the server must be pointing to itself, don't enter any other DNS  servers, in particular not that of your ISP.
0
 
Walter PadrónCommented:
Hi Techyhead,

- First of all, you must not have a DHCP server on the router and the server assigning the same scope.
- Follow mpfister advice and Autorize DHCP server (Open DHCP manager, right click on the server, Authorize, enter IP address).
- On the client run ipconfig /renew and check the lease.
- Let the clients point the DNS to your router, i suggest you to move one service at a time, first move the DHCP from the router to the w2k and when working then prepare to move DNS.

cheers
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
TechyheadAuthor Commented:
I have tried all of the above previously, apart from Authorizing the DHCP, will try that tomorrow and get back to you.
I noticed when setting up the scope I can add an option to point to address of the router? Should I do this or just skip setting the scope options?

Thanks
0
 
rindiCommented:
No, if you are using an AD domain, only that should do dns, and no other DNS servers should be known to the other boxes. The server will pass those addresses it can't resolve on to the internet by itself.
0
 
Michael PfisterCommented:
Here is what I'd set in DHCP:

Option                 Value
003 Router          <your routers ip address>
006 DNS Server   <your DNS servers IP>, <your ISPs DNS>
015 DNS Domain  <your internal AD domain name>

If you have WINS:
044 WINS/NBNS Server <your WINS server>
046 WINS/NBT Node Type 0x8

Like Rindi wrote, let the servers DNS point to itself and configure the DNS to forward requests to the ISPs DNS. In DNS Manager right click on your server, select properties, select thge Forwarders tab and enter your ISPs DNS server address.

Hope it helps,

Michael
0
 
TechyheadAuthor Commented:
I can't believe I didn't see the big Status window that says "You must Authorize the server".

Thanks alot guys.

Brett.
0
 
Michael PfisterCommented:
> I can't believe I didn't see the big Status window that says "You must Authorize the server".

Happens to all of us from time to time...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.