• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 831
  • Last Modified:

OWA how to remove domain name from username login

I am running Exchange 2003, and when I try to access OWA, I enter my username.  Instead of logging in, the login box reappears, which it then automatically appends the full name such as: 'exch1.mydomain.com\username'.  I try with this, and it fails as well.  If I just enter 'mydomain\username', I have no problems accessing OWA.  I went into IIS and tried modifying the default website > directory security > authentication > default domain setting to '\', but that had no effect.  Other than this, I'm not sure what to try...
0
bleujaegel
Asked:
bleujaegel
  • 4
  • 4
1 Solution
 
mvvinodCommented:
Do the same thing for "exchange" virtual directory and restart IIS Admin service and then test again.

Vinod.
0
 
bleujaegelAuthor Commented:
That had no effect.  I checked the authentication and security settings for the 'Default web site', 'Exchange, and 'Public'.  They all match.  I can login to the public folder fine using 'mydomain\username'.  I cannot login this way to the \exchange directory, however.  It still pops back up with the full host name, which then fails as well.  

The 'public' directory default domain is listed as 'mydomain'.  I then change the 'Default web site', and 'Exchange' directories back to this.
0
 
mvvinodCommented:
How many domains do you have??? If you replace it with domain name instead of \, does it work??
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
bleujaegelAuthor Commented:
I'm using one domain only.  It doesn't work with 'mydomain' for the exchange directory, but it works fine accessing the 'public' folders in the form domain\username.  Maybe I'm looking in the wrong place, and it's something else misconfigured.
0
 
SembeeCommented:
If you are on Exchange 2003 SP2, and have SSL, then simply enable Forms Based Authentication. You don't need to make any changes to the IIS configuration - the web page does it for you (despite what the page might actually say). It was an undocumented change in the service pack.

Simon.
0
 
mvvinodCommented:
Using credentials in domain\user form should work at any place. I understand that you are trying to use username only authentication for exchange and public folders.

Is the client machine you are connecting from also the same domain???? Have you made sure you unchecked "Integrated authentication" if you dont need it???

Vinod.
0
 
bleujaegelAuthor Commented:
Yes, unchecking "Integrated Windows authentication" solved the problem.  What is the purpose of this?  More specifically how does non-integrated Windows authentication differ from integrated?
0
 
mvvinodCommented:
Integrated authentication means that when a domain user logs on to a domain computer and opens the website (eg. OWA) windows automatically passes the credentials, authenticates the user and opens OWA mailbox for that user without prompting the user for credentials.

If only Basic authentication is enabled, no matter user/computer, user will have to put in username and password to open the page.

Vinod.
0
 
bleujaegelAuthor Commented:
Thanks for the info!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now