?
Solved

Background Intelligent Transfer Service Doesn't Work

Posted on 2006-05-30
17
Medium Priority
?
785 Views
Last Modified: 2011-05-09
I'm trying to install various MS products, and I get an error regarding BITS (Background Intelligent Transfer Service). I try tio run it manually from services: but I get Error 1083: The executable program that this service is configured to run in does not implement the service.

0
Comment
Question by:andersonmarske
  • 10
  • 7
17 Comments
 
LVL 15

Expert Comment

by:venom96737
ID: 16789010
go back into the services and make sure that the path to the executable is set to C:\WINDOWS\system32\svchost.exe -k netsvcs
then start the service.
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16789069
if that doesnt help try the steps listed in this KB you should get it back up http://support.microsoft.com/?kbid=910337
0
 

Author Comment

by:andersonmarske
ID: 16789071
It's set as that. Doesn't work.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:andersonmarske
ID: 16789085
I don't get an error code like that, and it happens when installing products such as VB.net Express.

Also, that link doesn't tell me how to fix it.
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16789105
Error 1083: The executable program that this service is configured to run in does not implement the service. (0x8007043B)
If you receive this error message, follow these steps:1. Click Start, click Run, type Regsvr32 %windir%\system32\qmgr.dll, and then click OK.
2. Click Start, click Run, type regsvr32 %windir%\system32\qmgrprxy.dll, and then click OK.
3. Click Start, click Run, type services.msc, and then click OK.
4. Double-click Background Intelligent Transfer Service.
5. In the General tab, click Start.
0
 

Author Comment

by:andersonmarske
ID: 16789117
That still doesn't work.
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16789123
did they say registered or did it error out
0
 

Author Comment

by:andersonmarske
ID: 16789142
It said successful. Will I need to reboot?
0
 
LVL 15

Accepted Solution

by:
venom96737 earned 1500 total points
ID: 16789144
ok try going to start run  regedit and looking here HKey_Local_ Machine\ Software\Microsoft\WindowsNT\CurrentVersion\SvcHost
see if there are entries refering to BITS & WUAUSERV
0
 

Author Comment

by:andersonmarske
ID: 16789157
No, there are not.
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16789171
You will find it under netsvcs righ click and modify and ensure that both entries are in there BITS and wuauserv if they are not just add them.
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16789175
make sure you are clicked on the folder for svchost then goto the nersvcs entry and do as stated above.
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16789182
you should see a list of other services used by the netsvcs
0
 

Author Comment

by:andersonmarske
ID: 16789199
In the registry it's not under Svchost and netsvsc. In the HKey_Local_ Machine\ Software\Microsoft\WindowsNT\CurrentVersion\SvcHost\netsvsc there is just some, what appears, to be hex under AuthenticationCapabilities and CoInitializeSecurityParam. In SvcHost neither are there. So what, and where, do I add these two entries?
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16789218
there are two places that you will see netsvcs make sure you are not looking in the folder you should be clicked on the svchost folder and on the right hand side you will see a netsvcs that looks like a piece of paper with red abin it right click it goto modify and check the list  or BITS and wuauserv if they are not there write them in make sure to click in the box so that all entries are not highlighted then write them in.
0
 

Author Comment

by:andersonmarske
ID: 16789236
Yep, I was looking in the wrong place. I added wuauserv, BITS was already there. Still no luck. Do they have to be in alphabetical order?
0
 
LVL 15

Expert Comment

by:venom96737
ID: 16789240
you have to reboot for it to take effect
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you build your web application in Visual Studio you'll get at least a few binaries, or .DLL, files in your bin folder. However, there is more compiling to be done. Normally this would happen when an ASP.NET resource within the web site is request…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Suggested Courses

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question