[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1555
  • Last Modified:

Exchange 2003 MTA Settings

I've had mail bounce back to me from verizonwireless recently.  I telnet-ed to their mail host and got the following message.  I've checked senderbase.org and it does not state that we are on any restricted lists.  So it must be our MTA perhaps?  Does anybody know what settings I need to change on Exchange 2003 SP1 (running on Server 2003 R2) to clear this up?  I assume we're having trouble with other mail domains too but I can personally confirm this one at this time.

554-mercury.verizonwireless.com
554-Your access to the VZW mail systems has been rejected due to the sending MTA
 or Network Service Provider's poor reputation  / e-mail hygiene on the Internet
.
554-
554-Please reference the following URL for more information:
554-http://www.senderbase.org/search?searchString=67.111.248.151
554-
554 If you believe that this failure is in error, please contact the recipient v
ia alternate means.


Connection to host lost.

Thanks in advance.
0
STorabi
Asked:
STorabi
1 Solution
 
SembeeCommented:
Nothing comes up in the RBL lists either:
http://www.robtex.com/rbls/67.111.248.151.html

However. your server isn't announcing itself correctly.
Or to to more precise, you have a PIX.

When I telnet in to port 25 on that IP address, the banner is this:

220 ****************************************************************************
****************************************

It should be something like this:

220 IGT-IMC-02.redmond.corp.microsoft.com Microsoft ESMTP MAIL Service <Inbound
SMTP Virtual Server> Tue, 30 May 2006 16:23:49 -0700

On the PIX, disable the fixup SMTP command
http://support.microsoft.com/default.aspx?kbid=320027

What is happening is the recipient is using the SMTP banner to check whether the host is valid or not. As you aren't presenting anything in the banner, the email is rejected.

You should also ensure that your DNS is set correctly: http://www.amset.info/exchange/dnsconfig.asp

Simon.
0
 
STorabiAuthor Commented:
Sembee, thanks very much for the response.  Although I can't verify your theory at this time (I am sadly not the firewall administrator).  I will award you the points for your clear explanation and supporting links.  Thanks
0
 
Anthony H.Commented:
so there was no solution. i'm having the same problem but no solution yet?
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now