Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1092
  • Last Modified:

SMTP Sending Issue (Outlook works but Outlook Express doesn't)

Hello,

  Like a million other users I'm receiving the following error code:

---------------------------
Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'Remote Mail', Server: 'mail.######.com', Protocol: SMTP, Port: 2525, Secure(SSL): Yes, Error Number: 0x800CCC0F
---------------------------

System:  Windows 2003 Server Advanced, Exchange 2003

Here is the log entry for the SMTP service

date time c-ip cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-win32-status cs-version cs-host cs(User-Agent)
2006-05-30 13:24:01 x.x.x.x - SMTPSVC1 MAIL-SERVER 192.168.1.8 0 QUIT - - 240 32 SMTP - -
2006-05-30 13:24:04 x.x.x.x - SMTPSVC1 MAIL-SERVER 192.168.1.8 0 QUIT - - 240 16 SMTP - -
2006-05-30 13:24:04 x.x.x.x - SMTPSVC1 MAIL-SERVER 192.168.1.8 0 QUIT - - 240 0 SMTP - -
2006-05-30 13:24:05 x.x.x.x - SMTPSVC1 MAIL-SERVER 192.168.1.8 0 QUIT - - 240 31 SMTP - -
2006-05-30 13:24:05 x.x.x.x - SMTPSVC1 MAIL-SERVER 192.168.1.8 0 QUIT - - 240 0 SMTP - -

This error happening in Outlook Express (OE).  The odd thing is that it does not happen in Outlook.
Server name / SSL / Ports are all configured correctly.
My certificate is self-signed.  I wonder if this is an issue with OE, since my Outlook gave me a warning message that the cert could be fake.  Maybe OE doesn't know what to do with it.  I have installed the certificate into Internet Explorer to see if that helped, but it didn't.  Any ideas?

Does anyone know where I can find a listing of the 'sc-status' and 'sc-win32-status' log codes?

Thanks,
DAve
0
dauyeung
Asked:
dauyeung
  • 10
  • 7
  • 2
  • +1
1 Solution
 
upul007Commented:
I had this issue when i configured my gmail account on OE. The program would start downloading and give this error. I could not figure this out. Tried creating a new account manually and using the auto config tool provided by gmail. Nothing worked. Setting server time outs did not help. Finally shifted all the emails to another folder and created account. Send & recieve worked.  
0
 
dauyeungAuthor Commented:
No emails in folder.  Receiving works fine.
0
 
war1Commented:
Greetings, dauyeung !

1. Register an important send/receive library file.  Go to Start > Run and type regsvr32 inetcomm.dll

2. Check if antivirus email check is slowing sending and receiving.  Disable it.

3. In the account settings, Advanced settings, change the server timeout time from 1 min to 5 min

4. Check if outgoing mail server authentication is required. Select that option in account settings and use same settings as incoming server

7. See this troubleshooter for not sending
http://www.slipstick.com/problems/nosend.htm

Best wishes!
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
dauyeungAuthor Commented:
1. Done
2. Already tryed
3. I don't think it's not a timeout issue, because it returns the error right away.
4. I am the admin and trying to make authentication required.  It sends fine when SSL is off.  However, I want all my users to send emails encrypted so that all internal email is never sent in clear text.

Thanks
  DAve
0
 
war1Commented:
Part of your error message is "or a long period of inactivity".  This sounds like a timeout issue to me.  Increase the server timeout time to 5 minutes.

I noticed the title is "Remote Mail".  Are you trying to send using VPN or a remote network?

If no joy, delete the account in Outlook Express, and then recreate it.
0
 
dauyeungAuthor Commented:
No go.  The message is a generic Microsoft issue.  The server logs indicate the SMTP service is dropping the connection for some reason.  And the reason is an sc-status of 240 or an sc-win-status of 31, 32, 16 or 0.

Thanks.
0
 
war1Commented:
Dave,

1. A recent Outlook Express update, KB 911567, can cause the problem.  The only fix now is to uninstall it from Add/Remove Programs > Show Updates and then disable Windows Autoupdate.

2. Register an important Outlook file. Go to Start > Run and type regsvr32 OLE32.DLL

3. Create a new Outlook Express identity.
http://support.microsoft.com/kb/209169

4. Repair or Reinstall Outlook Express.
http://www.theeldergeek.com/repair_reinstall_ie_and_oe_6.htm
OR
http://support.microsoft.com/default.aspx?scid=kb;EN-US;318378
0
 
war1Commented:
Dave, any update?
0
 
dauyeungAuthor Commented:
Unfortunately, no progress.  Another user at the same location is getting the same error, which suggests that it might be an issue with the network, or network compatibility or latency.  These two people are the farthest people that are trying to connect.  My network has a firewall and antispam software.  I doubt that they are causing a latency issue, but it is possible.  Any other thoughts?

DAve
0
 
dauyeungAuthor Commented:
Sorry, I thought this was concerning my users.  The OE issue continues, but two of my users that are using Outlook have the same/similar issue.  They get the same error.  However, all my other users that are using Outlook do not have the issue.

Thanks,
  DAve
0
 
war1Commented:
This does sound like a latency issue.  Antivirus check of emails can cause latency, so that SMTP server times out during virus check.

Did you increase the server timeout time to 5 minutes?
0
 
dauyeungAuthor Commented:
Done.  Same problem.  It doesn't wait at all to give the response.  The error comes back within seconds.

DAve
0
 
war1Commented:
Dave, temporarily disable the Firewall.  It may be blocking the sending of the emails.
0
 
dauyeungAuthor Commented:
No, it's not that.  There are many other users that can send emails.

Thanks
0
 
dauyeungAuthor Commented:
Does anyone have any other ideas?

DAve
0
 
war1Commented:
Dave, the suggestion of increasing the server timeout time may fix the problem, as increasing the time allows for the latency.  But you do not want to try it.  So I do not have any more suggestion.
0
 
dauyeungAuthor Commented:
Increasing the timeout did not work.

DAve
0
 
upul007Commented:
The error code 0x800CCC0F is defined as given below.

C:\>err 0x800CCC0F
# for hex 0x800ccc0f / decimal -2146644977 :
  IXP_E_CONNECTION_DROPPED                                      imnxport.h
# 1 matches found for "0x800CCC0F"

C:\>err 2146644977
# for hex 0xffffffff / decimal -1 :
  NO_TITLE                                                      ftsiface.h
  USE_DEFAULT                                                   ftsiface.h
  JET_wrnNyi                                                    esent98.h
# /* Function Not Yet Implemented */
  LZERROR_BADINHANDLE                                           lzexpand.h
# /* invalid input handle */
  MAPI_DIAG_NO_DIAGNOSTIC                                       mapidefs.h
  MSIDBERROR_FUNCTIONERROR                                      msiquery.h
# function error
  ERROR_UNHANDLED_ERROR                                         ntddchgr.h
# Unknown error condition
  PDR_ERROR                                                     penwin.h
# parameter or unspecified error
  ICERR_UNSUPPORTED                                             vfw.h
  ERROR_UNHANDLED_ERROR                                         winioctl.h
# Unknown error condition
# 10 matches found for "2146644977"

What could cause a connection drop at your location? Is the other user getting the exact error? Are you using POP or IMAP or both?
0
 
dauyeungAuthor Commented:
Firewall could cause the drop, but I don't see it in the FW logs.  Looks like I will check with the other user to see what error they are getting.  We are using POP.

Problem worked around.  I used another server.  I don't understand why the second server worked.  It is basically the same setup except that the second server doesn't use Active Directory authentication, it uses local user. And there's a certificate on the first server, which really shouldn't affect not encrypted connections.  I will look into possible AD replication issues.

Well, if you have any other suggestions I would appreciate it, since I would like to get rid of this work around.  I don't like the fact that one user (possibly two in the future) will be using a second server to send emails when the rest of the organization is using another server.

DAve
0
 
ee_ai_constructCommented:
PAQ / Refund
ee ai construct, community support moderator
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 10
  • 7
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now