[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

PIX Firewall "policy NAT" problem

Posted on 2006-05-30
5
Medium Priority
?
719 Views
Last Modified: 2013-11-16
I have a PIX 501E that I'm using VPN to connect to several locations via static tunnel and VPN client.  Everything works and there's no problem.  However when I use the PDM I get the annoying message :

PDM has encountered a firewall configuration command statement that PDM does not support.  Configuration parsing has been stopped. BLAH BLAH BLAH..

PDM does not support "policy NAT" commands in your configuration.
BLAH BLAH
(We've seen this before)..  

Here is the offending line in my case:  
static (inside,outside) 10.254.218.0 access-list trans 0 0

I'm not that great with command line or IOS, so I prefer to use the GUI.  How can I alter my configuration to accomplish the same objective w/o having to use "policy NAT" in my config?

Thanx!

Randy

Here is my config:

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password T4GKBJ5AuIeoIa/q encrypted
passwd 9jNfZuG3TC5tCVH0 encrypted
hostname pix501e
domain-name mycompany.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list 101 permit ip 192.168.2.0 255.255.255.0 10.1.3.0 255.255.255.0
access-list 117 permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list split-tunnel permit ip 192.168.2.0 255.255.255.0 10.1.3.0 255.255.255.0
access-list cryacl1 permit ip 10.254.218.0 255.255.255.0 68.241.41.192 255.255.255.192
access-list trans permit ip 192.168.2.0 255.255.255.0 68.241.41.192 255.255.255.192
pager lines 24
logging on
logging monitor warnings
logging buffered warnings
mtu outside 1500
mtu inside 1500
ip address outside 61.105.50.158 255.255.255.240
ip address inside 192.168.2.21 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.3.1-10.1.3.254 mask 255.255.255.0
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.2.0 255.255.255.0 inside
pdm location 68.241.41.192 255.255.255.192 outside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 192.168.2.4 255.255.255.255 inside
pdm location 192.168.2.253 255.255.255.255 inside
pdm location 10.1.3.0 255.255.255.0 outside
pdm location 192.168.2.2 255.255.255.255 inside
pdm location 192.168.2.11 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 2 interface
nat (inside) 0 access-list 101
nat (inside) 2 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 10.254.218.0 access-list trans 0 0
route outside 0.0.0.0 0.0.0.0 61.105.50.145 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.2.2 255.255.255.255 inside
http 192.168.2.253 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-sha-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map rtpmap 5 ipsec-isakmp
crypto map rtpmap 5 match address cryacl1
crypto map rtpmap 5 set peer 68.241.43.232
crypto map rtpmap 5 set transform-set myset
crypto map rtpmap 20 ipsec-isakmp
crypto map rtpmap 20 match address 117
crypto map rtpmap 20 set peer 24.105.196.74
crypto map rtpmap 20 set transform-set myset
crypto map rtpmap 100 ipsec-isakmp dynamic dynmap
crypto map rtpmap interface outside
isakmp enable outside
isakmp key ******** address 24.105.196.74 netmask 255.255.255.248 no-xauth no-config-mode
isakmp key ******** address 61.241.43.232 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp keepalive 300
isakmp nat-traversal 20
isakmp policy 5 authentication pre-share
isakmp policy 5 encryption 3des
isakmp policy 5 hash sha
isakmp policy 5 group 2
isakmp policy 5 lifetime 86400
isakmp policy 25 authentication pre-share
isakmp policy 25 encryption 3des
isakmp policy 25 hash md5
isakmp policy 25 group 2
isakmp policy 25 lifetime 86400
vpngroup myvpn address-pool ippool
vpngroup myvpn dns-server 192.168.2.253
vpngroup myvpn wins-server 192.168.2.253
vpngroup myvpn split-tunnel split-tunnel
vpngroup myvpn idle-time 1800
vpngroup myvpn password ********
telnet 192.168.2.2 255.255.255.255 inside
telnet 192.168.2.253 255.255.255.255 inside
telnet timeout 5
ssh 192.168.2.2 255.255.255.255 inside
ssh 192.168.2.253 255.255.255.255 inside
ssh timeout 60
management-access inside
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
0
Comment
Question by:rejma0415
  • 2
3 Comments
 

Author Comment

by:rejma0415
ID: 16790033
Note: the one VPN tunnel that goes from 192.168.2.X (our side) to 68.241.41.X has to have the 192.168.2.X get natted to 10.254.218.X before getting to 68.241.41.192 because of a duplicate IP subnet on the 68 side...
0
 
LVL 9

Accepted Solution

by:
stressedout2004 earned 1000 total points
ID: 16795216
There's no PIX501E so I am assuming that it is a typo on your part. Its either PIX501 or PIX506e

Unfortunately there's no other way to modify your configuration other than to change your internal IP scheme. I know it is easier said than done, but there's no other means.

Policy NAT is an advanced configuration and the PDM does not support it. The ASDM I believe does but it is not available in the platform that you have.
0
 

Author Comment

by:rejma0415
ID: 16798015
Thanx I appreciate it.  Yup It was a typo. :)

-Randy
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question