Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 566
  • Last Modified:

samba - network path could not found

samba ver 3.014 ubuntu linux 5.10  xp

trying to map a drive letter to a samba share using windows xp results in the error
"The network path \\ubuntu1\clients\ could not be found.

I am able to browse to the folder, but get the error when I click "Finish"

I am able to map a drive letter to my home <dir> on the samba box, but apparently no other shared drive

any help appreciated



0
Pookas
Asked:
Pookas
  • 3
  • 2
1 Solution
 
canaliCommented:
Try to use \\UbuntuIpAddress\share
Get the error again?
0
 
aravinthrkCommented:
I assume the usernames in both your Ubuntu and XP is same. In that case, you will be able to access the User share automatically (Haven't played around to see why this is the case, but it works that way!! :-)  My guess is Windows Networking sends the current logged in username/password to the Linux Box to authenticate for your home folder in Linux which has the same username and hence it is allowed...).
However, if you want to share other folders, you have to make sure your smb.conf has appropriate permissions to the particular folder.

Can you please paste your smb.conf file here?

Good Luck,
Aravinth.
0
 
PookasAuthor Commented:
still get the error using the ip address

here is the smb.conf:

#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
#

#======================= Global Settings =======================

[global]
      log file = /var/log/samba/log.%m
      name resolve order = wins bcast host
      idmap gid = 10000-20000
      socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
      username map = /etc/samba/smbusers
      encrypt passwords = yes
      dns proxy = no
      netbios name = ubuntu1
      idmap uid = 10000-20000
      workgroup = TRISTAR
      os level = 20
      syslog = 0
      security = user
      max log size = 1000
        wins support = no

[homes]
   comment = Home Directories
   browseable = no


[printers]
   comment = All Printers
   browseable = no
   path = /tmp
   printable = yes
   public = no
   writable = no
   create mode = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no


[Clients]
     path = /Shared/Clients
     create mode = 777
     available = yes
     browseable = yes
     public = yes
     writable = yes
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
aravinthrkCommented:
try this:
In smb.conf:
========
[LinuxShare]
      path=/path/to/SharedFolder
     writeable=yes
     browseable=yes
     valid users=#your username here...
     
In /etc/samba/sambausers:
=================
Add the following line in the sambausers file.

yourUserName = yourUserName


Restart:
=====
as SuperUser, do
#killall smbd
#killall nmbd

followed by

#smbd
#nmbd

Now try accessing your favorite folder.

Let us know if this works.
Good Luck
Aravinth.
0
 
PookasAuthor Commented:

made your requested changes and re-booted the linux box

still no go.

weird
0
 
PookasAuthor Commented:
got it to work

had to add myself as an admin user, using the syntax

admin users=my user name
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now