Qmail not sending

Posted on 2006-05-30
Last Modified: 2009-01-06

Hello -

I lease a dedicated root server at (fedora 2).
The server has PLESK 7.5.4 preinstalled.
The email server application is Qmail.
I have it configued for authenticed smtp.
The pop3 works OK and receives mail.
However the server (MTA) will not send
any mail from any mail account or via any system service
for notifications.

The log information in brief is reporting:
delivery 577: failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as_local._(#5.4.6)/

The email messages are contained within the "Mail Queue", but are not being sent.
Presumable due to the error message above.

Tried to send through a php application by changing php.ini.
I have changed a suggested php.ini setting from:
sendmail_path = /usr/sbin/sendmail -t -i/

To: sendmail_path = /var/qmail/bin/qmail-inject
And restarted the server.
(No Result)

All DNS entries appear correct.

Qmail files:





Working on this for six days with customers waiting to be moved
to this server promised weeks ago. Any and all help would be most


Question by:osdfoster
    LVL 43

    Expert Comment

    Well, it looks like the recipient domain is not in Your control/locals - since it contains only localhosts (is it type? did You mean localhost?)
    it's very propable.

    You may think, that if the domain is in virtualdomains, all is fine - but it's not.
    The entry '' tells qmail to rename to and try delivery. But the delivery is still to - which is not in locals.
    It can be tweaked/redirected with users/assign (users/cdb) file to next address is You like - possibly to 1-username@localhost or another alias directory(like /var/qmail/alias)

    However control/locals should not contain localhost anyway - it's often tested by open-relay testers if localhost is relayed.

    Author Comment

    Hi again,

    I have placed the domain name in control/locals as suggested.
    i.e. [ ]

    I get the same result of non delivery to internal virtual domains
    or to addresses in the outside world.

    Now it appears that I have broken the pop3 as it is no longer
    accepting outside mail.

    I can't figure out what I messed up.

    Any ideas are sure appreciated.


    Author Comment

    Dear Experts,

    After weeks of fighting this problem and having to deal with the Philipine out-sourced 1and1 support people,
    I determined the fault was not that of a configuration error, but rather of a unresolved DNS error at

    I suggested this to them and as usual they did not persue the issue. Their only check was that they could email
    to and from Qmail ( as could I from ) another network. The problem was that email was not being received by
    certain Domains on another machine within's network which we lease.

    Anyway, I had them provision another machine (at my cost, of course) and it has no Qmail problems with the
    same configuration as the other machine. And no DNS issues either at this time.

    Be advised that one should use extreme care when leasing hosted servers from
    You get what you pay for ;)  I will be looking to move ourselves and our customers to another
    host early next year. We lease (3) top end servers from 1and1 and have never received support that wasn't

    Consider this question closed .....

    LVL 1

    Accepted Solution

    PAQed with points refunded (500)

    Community Support Moderator

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
    Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    This video discusses moving either the default database or any database to a new volume.

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    9 Experts available now in Live!

    Get 1:1 Help Now