Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Remote Desktop Connects From One Computer To The Other, But Not The Other Way Around

Posted on 2006-05-30
32
Medium Priority
?
258 Views
Last Modified: 2010-03-18
I have Windows XP Pro on two computers.  Windows Firewall is turned off.  I can use remote desktop to connect from computer "A" to computer "B", but it will not work in the other direction.  They are both on my local network.  The message I keep getting is "The client could not connect to the remote computer".  All computers have remote desktop enabled.  I have read another article on here and the solution was to turn of windows firewall.  That didn't work for me.
0
Comment
Question by:Rigel222
  • 14
  • 10
  • 8
32 Comments
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16794805
Hi Rigel222,

any other firewalls enabled?

can you ping in both directions and resolve names?
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16794810
do you have the router(s)>>>both sides of connection, configured to allow incoming/outgoing packets for RDP?
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16794863
@rigel222, gave you bad dope... forget what I said.

Right click on my computer and choose PROPERTIES, then go to Computer NAME tab, then click NETWORK ID. Follow the prompts that identify your network.  Do this to both computers.

Restart your computer(s)

Recreate the shares (delete any shares prior).

Attempt RDP, and post your results
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:Rigel222
ID: 16794890
No dice.  I followed the wizzard, and the same thing still happens.  Both computers can access the internet, and ping each other.  They each have successfully mapped network drives to each other.  Only one accepts incoming Remote Desktop connections.  Unfortunately, the one that doesn't accept them is the one that I need to.
0
 

Author Comment

by:Rigel222
ID: 16794891
They are both connected to the same router.
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16794896
yes hence irwins apology..... do you have any other firewall appz, have you tried reenabling RD can you resolve both by name
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16794899
very odd, what does the event viewer say, sorry mate i missed your first post :)
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16794903
are you accessing by IP or by hostname?
0
 

Author Comment

by:Rigel222
ID: 16794909
No other firewalls.  I have unchecked and rechecked allow Remote Desktop connections.  I don't know what you mean by resolve by name.  What is the event viewer?
0
 

Author Comment

by:Rigel222
ID: 16794912
I am accessing both by IP.  I have tried using the names, that only works in one direction also.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16794917
Did you apply this?

Right click my computer > properties > remote > allow users to remotely connect to this computer on the controlling computer > start > all programs > accesories > comunications > remote desktop

AND

Vice Versa?
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16794919
your rdp is obviously setup fine,

you need to check your logs  right click my computer choose manage - event viewer - application and system logs
0
 

Author Comment

by:Rigel222
ID: 16794922
Yes, of course, they both have "allow users to remotely connect" CHECKED, and I am running "remote desktop", I am doing so from a shortcut though, because it's quicker than "all programs >accessories >communications > remote desktop"
0
 

Author Comment

by:Rigel222
ID: 16794923
On which computer should I run the event viewer?
0
 

Author Comment

by:Rigel222
ID: 16794924
What am I looking for in the event logs?
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16794931
thats fine,

check your event log on the machine that isnt working - you are looking for errors
0
 

Author Comment

by:Rigel222
ID: 16794932
On the computer that doesn't allow incoming remote desktop connections, there is nothing in the event log that seems recent enough to be the culprit.
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16794939
turn off the application layer gateway service as well

disable the windows firewall service completely and reboot your machine

services.msc
0
 

Author Comment

by:Rigel222
ID: 16794942
The last error was on 5/24/06, it is unrelated.
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16794944
if jay-jay70's comment doesnt work..

scope out MSCONFIG and see if there are any other network/communications programs that are running in the back ground
0
 

Author Comment

by:Rigel222
ID: 16794947
How do I turn off the application layer gateway service?  Firewall is completely disabled.  I'll reboot right after I disable the gateway...
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16794953
start - run - services.msc

stop the service and disable the startup

do you have any security packages installed?
0
 

Author Comment

by:Rigel222
ID: 16794973
Okay, I disabled the service, and restarted.  I still cannot connect from the other computer to this one.  I don't think I have any security packages installed, like what?
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16794975
norton, mcaffee anything like that
0
 

Author Comment

by:Rigel222
ID: 16794979
No.  Nothing.
0
 

Author Comment

by:Rigel222
ID: 16794991
The message I keep getting is:

The client could not connect to the remote computer.

Remote connections might not be enabled or the computer might be too busy to accept new connections.
It is also possible that network problems are preventing your connection.

Please try connecting again later.  If the problem continues to occur, contact your administrator.

I know RD *IS* enabled, and the computer isn't "too busy".  Maybe we could focus on the "network problems" part, but they are both connected to the same switch and can see each other, so it's got to be something subtle.
0
 
LVL 30

Accepted Solution

by:
Irwin Santos earned 2000 total points
ID: 16794993
Here is a Rob Will solution from PAQ
-------------------------------------
Firstly can you ping the workstation you are trying to connect to. If not there may be a basic connectivity problem. One thing to watch is the local and remote VPN sites need to be on different subnets. Below I have compiled a little list of items to check when troubleshooting a Remote Desktop Connection. Perhaps one of these ideas will solve your problem:

-try connecting using the IP of the remote computer not the computer name
-"allow users to connect remotely to this computer" must be enabled
-you must be a member of the remote desktop users group (administrators are by default)
-if the workstation is a member of a server 2000/2003 domain make sure in the users profile under "Terminal Services Profile", that the "Deny the user permission to log on to any terminal server" is not checked
-if XP SP2 the firewall needs to be configured to allow remote connections ( I would disable for now for troubleshooting purposes)
-The terminal Services service must be running
If you have access to the remote machine make sure it is "listening" for your connection. To do so at a command line enter:
    netstat -an |find "3389"
You should get the following result:
    TCP 0.0.0.0:3389 0.0.0.0:0 listening
If not go to Start | Run | services.msc and see if Terminal Services is started and set to automatic

A couple of useful Remote Desktop configuration sites:

http://www.microsoft.com/windowsxp/using/mobility/getstarted/remoteintro.mspx

http://www.microsoft.com/technet/prodtechnol/windowsserver2003/library/ServerHelp/1e4a44de-2be1-4d29-9387-9f04b79cc17a.mspx
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16795000
only time i have seen these errors are with either a security package installed or windows firewall

the above link from rob is assuming that you are using terminal services and a VPN

your connectvity is fine as you can ping by both name and address and get from one to another

i would be looking at a repair install myself
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16795008
@rigel222.

I copied and pasted the PAQ.. and should've weeded out the preceding material before the links.

Check out the links to confirm that we got the base covered.
0
 

Author Comment

by:Rigel222
ID: 16795030
The dang service wasn't running.  How do you like that!  THANK YOU!!!

If not go to Start | Run | services.msc and see if Terminal Services is started and set to automatic
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 16795034
well done Irwin
0
 
LVL 30

Expert Comment

by:Irwin Santos
ID: 16795146
Thank you Rigel222.. but in all fairness..this should've been split.. because, I was following what Jay_jay70 was posting and from what you were responding to, and the conclusion was based on isolating several possibilities based on the previous comments.

Should you wish to grant jay_jay70 some points, I'm welcome to you opening this question so that you can split points to both of us, 50/50 is good with me (just mark mine the accepted comment after you click split points as described below)

Here's how to do it...click on the link below

http://www.experts-exchange.com/Community_Support/

Then post in the title "Please reopen to split points", and in the body of the question put
http://www.experts-exchange.com/Networking/Microsoft_Network/Q_21868985.html#16794993

In 24 hours a moderator will reopen the question, and then you can award accordingly.  I'm sure that Jay_jay70  will agree and be appreciative as he did provide good assists.

Thank you in advance.

Aloha from Hawaii,

Irwin
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Need In an Active Directory enviroment, the PDC emulator provide time synchronization for the domain. This is important since Active Directory uses Kerberos for authentication.  By default, if the time difference between systems is off by more …
Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…

579 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question