sony dru-810 DVD Drive will not open. Have to do multiple shutdowns to get it back.

Posted on 2006-05-30
Last Modified: 2008-01-16
sony dru-810 DVD Drive will not open. It shows in the device manager and shows that it is working properly. If I hit the physical button nothinh happens, if I try to open it through windows or anyprogram, the computer freezes completely. It has been doing this for a while. It used to come back online after a shutdown. It kept taking more and more shutdowns and eventually system restores to get it back. It does not matter if a disk is in there or not, it will just decide it does not want to open. I hade to unplug it from the cable with just power on it to get it back the last time - now one day later it is locked closed again. Anyone had this happen before or any ideas to permanatly fix this issue will be greatly appreciated.
Question by:LVm3rlin
    LVL 87

    Accepted Solution

    If an optical drive fails to open, you can force it to open by using something like a paperclip and pushing it into the small hole at the front of the drive.

    Look for a firmware update for your drive. If that doesn't help the drive is dying and you should replace it.

    Author Comment

    Thank you for the paper clip idea - it works, but the firmwear is updated and the drive just replaced a dead DVD drive 3 months ago. If it is dead that is a real problem. Any other ideas will be appreciated. It is up and running now when I deleated svcroot.exe from my start up, but that may be a coincidence.
    LVL 87

    Expert Comment

    I think I missunderstood your phrase "and eventually system restores to get it back." that you restored windows, so I ruled out a software problem. Try the following:


    Right click in the upper and lower filter entries in these keys and press delete. Reboot and check if it is OK now.

    Or if you don't want to edit your registry yourselve, download and run the following:

    If this doesn't help,

    Download the latest version of HijackThis

    (Click on the „Directdownload“ link).

    run it and save the log. Paste the log to the following website

    Follow the following exactly:

    At the bottom of the page you'll see a "ANALYZE" button. Click it and you will have an analysis of your log. Now a new button, "SAVE ANALYSIS" will show up at the bottom. Your analyzed log will be saved to a page on that homepage, of which you can post the URL here. I should then be able to see if there is any software causing problems.
    LVL 91

    Expert Comment

    you can also try to connect it to the other IDE cable, or try another cable.
    did you install / upgrade something recently ? you can then uninstall this software, or disable it with msconfig.
    you can also troubleshoot which one causes it with msconfig (type it in the run box)
    -in startup tab, click on disable all
    -in services tab, click "hide MS services", then click disable all.
    if it works now, add 1 service, or startup item till the bad guy is found

    Author Comment

    Sorry for the delay, but it was working again and I had to wait for it to "break" again - So I am now trying all that you 2 have wrote and will be posting the needed results. Thanks for your help and I hope you are both still there.

    Author Comment

    OK - believe it or not the simplest thing worked. I put in the paperclip after trying Rindi's regedit trick (which did not work by the way). After getting it open with the clip and closing it with the button, it works again. It is not "Fixing" the problem, but I am satisfied. If anyone has more ideas as to what it could be for future members, feel free to keep posting any ideas.

    Featured Post

    Scale it in WD Gold

    With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

    Join & Write a Comment

    Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
    Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
    In this sixth video of the Xpdf series, we discuss and demonstrate the PDFtoPNG utility, which converts a multi-page PDF file to separate color, grayscale, or monochrome PNG files, creating one PNG file for each page in the PDF. It does this via a c…
    This video discusses moving either the default database or any database to a new volume.

    729 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now