Enable Telnet server on Fedora core 4

Hello,

I am using Linux Fedora core 4. Now, I want to enable Telnet service on this server.How should i do now ?

Regards.
freshrainAsked:
Who is Participating?
 
slyongConnect With a Mentor Commented:
You can grep the rpms from http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/Fedora/RPMS/.  I am not sure why yum could find the baseurl.  You might want to check /etc/yum.conf.  With yum it is easier because it resolve all the dependencies for you.  If you get the rpms, you might need to make sure that you install all dependencies.

To install the rpm after downloading it, just do:

# rpm -Uvh xinetd-2.3.13-6.i386.rpm

After installing xinetd just continue as the first reply.

regards
slyong
0
 
slyongCommented:
Hi,

First a word of caution.  Use SSH instead of Telnet if you can.

1) Check if you have krb5-workstation and xinetd installed

# yum list installed | grep krb5
# yum list installed | grep xinetd

2) If not install it (including all dependencies)

# yum install krb5-workstation
# yum install xinetd

3) Enable it.  Edit the file /etc/xinetd.d/krb5-telnet.  Change the second last line from disable=yes to disable=no

4) Start the xinetd service

# service xinetd start

You should have telnetd up and running.
0
 
freshrainAuthor Commented:
Hello,

I  do commands as folow:

[root@SaigonBank usr]# yum list installed | grep krb5
krb5-auth-dialog.i386                    0.2-5                  installed
krb5-devel.i386                          1.4-3                  installed
krb5-libs.i386                           1.4-3                  installed
krb5-workstation.i386                    1.4-3                  installed
pam_krb5.i386                            2.1.7-3                installed
You have new mail in /var/spool/mail/root
[root@SaigonBank usr]# yum list installed | grep xinetd
[root@SaigonBank usr]# yum install xinetd
Setting up Install Process
Setting up repositories
Cannot find a valid baseurl for repo: updates-released
[root@SaigonBank usr]#

What does it mean ?
Should I can do next?

Thanks
0
 
linux2000inConnect With a Mentor Commented:
Well ,

Above 1 more step need to be done that

you have to install telnet-server-0.17-35.i386.rpm


and then in etc/xinetd.d/telnet

change to
Disable = no

and restart  GLUG#services xineted restart

TEST:
GLUG#telnet localhost

It must show telnet banner

Regards,
linux2000in

http://www.linux-directory.net :: It's all about Open Source & Linux

http://www.linux-gujarat.co.in :: It's place to learn Linux in differrent way !
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.