[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 369
  • Last Modified:

CiscoClient to Pix506

Hi,
i've a ciscoclient 4.0.3A which i want to connect to a Pix 506E Version 6.3(3), i've followed the sample from
http://www.cisco.com/en/US/products/sw/secursw/ps2308/products_configuration_example09186a00801e71c0.shtml 

I can connect fine to the pix but i'm not able to reach any other host behind the pix (10.0.3.0), i can only ping my own ip
given by the pix (in the current setup it's 10.0.8.1) . From syslog there is nothing which would indicate a permission problem.

Does anybody have a idea ?

Thats my config:

: Saved
: Written by enable_15 at 09:02:32.870 UTC Wed May 31 2006
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password HjjjMB.G7ccUTff. encrypted
passwd HjjjMB.G7ccUTff. encrypted
hostname pixfirewall
domain-name pix-transfer.intern
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 102 permit ip 10.0.3.0 255.255.255.0 10.0.8.0 255.255.255.0
access-list 102 permit tcp 10.0.3.0 255.255.255.0 10.0.8.0 255.255.255.0
access-list 102 permit icmp 10.0.3.0 255.255.255.0 10.0.8.0 255.255.255.0
pager lines 24
logging on
logging buffered alerts
logging trap informational
logging host inside 10.0.1.195
mtu outside 1500
mtu inside 1500
ip address outside 212.xx.xx.xxx 255.255.255.248
ip address inside 10.0.3.4 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 10.0.8.1-10.0.8.254
pdm history enable
arp timeout 14400
global (outside) 1 212.19.51.227 netmask 255.255.255.248
nat (inside) 0 access-list 102
route outside 0.0.0.0 0.0.0.0 212.19.51.225 1
route inside 10.0.1.0 255.255.255.0 10.0.3.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 10.0.3.50 /
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup group1 address-pool vpnpool1
vpngroup group1 dns-server 10.0.1.190
vpngroup group1 wins-server 10.0.1.190
vpngroup group1 default-domain domain.com
vpngroup group1 split-tunnel 102
vpngroup group1 idle-time 1800
vpngroup group1 password **********
telnet 10.0.1.61 255.255.255.255 inside
telnet 10.0.1.0 255.255.255.0 inside
telnet timeout 5
ssh 10.0.1.62 255.255.255.255 inside
ssh 10.0.1.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
terminal width 80
Cryptochecksum:e8d6ec7dc92d37de12cf5bb69f390900

Syslog, showing the connection attemp and a netbios request:
10.0.3.4:%PIX-6-602301: sa created, (sa) sa_dest= 212.xx.xx.xxx (Unresolved) , sa_prot= 50, sa_spi= 0xff605291(4284502673), sa_trans= esp-aes-256 esp-sha-hmac , sa_conn_id= 1
10.0.3.4:%PIX-6-602301: sa created, (sa) sa_dest= 84.xx.xx.xxx (Unresolved) , sa_prot= 50, sa_spi= 0xf1182273(4044890739), sa_trans= esp-aes-256 esp-sha-hmac , sa_conn_id= 2
10.0.3.4:%PIX-6-302013: Built inbound TCP connection 8 for outside:10.0.8.1 (Unresolved) /1192 (10.0.8.1 (Unresolved) /1192) to inside:10.0.3.50 (unresolved) /445 (10.0.3.50 (unresolved) /445)
0
MKrauss
Asked:
MKrauss
  • 3
  • 3
1 Solution
 
stressedout2004Commented:
Make the following configuration changes:

access-list 102 permit ip 10.0.1.0 255.255.255.0 10.0.8.0 255.255.255.0
no access-list 102 permit tcp 10.0.3.0 255.255.255.0 10.0.8.0 255.255.255.0
no access-list 102 permit icmp 10.0.3.0 255.255.255.0 10.0.8.0 255.255.255.0
clear xlate
isakmp nat-t



0
 
MKraussAuthor Commented:
there is unfortunality no change, any other idea ?

10.0.3.4:%PIX-6-602301: sa created, (sa) sa_dest= 212.xx.xx.xxx (Unresolved) , sa_prot= 50, sa_spi= 0x2af5a38(45046328), sa_trans= esp-aes-256 esp-sha-hmac , sa_conn_id= 2
10.0.3.4:%PIX-6-602301: sa created, (sa) sa_dest= 84.xx.xx.xxx (Unresolved) , sa_prot= 50, sa_spi= 0x8fe015d1(2413827537), sa_trans= esp-aes-256 esp-sha-hmac , sa_conn_id= 1
10.0.3.4:%PIX-6-609001: Built local-host inside:10.0.1.190 (Unresolved)
10.0.3.4:%PIX-6-302015: Built inbound UDP connection 9 for outside:10.0.8.1 (Unresolved) /1081 (10.0.8.1 (Unresolved) /1081) to inside:10.0.1.190 (Unresolved) /53 (10.0.1.190 (Unresolved) /53)
10.0.3.4:%PIX-6-302015: Built inbound UDP connection 10 for outside:10.0.8.1 (Unresolved) /137 (10.0.8.1 (Unresolved) /137) to inside:10.0.1.190 (Unresolved) /137 (10.0.1.190 (Unresolved) /137)
10.0.3.4:%PIX-6-302015: Built inbound UDP connection 11 for outside:10.0.8.1 (Unresolved) /1082 (10.0.8.1 (Unresolved) /1082) to inside:10.0.1.190 (Unresolved) /53 (10.0.1.190 (Unresolved) /53)
10.0.3.4:%PIX-6-609001: Built local-host inside:10.0.3.3 (Unresolved)
10.0.3.4:%PIX-6-302013: Built inbound TCP connection 12 for outside:10.0.8.1 (Unresolved) /1083 (10.0.8.1 (Unresolved) /1083) to inside:10.0.3.3 (Unresolved) /23 (10.0.3.3 (Unresolved) /23)
10.0.3.4:%PIX-6-302015: Built inbound UDP connection 13 for outside:10.0.8.1 (Unresolved) /1084 (10.0.8.1 (Unresolved) /1084) to inside:10.0.1.190 (Unresolved) /53 (10.0.1.190 (Unresolved) /53)
10.0.3.4:%PIX-6-302015: Built inbound UDP connection 14 for outside:10.0.8.1 (Unresolved) /1085 (10.0.8.1 (Unresolved) /1085) to inside:10.0.1.190 (Unresolved) /53 (10.0.1.190 (Unresolved) /53)
0
 
stressedout2004Commented:
Turn on the following debug:

debug icmp trace

Then connect with the VPN Client and initiate a ping to the internal network. See if the PIX is getting the packet. Also can you post an updated copy of your PIX config?
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
MKraussAuthor Commented:
thanks for helping, i found my problem but got now a new, i can ping now my internal network
which is on 10.0.1.0 , my pix is in our dmz net 10.0.3.0, the firewall between those nets has
10.0.3.1 and didnt had the route set to 10.0.8.0, i've added the route on the unix host like
route add -net 10.0.8.0 netmask 255.255.255.0 dev eth2 gw 10.0.3.4 (10.0.3.4 is the pix).

But within my DMZ on 10.0.3.0 i can not reach any hosts, all hosts in the DMZ are using 10.0.3.1 as
defaulte route, only if i change the def. route on a DMZ host to 10.0.3.4 makes it working but then i cant reach them
through my internal lan anymore, i've already tried to set manual routes on a test host within DMZ but that
doesnt help.

Do you see a chance to fix this somehow ?

pixfirewall(config)# debug icmp trace
ICMP trace on
Warning: this may cause problems on busy networks
pixfirewall(config)# 1: ICMP echo-request from outside:10.0.8.1 to 10.0.3.4 ID=1280 seq=256 length=40
2: ICMP echo-request from outside:10.0.8.1 to 10.0.3.4 ID=1280 seq=512 length=40
3: ICMP echo-request from outside:10.0.8.1 to 10.0.3.4 ID=1280 seq=768 length=40
4: ICMP echo-request from outside:10.0.8.1 to 10.0.3.4 ID=1280 seq=1024 length=40
5: ICMP echo-request from outside:10.0.8.1 to 10.0.3.1 ID=1280 seq=1280 length=40
6: ICMP echo-request from outside:10.0.8.1 to 10.0.3.1 ID=1280 seq=1536 length=40
7: ICMP echo-request from outside:10.0.8.1 to 10.0.3.1 ID=1280 seq=1792 length=40
8: ICMP echo-request from outside:10.0.8.1 to 10.0.3.1 ID=1280 seq=2048 length=40


: Saved
: Written by enable_15 at 04:45:24.098 UTC Fri Jun 2 2006
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password HjjjMB.G7ccUTff. encrypted
passwd HjjjMB.G7ccUTff. encrypted
hostname pixfirewall
domain-name pix-transfer.intern
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 102 permit ip 10.0.3.0 255.255.255.0 10.0.8.0 255.255.255.0
access-list 102 permit ip 10.0.1.0 255.255.255.0 10.0.8.0 255.255.255.0
pager lines 24
logging on
logging buffered alerts
logging trap informational
logging host inside 10.0.1.195
mtu outside 1500
mtu inside 1500
ip address outside 212.xx.xx.xxx 255.255.255.248
ip address inside 10.0.3.4 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool1 10.0.8.1-10.0.8.254
pdm history enable
arp timeout 14400
global (outside) 1 212.xx.xx.xxx netmask 255.255.255.248
nat (inside) 0 access-list 102
route outside 0.0.0.0 0.0.0.0 212.xx.xx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 10.0.3.50 /
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup group1 address-pool vpnpool1
vpngroup group1 dns-server 10.0.1.190
vpngroup group1 wins-server 10.0.1.190
vpngroup group1 default-domain domain.com
vpngroup group1 split-tunnel 102
vpngroup group1 idle-time 1800
vpngroup group1 password *****
telnet 10.0.1.61 255.255.255.255 inside
telnet 10.0.1.0 255.255.255.0 inside
telnet timeout 5
ssh 10.0.1.0 255.255.255.0 inside
ssh 10.0.3.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
terminal width 80
Cryptochecksum:006e5d5eb498edfec84f960199aa926d
: end


0
 
MKraussAuthor Commented:
I got it to work now, another access-list and local route entries made the trick.
Thanks for helping
0
 
stressedout2004Commented:
Glad to hear its working out for you.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now