[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 166
  • Last Modified:

Read-Only Issues with 2K3

Hi All,

This one is probably going to sound weird......

I have a 2k3 box in my environment and no matter what I do, I am unable to remove read-only permissions from folders created on either drive (3 of them, 2 local, 1 SAN) with any type of account (from Domain User to Enterprise Admin) I delete it and as soon as it is done going through everything, I check it again and read-only is right back...in a greyed check-box. I have removed all accounts from a folder, and re-added them to no avail, I have created folders with the only permissions as Everyone - Full Control, and I am still unable to remove the read-only..... It seems like read-only is being forced on it, but my AD guy's have said there should be no AD policies that are being pushed on it that should dictate this kind of action...

Please ask any additional questions and I'll do my best to provide additional clarification. I know this description is kinda vague, I apologize in advance....

Thanks much,

Mick Farlow
0
MicFarlow77
Asked:
MicFarlow77
  • 3
  • 3
  • 2
  • +2
1 Solution
 
Netman66Commented:
If the checkbox is grey then it's being inherited from somewhere higher up.

Keep checking the parent folders until you find the one that isn't grey - this is where it's set.

You can always click Advanced on the Security tab then uncheck the box for "Allow inheritable permissions to propogate from the parent" - this should give you the option of copying or removing the current permissions.

0
 
oBdACommented:
The Read-Only box for *folders* has no meaning in this case, especially if the box is greyed out; check here for details:
You Cannot View or Change the Read-Only or System Attribute of Folders
http://support.microsoft.com/?kbid=326549

If you have shared this folder and can't write changes back, it's likely that the *share* permissions are set to Read-Only for the Everyone group; this is the default behavior of Server 2003 when creating a new share, whereas NT4 and W2k set Full Access for Everyone.
0
 
MicFarlow77Author Commented:
Hey Netman66,

Thanks for the quick response.

I have tried the above to no avail....

One thing I was reminded of as I checked this area again before replying is that Special Permissions is greyed out as well, sometimes with a check mark, sometimes without, but in all cases, I am unable to flip it one way or the other....

Thanks again for all followups....

Mick
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
Netman66Commented:
oBdA is on to something here - I misread the fact that you are talking about folders.  This is considered normal even though you wouldn't think so.

Try the attrib command as mentioned in the article.

Let us know.

0
 
Netman66Commented:
Also, check and report to us who the owner is - it's in Advanced.

0
 
MicFarlow77Author Commented:
Thanks guy's for the posts......

A little more info.....

The goal here was to use this server as a home directory server for users with large home directories from other servers, easy enough......

On the folders, I initially set them to have correct permissions, the owner was the actual home directory owner and he was given full control. Everyone was removed and only various Admin groups had any other access...and all of that was full control as well. (In some cases I even removed the Admin groups and only placed in a single admin account)

User calls up the next day and say's he can't change or write anything to the new server, and that is when I notice all of this....

You guy's have given some good idea's, so now I am at a point that I need to teat with a user... I will report back on results....

Thanks a ton!

Mick
0
 
mikeleebrlaCommented:
odba is correct....

http://www.annoyances.org/exec/forum/winxp/1065399208

bascially just ignore that 'read only' checkbox on the folder since read only is a file attribute, not a folder attribute so that checkbox doesnt mean anything.
0
 
oBdACommented:
"he can't change or write anything to the new server"--as I said before: check the *share* (NOT the NTFS permissions, you've been there already) for the home share and allow the Everyone group Full Access; there's absolutely no added security if you work with both NTFS and share permissions, so just don't use share permissions.
0
 
MicFarlow77Author Commented:
Hey oBdA,

Who would have thunk it.......

I always deal with NTFS permissions, so I never thought to look at the share permissions.......

oBdA, you nailed it..... I appreciate your help greatly.

Thanks,

Mick
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now