[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 13288
  • Last Modified:

How to check Hard disk problem at ok prompt in solaris

How to check Hard disk problem at ok prompt in solaris

The command i tried
ok devalias
screen                   /pci@1f,2000/TSI,gfxp@1
net                      /pci@1f,4000/network@1,1
disk                     /pci@1f,4000/scsi@3/disk@0,0
cdrom                    /pci@1f,4000/scsi@3/disk@6,0:f
tape                     /pci@1f,4000/scsi@3,1/tape@4,0
tape1                    /pci@1f,4000/scsi@3,1/tape@5,0
tape0                    /pci@1f,4000/scsi@3,1/tape@4,0
disk6                    /pci@1f,4000/scsi@3/disk@6,0
disk5                    /pci@1f,4000/scsi@3/disk@5,0
disk4                    /pci@1f,4000/scsi@3/disk@4,0
disk3                    /pci@1f,4000/scsi@3/disk@3,0
disk2                    /pci@1f,4000/scsi@3/disk@2,0
disk1                    /pci@1f,4000/scsi@3/disk@1,0
disk0                    /pci@1f,4000/scsi@3/disk@0,0
scsi              

ok probe-scsi-all
/pci@1f,4000/scsi@3,1

/pci@1f,4000/scsi@3
Target 1
  Unit 0   Disk     SEAGATE ST318404LSUN18G 5221
Target 6
  Unit 0   Removable Read Only device    TOSHIBA XM6201TASUN32XCD1103
0
nessmssit
Asked:
nessmssit
3 Solutions
 
arthurjbCommented:
probe-scsi is the only disk checking command in opb (open boot prom)


If you type
boot disk
at the ok prompt, and nothing happens, then either the disk has gone bad or it is blank.  

The only way to tell is to attach the disk as a secondary disk on another Solaris system.

Since you have nothing to loose and it won't hurt anything anyway, you should try boot disk0 then boot disk1 etc until you get to disk5
0
 
Mohan ShivaiahCommented:
Hi nessmssit,

1> Try the command at the ok prompt
      ok probe-scsi-all
2>  ok boot -rv  
     Performs a reconfiguration boot. Use this option to find a newly attached device and to create new device entries in the /devices
     and /dev directories. It also updates the /etc/path_to_inst file.

Hope will solve the problem.
Cheers.
mohan shivaiah.
0
 
NopiusCommented:
show-disks may be helpfull.
From your output, try to boot from disk1, not from default dusk (if the problem is booting):
boot -vr disk1
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now