OWA authentication issues with Exchange 2003

We just installed a new Exchange server in our site. We're running Windows 2003 Server and Exchange 2003. I moved my mailbox as a test and everything is working fine.

The issue I have is with OWA. When I go to mail.company_name.com to access my web based email, the authentication box for the old server somes up. After I authenticate, the authentication box for the new server comes up. I login and I'm able to access my web based email.

When I logout from OWA, the authentication box comes up again (for the new server). In order to logout from OWA I have to authenticate again.

Is there anyway to clean up this process?

John

rocklin_rebelAsked:
Who is Participating?
 
SembeeCommented:
If these are two separate servers without a frontend server then that would appear to be Exchange working correctly. By hitting the first Exchange server you need to authenticate. Exchange basically says "not here, try there" and then the second server asks you to authenticate. The second server doesn't know anything about your first authentication attempt.

The usual reason for authentication being required on log off is that anonymous authentication is disabled on the /exchweb virtual directory in IIS Manager. Enable it again.
FBA only works if you are using SSL.

if you are going to run two servers then you have two choices...

1. Expose both servers to the internet and tell the users which one to hit.
2. Use a frontend server, which sorts out where your email needs to be pulled from automatically.

Simon.
0
 
rocklin_rebelAuthor Commented:
I fixed one of the problems. I'm able to log out of OWA without being prompted for authentication. I unchecked the box to enable forms based authentication in Exchange System Manager under Protocols, HTTP, properties for Exchange Virtual Server.

Still have one more problem. It would be nice if mail.company_name.com would automatically redirect me to the new server immediately for OWA.
Thanks,
John
0
 
rocklin_rebelAuthor Commented:
Again, thank you for your precise answer. We're probably going with solution #1.

John
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.