[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 744
  • Last Modified:

Open port 21 and 80

Hello,

I have a Zyxel 650HW router, I have modifed the NAT to forward incoming request of port 21 and 80 to my server (192.168.1.2).

On my server I have installed IIS, and configured port 21 and 80 in my server ip (192.168.1.2). For some reason, when I tell a friend (outside my network) to access my Public IP, they get "Page cannot be displayed" on both port (21 and 80). But! When I try to access my server IP from my browser (inside my network) I can see the website, but cannot access the port 21 (FTP).

Here is the strange thing, when I access: ftp://192.168.1.2 from my server, I can see my FTP folder.

I need to access the FTP and Web from the outside of my network, what should I do?

Regards,
Andre
0
Asheron
Asked:
Asheron
  • 3
  • 2
  • 2
  • +1
1 Solution
 
Irwin SantosComputer Integration SpecialistCommented:
0
 
Irwin SantosComputer Integration SpecialistCommented:
Confirm this and post back your results.
0
 
AsheronAuthor Commented:
That is exactly how my Zyxel is configured.
0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
YoungBonziCommented:
This may sound silly, but do you have the FTP service installed (or started)?

Could you check your Services panel to see if it's running/installed?

If not, see here for how to install it from Add/Remove programs:
http://img246.imageshack.us/img246/686/iisftp4kc.jpg

0
 
AsheronAuthor Commented:
Yes, FTP server is installed AND running.
0
 
Rob WilliamsCommented:
From the 192.168.1.2 PC, connect to http://www.canyouseeme.org and test for ports 80 and 21. This will verify if they are properly forwarded to the PC.
-If they are open/forwarded, it will also display your true public/Internet IP. Is this the IP to which you are trying to connect? it should be.
-If they are not open:
  a) make sure any software firewalls on 192.168.1.2 ,such as the Windows or other, are temporarily disabled for test purposes
  b) look in the status page of the Zyxel and verify that the public/WAN IP is the same as reported by canyouseeme. If not and it is a private IP such as 192.168.x.x, or 10.x.x.x or 172.16-31.x.x  it means the modem is a combined modem and router, and is performing NAT. Best solution if that is the case is to put the modem in Bridge mode. If in doubt post the make and model of the modem.

Let us know how you make out.
--Rob
0
 
AsheronAuthor Commented:
The NAT firewall was blocking both ports :), thank you Rob.
0
 
Rob WilliamsCommented:
Excellent ! Glad to hear you were able to resolve so easily.
Thanks Asheron,
--Rob
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now