Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 475
  • Last Modified:

commands to configure a 1720 with 2 wic 1t for internet and point-to-point

Hi,
Can someone help with the list of commands needed to configure a 1720 for both internet & point-to-point?  Basically I have 2 1720's one at each site.  They both have 2 csu/dsu wic 1t cards installed.  One wic will be used to connect the site to the internet while the other will connect the sites point-to-point.  Here is the network:

Site1                                                                           Site2
switch----Firewall----1720--------internet/ppp--------1720----Firewall----switch

Router config at site1:
(point-to-point csu/dsu)

Interface serial 1
service-module t1 clock source internal
service-module t1 timeslots 1-24 speed 64                
service-module t1 framing esf
service-module t1 linecode b8zs
ip address 10.10.10.1 255.255.255.252
encapsulation ppp
fair-que
no shut

(internet csu/dsu)
Interface serial 0/0
service-module t1 timeslots 1-24 speed 64                
service-module t1 framing esf
service-module t1 linecode b8zs
ip address 63.63.63.150 255.255.255.240 (bogus ip of course)
no shut

(ethernet port)
Interface fast0
ip address 192.168.1.1 255.255.255.0
no shut

router eigrp 10
network 10.10.10.1 255.255.255.252
network 192.168.2.1 255.255.255.0


Site 2
(point-to-point csu/dsu)

Interface serial 1
service-module t1 clock source line
service-module t1 timeslots 1-24 speed 64                
service-module t1 framing esf
service-module t1 linecode b8zs
ip address 10.10.10.2 255.255.255.252
encapsulation ppp
fair-que
no shut

(internet csu/dsu)
Interface serial 0/0
service-module t1 timeslots 1-24 speed 64                
service-module t1 framing esf
service-module t1 linecode b8zs
ip address 65.65.65.150 255.255.255.240 (bogus ip of course)
no shut

ethernet port)
Interface fast0
ip address 192.168.3.1 255.255.255.0
no shut


router eigrp 10
network 10.10.10.2 255.255.255.252
network 192.168.3.1 255.255.255.0


0
hplaud5035
Asked:
hplaud5035
  • 2
1 Solution
 
rshooper76Commented:
Do you have 2 T1's at each site?
0
 
hplaud5035Author Commented:
YES
0
 
lrmooreCommented:
router eigrp 10
network 10.10.10.1 255.255.255.252

On both sides, this network statement should be exactly:
  network 10.10.10.0 255.255.255.252
                            ^

I don't see a default route:
 ip route 0.0.0.0 0.0.0.0 65.65.65.149

>Interface fast0
>ip address 192.168.1.1 255.255.255.0
Given a public IP on the Internet T1 and a private IP on the LAN, you must NAT:
 interface fast 0
   ip nat inside
 interface Serial 0/0
   ip nat outside
 access-list 5 permit 192.168.1.0 0.0.0.255
 ip nat inside source list 5 interface serial0/0 overload

Q: How are you employing  your firewall?

0
 
hplaud5035Author Commented:
Well I was hoping to let the firewall do the NATing.  Am I supposed to nat at the router?  Also, I was only given public ips for one segment.  I can't use any of the Ips given on the ethernet port because they all belong to the same subnet or is there a way around this (router complains that it overlaps)?  If there is, then I can use all public ips on the router and let the firewall do the nat.  The firewall a GB250(gnat) is also my internal gateway for the lan. The eigrp/network commands are identical they have 10.10.10.0 255.255.255.252... I just added the address to give a bit more information about the network.  The Firewall isn't so much a concern at the moment, At the moment I'll be happy to ping something from the console out on the internet.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now