• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 877
  • Last Modified:

Crystal Reports Groups have Blue font and Hand Cursor on Hover

How can I turn of the Automatic Blue coloring of the Font and the Hand Cursor on hover over the group headings when viewed in the CR Viewer.  I would also like to prevent  the report to be re-presented containing only the group when the group title is clicked.  I am using using Crystal Reports V9 that ships with Visual Studio 2003.
0
KenFowlerHonda
Asked:
KenFowlerHonda
  • 5
  • 4
  • 3
  • +1
1 Solution
 
mlmccCommented:
You should be able to change the format on the group header to change the background color.

I don't know about the mouse hover.

mlmcc
0
 
KenFowlerHondaAuthor Commented:
It is not the background color I am having a problem with.  It is the default font color for automatic Group Header Field.
0
 
mlmccCommented:
Not sure you can change that.  

Which viewer are you using?

mlmcc
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
wykabryanCommented:
Is this blue in the actual report?  I would suspect that this is the case.  You can simply go into the report and turn all fields that you want from blue to black.  The mouse image, this is not controlled from within crystal.  I would guess this is machine based.  

After you have modified your report colors, I would suggest that you close out of the report.  This will give you a blank CR screen.  Then go to File>Options>Fonts tab> Group Name Fields.  Make sure that the color is what you desire.  I would also suggest that you go through the other areas and make sure the settings are acceptable.  Once you have these setting, CR will apply them to any New report.  CR does not apply to any report that already exists.  
0
 
KenFowlerHondaAuthor Commented:
Thanks for the suggesions but as it turns out there was a link set in the viewer to our main style sheet where all Links are set to a blue font.  appearantly the Group names are created as links and therefore picked up the blue font.  Removing the style sheet solved the color problem but not the cursor (being a hand) problem.
0
 
mlmccCommented:
That may be a Windows cursor setting.

mlmcc
0
 
mlmccCommented:
Check the Windows --> CONTROLS PANEL --> MOUSE

mlmcc
0
 
mlmccCommented:
Did the hand problem get solved?

mlmcc
0
 
KenFowlerHondaAuthor Commented:
No.  I seems that the Group Headers on Crystal Reports are setup as links.  I have not seen a way of Disabling this behavior in Crystal.
0
 
ladylinetCommented:
There is a stylesheet file that contains definitions for lot of things crystal uses for html presentation, I don't know about links - look at virtual directory /crystalreportviewer (or something like that) on your web server...

Lady Linet
0
 
ladylinetCommented:
CrystalReportViewer has a property to turn off links

  EnableDrillDown  = False

 Css class for group tree is "crgrptr", search for it in your virtual directoriums on IIS.

Lady Linet
0
 
KenFowlerHondaAuthor Commented:
The solution of setting the EnableDrillDown property to false removed both the blue color that is assigned to links in the style sheet, the link underline and the unwanted functionality of having the report restricted to only the one group when the link was clicked.

Thanks!!
 
0
 
ladylinetCommented:
Glad to help!

Lady Linet
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now