[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 865
  • Last Modified:

Cannot load COMMAND.COM after 6.5 upgrade

Okay guys, here goes:

Today I upgraded a Netware 6.0sp4 server to Netware 6.5 (not SuSe Linux ver). All seemed to go fairly well until the reboot at the end of all the installation, clean up, etc. The server booted to the Novell screen, stayed there awhile, then the monitor went black for a couple of minutes. Next came a blinking cursor in the upper left hand corner. After what seemed like forever I got the following:
   Unable to EXEC server (insufficient memory?).
   Cannot load the file c:\COMMAND.COM
   Insert correct disk and strike any key.

Now understand that I am in NO WAY a Netware expert, but I'm all they've got, so I need some help here. In baby steps (please?).

The server has 1GB RAM, is a Compaq ProLiant ML350 -G3. Three 18.2 GB hard drives , RAID 0. Sorry I don't remember the processor
0
jojo0508
Asked:
jojo0508
  • 6
  • 4
  • 2
  • +1
3 Solutions
 
BudDurlandCommented:
My first instinct was to blame a device driver or memory manager loading in CONFIG.SYS or AUTOEXEC.BAT, but since this server was running a previous version of NetWare, that is not likely the problem.

The problem may be as simple as a corrupted SERVER.EXE file, and copying it off the installation media will solve the problem.  

1) boot the server, press whatever key stops DOS from running AUTOEXEC.BAT
2) rename the AUTOEXEC.BAT and CONFIG.SYS
3) Create new bare-bones ones to load only the CD-ROM drivers for your system
4) reboot to a DOS prompt, find SERVER.EXE on the CD-ROM, copy it to C:\NWSERVER
5) delete the cd-rom specific AUTOEXEC.BAT and CONFIG.SYS
6) Create a CONFIG.SYS with only the following line
  files =100
7) Reboot
8) at the DOS prompt, enter:
  cd c:\nwserver
  server

If this works, Yay!.  Shutdown the server and create an AUTOEXEC.BAT with the above lines in it and reboot.

If that didn't work, it could be any number of other things far, far more complex.  I know this answer won't win me any points, but if manually copying SERVER.EXE does not fix the problem, I recommend that you stop there and go hire a NetWare expert.
0
 
pgm554Commented:
What disk did you use to do the upgrade?
There is an overlay disk with all of the spacks(NW6.5 sp5)that is available as an ISO download from their site.
You might be having a driver issue.
You are not really using raid 0 are you?
That is a VERY BAD idea on a production server.
If you lose a disk you lose the file server and all of it's data.

http://support.novell.com/filefinder/18197/index.html
0
 
PsiCopCommented:
Interesting. Reboot the server and press ESC when prompted, to return DOS. Does that work?
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jojo0508Author Commented:
First, for Bud Durland: Thanks for the suggestions! I'll give them a try in the morning. Since this server is located at an elementary school and school is out, there's no one there to care, so I just left it. I actually have a Netware expert but I can't find her - guess she's gone on vacation, which is where I'll be in about 10 days. I'd kinda like to get this resolved before I head North to Alaska!

Second, for pgm554: Please excuse me for having my head ... somewhere it really doesn't belong. Of course it isn't RAID 0, it's RAID 5. My brain is functioning at 0. Sorry! I did download the 6.5 sp5 overlay image and burn my installation disk. At least THAT part I got right...

Third, for PsiCop: I hope that works 'cuz I'm going to have a hard time trying BudDurland's suggetion if it doesn't, huh?

I'll let y'all know how it turns out. Sure hope I get to award some points !
0
 
jojo0508Author Commented:
Okay, here's today's exciting news: Tried the steps outlined by BudDurland, no luck. So I rebooted into DOS and put everything back the way it was, except I changed the Files=40 to Files=100 in CONFIG.SYS. Rebooted again and got:

IO error reading drive C
Abort, Retry, Fail?

If you Fail, it says “Unable to EXEC server (insufficient memory?)”. If you Abort, it says, “Cannot load C:\COMMAND.COM   Insert correct disk and Strike any key”

I rebooted and watched the system console throughout, rather than letting the logo screen stay active. The volumes are being mounted, NLMs are being loaded, some kind of ProLiant Manager window opens and immediately closes back to the console. SOMETHING whizzes by and in about a half a second the cursor starts blinking and eventually the IO error message is displayed.

#$%&*#!!!

Jo

 

0
 
pgm554Commented:
Boot into dos and change to the nwserverr dir.

type in

server -na -nl

and hit enter (this will turn off the logo ,and no autoexec will execute)
let's see what'going on
0
 
PsiCopCommented:
Also, please post the entire contents of CONFIG.SYS
0
 
jojo0508Author Commented:
Will try to get out there and do this tomorrow - although since it's Saturday, I'm not making any promises... It may be Monday!
0
 
jojo0508Author Commented:
Okay  - the CONFIG.SYS:
Files=100
Buffers=50
country=001,437 ,c:\dos\country.sys
device=c:\cpqidecd.sys  /D:CPQCDROM
device=c:\dos\display.sys  con=(EGA,,1)
Lastdrive=z

For good measure, the AUTOEXEC.BAT:
@echo off
prompt $p$g
path=c:\dos
mscdex  /d:cpqcdrom  /v  /m:50  /l:f
c:\dos\nlsfunc
c:\dos\mode  con  cp  PREPARE=((437)  c:\dos\EGA\cpi)
c:\dos\mode  con  cp  Select=437
cd \NWSERVER
server

And finally, the last screen when I booted from  server -na  -nl:
Warning: Skipping stage 5 loading of nlms.
Loading Module  DHOST.NLM                            [   ok   ]

Novell Open Enterprise Server, Netware 6.5
Support Pack Revision 05
(C) Copyright    yada yada yada
Server Version 5.70.05  Dec 16, 2005

Saturday ,June3, 2006   10:52:09 am cst
:
:

6-03-2006    10:52:33 am:    DS-10552.79-264
       Bindery open requested by the SERVER

Loading Module  DXEVENT.NLM                        [   ok  ]
Loading Module  GAMS.NLM                             [   ok  ]
Loading Module  NMAS.NLM                             [   ok  ]
      Auto-Loading Module SPMNWCC.NLM          [  ok   ]
Loading Module  SPMDCLNT.NLM                      [   ok  ]

6-03-2006    10:53:22 am:    DS-10552.79-262
       Directory Services:   Local database is open

:_


And that's where I left it - after waiting about 10 minutes to see if it would do anything else

0
 
pgm554Commented:
So you're at a command prompt?That is good.
If that is so ,then it looks as if something in the autoexec.ncf is causing the server to go kaput.

Load nwconfig and post what is in the autoexec.ncf

I think what we need to do is look for a line that might be loading some Compaq utility.

I am thinking Compaq Insight managermight be the culprit.
If so ,we need to rem it out.
0
 
jojo0508Author Commented:
Is that a command prompt? A colon and a cursor? I don't remember if the cursor was blinking or not. If I can't type it in from there I'll just shut it down and start all over.

Thanks - I'll do that first thing Monday and let you know.
0
 
jojo0508Author Commented:
pgm554 - If you were here I'd kiss you (assuming you're a guy!) It was indeed one teeny line in the autoexec.ncf. When I remmed out the line  CPQSNMP, everything ran exactly as it should. Now I don't have to have a nervous breakdown.

While I was rummaging around in NWCONFIG, I took a look at the ProLiant Integrated Management Log. It showed all the abends from all the times I had tried to restart the server since I updated. There were always two at a time and they were always the same two. Here they are -
Abnormal Program Termination (Abend: Caller should switch to either DoRealModeInterruptDisabled or DoRealModeInterrupt32Disabled      Running Process CPQBSSA.NLM  1  EIP:  1207B8h)
Abnormal Program Termination (Abend: Caller should switch to either DoRealModeInterruptDisabled or DoRealModeInterrupt32Disabled      Running Process CPQHTHSA.NLM  1  EIP:  1207B8h)

I've upped the points and will be awarding with a little bit of a split.

Thanks to ALL of you!

Jo
0
 
pgm554Commented:
Yes,I am male.(go figure,a guy in IT,what a rarity!).
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 6
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now