[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Exchange 2003 rejecting incoming email

Posted on 2006-06-01
6
Medium Priority
?
14,948 Views
Last Modified: 2012-05-05
I'm really having a bad day.

First, let me say that I have nt changed any settings in Exchange since I upgraded to Service Pack 2 a few months ago. There have been no patches or updates run since the beginning of May. I have not changed any settings on my firewall in the past several months. I have gone through every setting and verified that they are still the same.

Everything has been running rather smoothly for quite some time. As of some time this morning, things got rough. Very little email from outside of our domain is actually getting through to the recipients. I have run an unbelievable number of tests from outside email accounts. Every web-based email account that I have fails to get through. But I have had other people send me mail from their Exchange Server, and it gets through fine. I've also had a friend of mine send me an email through telnet without any problem. In addition, we have had mail from several other senders throughout the day, including Dell, a couple of different government agencies, and even a little bit of spam (although far less than normal).

Here are some of the bounce messages I've gathered:

from Gmail:
Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 550 Requested action not taken: mailbox unavailable

from Hotmail:
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;550 Requested action not taken: mailbox unavailable

from Mail.com
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; host mail.ourserver.com[70.xxx.119.xxx]
     said: 550 Requested action not taken: mailbox unavailable (in reply to RCPT
     TO command)

from Yahoo!:
70.xxx.119.xxx does not like recipient.
Remote host said: 550 Requested action not taken: mailbox unavailable
Giving up on 70.xxx.119.xxx.

from a friend with his own email domain (hosted by verizon):
Reason: Remote SMTP server has rejected address
Diagnostic code: smtp;550 Requested action not taken: mailbox unavailable
>  Remote system: dns;mail.ourserver.com
> (TCP|206.xx.252.xxx|58455|70.xxx.119.xxx|25) (SMTP service ready)

a different one from Gmail (after I put the firewall in bypass):
Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 550 5.2.1 Mail from 64.233.184.232 refused: spam site. (note: the IP is Google)

I've tried changing settings in Exchange, including disabling the Intelligent Message Filter, with zero success. As I said above, I even tried disabling the firewall. I'm running out of ideas. We use Symantec Mail Security for Exchange, but I checked the log, and there hasn't been anything blocked by SMSE since yesterday - and that is very unusual.

Anyone got any ideas? I'd give you 1,000 points if I could.
0
Comment
Question by:realitybytes
  • 4
  • 2
6 Comments
 
LVL 8

Accepted Solution

by:
mvvinod earned 2000 total points
ID: 16812381
1. Looks to me like spam filter is not letting the mail through. Always the spam filter grabs the SMTP and then hands it over to exchange, since all of them are saying mailbox unavailable, have you tried to telnet a mail directly into the mailbox you are testing ???? Also what spam filter do you have ???

2. Also check the reverse DNS for your mx record ip to see if it exist. USe dnsstuff.com or dnsreport.com

3. If you can uninstall spam filter and check again if possible....

4. Enable complete logs on SMTP virtual server and send a mail from outside and go back and look at the log to see exact message exchange between the servers...

Vinod.
0
 
LVL 1

Author Comment

by:realitybytes
ID: 16812525
Thank you for your response.

1a. yes, as I said above, I did have a friend telnet directly into my mailbox - successfully.
1b. as I said above, we use Symantec Mail Security for Exchange. But the log does not show any rejected spam since yesterday. Normally, the software logs at least 50 to 100 spam emails a day.

2. I have thoroughly checked our MX Record and our A Record at DNSstuff, and I have done a complete Reverse DNS Lookup. All records are correct.

3. That may be difficult to do because of the downtime issues. I can disable the Spam Checking, but I have already tried that, with no success. I fear that the problem could actually be the Microsoft Intelligent Message Filter is filtering even though I have told it not to. I don't think you can uninstall that feature from MS Exchange.

4. Maybe I'm not looking at the right Log, but what I can see doesn't tell me anything:
2006-06-02 00:20:54 64.233.184.231 wr-out-0506.google.com SMTPSVC1 HOTEL 192.168.1.x 0 RCPT - +TO:<rob@ourserver.com> 0 0 56 35 13093 SMTP - - - -
2006-06-02 00:20:54 64.233.184.231 wr-out-0506.google.com SMTPSVC1 HOTEL 192.168.1.x 0 QUIT - wr-out-0506.google.com 240 13453 75 4 0 SMTP - - - -

If you can make heads or tails out of that, I'm deeply indebted.
0
 
LVL 8

Expert Comment

by:mvvinod
ID: 16812638
You have to enable all fields in the log to read more details. If you goto ESM, click SMTP virtual server properties, make sure all fields in the logs are turned on. Then try another mail and post the partial logs here.

Vinod.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
LVL 8

Expert Comment

by:mvvinod
ID: 16812643
Also how seeon do you get the NDR, when you send from google,yahoo etc ????

Also try using diferent address also for testing purposes to see if mail goes through ??

Is nobody getting e-mail in the org ??? or they dont get everything ?? or is this problem with only some users ??

Also are you using only SMTP virtual server or do you use smtp connector also ??

Vinod.
0
 
LVL 1

Author Comment

by:realitybytes
ID: 16812650
Well, I'm willing to admit when I'm wrong. You were spot on about the Spam Filter. I disabled the Symantec Mail Security for Exchange again, and sent few another salvo of test emails from a half dozen different email accounts. They all came through.

Don't know why that didn't work earlier, but I did notice that when I tried to save the settings changes this time, the program seemed to hang for quite a while.

Anyway, thanks for the push in the back!
0
 
LVL 8

Expert Comment

by:mvvinod
ID: 16812688
Great! Now you have only 1 thing to work with....

Vinod.
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
How to effectively resolve the number one email related issue received by helpdesks.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses
Course of the Month20 days, 9 hours left to enroll

868 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question