Strange Slave drive problem!!!

Posted on 2006-06-01
Last Modified: 2010-04-03
Hi experts,

Bit of a strange one - well to me anyway - i have a 40GB Maxtor HD with windows OS etc and i want my other HD (Fujitsu 40GB) as the slave... very occassionally it works fine but then after say 3 or 4 (if im lucky) restarts it wont recognise either of my HDs until i reboot with just the main HD in i.e. unplug the slave.

Then no matter the settings on the drives ie cable select master/slave for the next 30 - 50 restarts it just wont restart with the slave drive and then suddenly when i decide to try it again a few weeks later it works again for 2-3 restarts.

Im not the best at hardware by a long shot and dont really know what i am doing... but i have tried all configurations on the back master/slave - cable select with master at end of cable etc etc.

This is really starting to annoy me now becasue i neeed the extra space but cant store anything useful on their because i know after a couple of restarts i wont be able to access it for ages.

Please help me out with this guys... ask any questions i will try to answer them best i can
Question by:MattAllen
    LVL 5

    Expert Comment

    Sounds to me like the slave drive is flakey... Try a new hard drive...
    LVL 8

    Expert Comment

    Use the maxtor diagnostics tool and see if it comes up with anything.  The drive probably is flakey and this tool might not reveal any problems, but you could try to switch out the cable too.
    LVL 87

    Accepted Solution

    Check the options in your BIOS settings. Some allow for some timeout so that the HD's have enough time to power up. Your disks just might not be ready because things go too fast. If you can't find such an option try turning off the "Short memory" test. This will make the system take longer to boot because it counts up the RAM, but this extra time should ensure the disks are ready. If neither of these options help and changing the IDE cables don't help either as has been mentioned above, also check the power molex connectors to the disks. If you have other free connectors like that use the others, or another possibility, get a more powerfull PSU.
    LVL 91

    Expert Comment

    to test out the controllers, you could connect the disks to the IDE 1 connector in stead of  IDE 0, and the cd drives to the IDE 0
    LVL 32

    Expert Comment

    I agree with most of the above as well. One additional thing that may cause this is that some drives have motors that "freeze up". When you turn the power on, they either spin normally and work, or the motor can't pick up enough speed and just shuts down. The best way to test this is to open the case and hold the drive in your hand when you apply power.

    In any case if it doesn't turn out to be a cable or jumper problem you'll probably want to replace that drive.
    LVL 2

    Expert Comment

    Faulty IDE cable or power cable (some splitter?), these are the easiest to check. If not, might be the faulty drive. Backup as soon as you can.

    Author Comment

    Thanks for the comments experts,

    Iv switched the both the cables (IDE/Power) and still have the same problem but il try the other suggestions and get back to you all.

    Thanks a lot people
    LVL 11

    Expert Comment

    There are some drives that just don't play well with others.  We had a run of WD's that wouldn't work with anything from Seagate a while back.  They'd work with any other manufacturer's drives, but not Seagate's.  But, only if the WD with the master and the Seagate the slave.  If the roles were reversed, everything worked fine.  

    In other cases, it was simply a matter of upgrading the BIOS, or is even odder cases, stepping the BIOS back a revision or two.  Check the manufacturer's site for updates.

    Good luck.

    Author Comment

    Thanks guys...

    I tred it with a brand new maxtor drive and had same problem...but slowing the boot seems to have worked so far after 5 boots... cheers all
    LVL 87

    Expert Comment

    your welcome

    Featured Post

    Network it in WD Red

    There's an industry-leading WD Red drive for every compatible NAS system to help fulfill your data storage needs. With drives up to 8TB, WD Red offers a wide array of solutions for customers looking to build the biggest, best-performing NAS storage solution.  

    Join & Write a Comment

    Suggested Solutions

    Title # Comments Views Activity
    Host missing from Vcenter 5.5 13 93
    NetAPP FAS3210 4 22
    Netapp Snapshots 3 22
    make a "clean" image windows 7 with paragon 6 27
    If you have a USB Drive that is not recognized by Windows the problem is usually that you have too many network drives or other drives that occupy all the drive letters D: E: or F: which is the normal drive letter of a usb drive. The way to correct …
    A bootable USB key can be very handy now-a-days. My favorite USB key consists of our Windows 7 image, network card drivers (to connect up to a Ghost server), the latest BIOS updates for all of our PCs and CopyWipe (to erase a retired PC) Creating…
    This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
    This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now